summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-01-21 15:31:05 +0000
committerChristian Heim <phreak@gentoo.org>2007-01-21 15:31:05 +0000
commit995beecc8106cf7aa73c324683cd7edc7a71dc53 (patch)
tree58e5f39741e638c2441282cba89afa68a326c305 /dev-libs/apr-util
parentVersion bump (thanks to Conrad Kostecki <ConiKost at gmx.de> in #114232). (diff)
downloadgentoo-2-995beecc8106cf7aa73c324683cd7edc7a71dc53.tar.gz
gentoo-2-995beecc8106cf7aa73c324683cd7edc7a71dc53.tar.bz2
gentoo-2-995beecc8106cf7aa73c324683cd7edc7a71dc53.zip
Version bump (thanks to Conrad Kostecki <ConiKost at gmx.de> in #114232).
(Portage version: 2.1.2-r1)
Diffstat (limited to 'dev-libs/apr-util')
-rw-r--r--dev-libs/apr-util/ChangeLog9
-rw-r--r--dev-libs/apr-util/apr-util-1.2.8.ebuild66
-rw-r--r--dev-libs/apr-util/files/digest-apr-util-1.2.83
3 files changed, 76 insertions, 2 deletions
diff --git a/dev-libs/apr-util/ChangeLog b/dev-libs/apr-util/ChangeLog
index 73b4c50ab80e..9aec7a3db24c 100644
--- a/dev-libs/apr-util/ChangeLog
+++ b/dev-libs/apr-util/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/apr-util
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.66 2006/10/18 16:06:14 uberlord Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.67 2007/01/21 15:31:05 phreak Exp $
+
+*apr-util-1.2.8 (21 Jan 2007)
+
+ 21 Jan 2007; Christian Heim <phreak@gentoo.org> +apr-util-1.2.8.ebuild:
+ Version bump (thanks to Conrad Kostecki <ConiKost at gmx.de> in #114232).
18 Oct 2006; Roy Marples <uberlord@gentoo.org> apr-util-0.9.12.ebuild:
Added ~sparc-fbsd keyword.
diff --git a/dev-libs/apr-util/apr-util-1.2.8.ebuild b/dev-libs/apr-util/apr-util-1.2.8.ebuild
new file mode 100644
index 000000000000..2c636e711447
--- /dev/null
+++ b/dev-libs/apr-util/apr-util-1.2.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.2.8.ebuild,v 1.1 2007/01/21 15:31:05 phreak Exp $
+
+inherit eutils flag-o-matic libtool db-use
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="berkdb gdbm ldap postgres sqlite sqlite3"
+RESTRICT="test"
+
+DEPEND="dev-libs/expat
+ ~dev-libs/apr-${PV}
+ berkdb? ( =sys-libs/db-4* )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( =net-nds/openldap-2* )
+ postgres? ( dev-db/postgresql )
+ sqlite? ( =dev-db/sqlite-2* )
+ sqlite3? ( =dev-db/sqlite-3* )"
+
+# NOTE: This package in theory can support mysql,
+# but in reality the build system is broken for it....
+
+src_compile() {
+ local myconf=""
+
+ elibtoolize || die "elibtoolize failed"
+
+ use ldap && myconf="${myconf} --with-ldap"
+
+ if use berkdb; then
+ dbver="$(db_findver sys-libs/db)" || die "Unable to find db version"
+ dbver="$(db_ver_to_slot "$dbver")"
+ dbver="${dbver/\./}"
+ myconf="${myconf} --with-dbm=db${dbver}
+ --with-berkeley-db=$(db_includedir):/usr/$(get_libdir)"
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ econf --datadir=/usr/share/apr-util-1 \
+ --with-apr=/usr \
+ --with-expat=/usr \
+ $(use_with gdbm) \
+ $(use_with postgres pgsql) \
+ $(use_with sqlite sqlite2) \
+ $(use_with sqlite3) \
+ ${myconf} || die "econf failed!"
+
+ emake || die "emake failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc CHANGES NOTICE
+
+ # This file is only used on AIX systems, which gentoo is not,
+ # and causes collisions between the SLOTs, so kill it
+ rm "${D}"/usr/$(get_libdir)/aprutil.exp
+} \ No newline at end of file
diff --git a/dev-libs/apr-util/files/digest-apr-util-1.2.8 b/dev-libs/apr-util/files/digest-apr-util-1.2.8
new file mode 100644
index 000000000000..bf335ad4a8f2
--- /dev/null
+++ b/dev-libs/apr-util/files/digest-apr-util-1.2.8
@@ -0,0 +1,3 @@
+MD5 a2e2e54d65e9eae961f7171335cf2550 apr-util-1.2.8.tar.gz 646379
+RMD160 00b10ef0aab26f3ea5d374e2400c1dba566a9020 apr-util-1.2.8.tar.gz 646379
+SHA256 6527cb0b3dd619acfca668412e84e52860dfd862054246ca903822d5ea824de6 apr-util-1.2.8.tar.gz 646379