summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-01-28 21:28:13 +0000
committerChristian Heim <phreak@gentoo.org>2007-01-28 21:28:13 +0000
commit9ec61e1040afe749ff99d041b785f68dd2cb27c0 (patch)
tree69e5368342a4c046b0d0794c4a897aed74538b92 /dev-libs/apr-util
parentVersion bump, new upstream version. Cleaning up the ebuild a bit. (diff)
downloadgentoo-2-9ec61e1040afe749ff99d041b785f68dd2cb27c0.tar.gz
gentoo-2-9ec61e1040afe749ff99d041b785f68dd2cb27c0.tar.bz2
gentoo-2-9ec61e1040afe749ff99d041b785f68dd2cb27c0.zip
Version bump, new upstream version. Cleaning up the ebuild a bit.
(Portage version: 2.1.2-r4)
Diffstat (limited to 'dev-libs/apr-util')
-rw-r--r--dev-libs/apr-util/ChangeLog7
-rw-r--r--dev-libs/apr-util/apr-util-0.9.13.ebuild72
-rw-r--r--dev-libs/apr-util/files/digest-apr-util-0.9.133
3 files changed, 81 insertions, 1 deletions
diff --git a/dev-libs/apr-util/ChangeLog b/dev-libs/apr-util/ChangeLog
index 7d143a87dcb1..5e929e8ec193 100644
--- a/dev-libs/apr-util/ChangeLog
+++ b/dev-libs/apr-util/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/apr-util
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.68 2007/01/28 20:06:37 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.69 2007/01/28 21:28:13 phreak Exp $
+
+*apr-util-0.9.13 (28 Jan 2007)
+
+ 28 Jan 2007; Christian Heim <phreak@gentoo.org> +apr-util-0.9.13.ebuild:
+ Version bump, new upstream version. Cleaning up the ebuild a bit.
28 Jan 2007; Luca Longinotti <chtekk@gentoo.org>
-files/apr-util-0.9.x-161086-161087.patch, metadata.xml,
diff --git a/dev-libs/apr-util/apr-util-0.9.13.ebuild b/dev-libs/apr-util/apr-util-0.9.13.ebuild
new file mode 100644
index 000000000000..d6225b54c1a0
--- /dev/null
+++ b/dev-libs/apr-util/apr-util-0.9.13.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-0.9.13.ebuild,v 1.1 2007/01/28 21:28:13 phreak Exp $
+
+inherit eutils flag-o-matic libtool db-use
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc-macos ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="berkdb gdbm ldap"
+RESTRICT="test"
+
+DEPEND="dev-libs/expat
+ ~dev-libs/apr-${PV}
+ berkdb? ( =sys-libs/db-4* )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( =net-nds/openldap-2* )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/apr-util-0.9.12-linking.patch
+ elibtoolize || die "elibtoolize failed"
+}
+
+
+src_compile() {
+ local myconf=""
+
+ use ldap && myconf="${myconf} --with-ldap"
+ myconf="${myconf} $(use_with gdbm)"
+
+ if use berkdb; then
+ dbver="$(db_findver sys-libs/db)" || die "Unable to find db version"
+ dbver="$(db_ver_to_slot "$dbver")"
+ dbver="${dbver/\./}"
+ myconf="${myconf} --with-dbm=db${dbver}
+ --with-berkeley-db=$(db_includedir):/usr/$(get_libdir)"
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ econf \
+ --datadir=/usr/share/apr-util-0 \
+ --with-apr=/usr \
+ --with-expat=/usr \
+ $myconf || die "econf failed!"
+
+ emake || die "emake failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" installbuilddir=/usr/share/apr-util-0/build install || die "make install failed!"
+
+ #bogus values pointing at /var/tmp/portage
+ sed -i -e 's:APU_SOURCE_DIR=.*:APU_SOURCE_DIR=:g' "${D}"/usr/bin/apu-config
+ sed -i -e 's:APU_BUILD_DIR=.*:APU_BUILD_DIR=/usr/share/apr-util-0/build:g' "${D}"/usr/bin/apu-config
+
+ dodoc CHANGES NOTICE
+
+ # Will install as portage user when using userpriv. Fixing
+ chown -R root:0 "${D}"/usr/include/apr-0/
+
+ # This file is only used on AIX systems, which gentoo is not,
+ # and causes collisions between the SLOTs, so kill it
+ rm "${D}"/usr/$(get_libdir)/aprutil.exp
+}
diff --git a/dev-libs/apr-util/files/digest-apr-util-0.9.13 b/dev-libs/apr-util/files/digest-apr-util-0.9.13
new file mode 100644
index 000000000000..fe458f30ff67
--- /dev/null
+++ b/dev-libs/apr-util/files/digest-apr-util-0.9.13
@@ -0,0 +1,3 @@
+MD5 31e3881af0d9546286b0057717cdb89b apr-util-0.9.13.tar.gz 593575
+RMD160 34d6e517de6cb64e0b1aef45a99ee64f9ceba130 apr-util-0.9.13.tar.gz 593575
+SHA256 8c5a2c9e0434a391360bbf3573a403a3f4f326d1b562f64276cbd4f92066da7f apr-util-0.9.13.tar.gz 593575