summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-06-08 22:22:15 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2015-06-08 22:22:15 +0000
commite07c60371200f907f505872c28df8ceca041deaf (patch)
tree50b7824527ce9ce739a39201602d5d2be678ba44 /dev-libs/atk
parentVersion bump for Gnome 3.16. (diff)
downloadgentoo-2-e07c60371200f907f505872c28df8ceca041deaf.tar.gz
gentoo-2-e07c60371200f907f505872c28df8ceca041deaf.tar.bz2
gentoo-2-e07c60371200f907f505872c28df8ceca041deaf.zip
Version bump for Gnome 3.16.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-libs/atk')
-rw-r--r--dev-libs/atk/ChangeLog7
-rw-r--r--dev-libs/atk/atk-2.16.0.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-libs/atk/ChangeLog b/dev-libs/atk/ChangeLog
index 118430c497e3..096f3bb93ca7 100644
--- a/dev-libs/atk/ChangeLog
+++ b/dev-libs/atk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/atk
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/ChangeLog,v 1.305 2015/06/07 10:26:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/ChangeLog,v 1.306 2015/06/08 22:22:15 eva Exp $
+
+*atk-2.16.0 (08 Jun 2015)
+
+ 08 Jun 2015; Gilles Dartiguelongue <eva@gentoo.org> +atk-2.16.0.ebuild:
+ Version bump for Gnome 3.16.
07 Jun 2015; Markus Meier <maekke@gentoo.org> atk-2.14.0.ebuild:
arm stable, bug #534012
diff --git a/dev-libs/atk/atk-2.16.0.ebuild b/dev-libs/atk/atk-2.16.0.ebuild
new file mode 100644
index 000000000000..546409d5b6b4
--- /dev/null
+++ b/dev-libs/atk/atk-2.16.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-2.16.0.ebuild,v 1.1 2015/06/08 22:22:15 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="http://projects.gnome.org/accessibility/"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="+introspection nls test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-util/gtk-doc-am
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests (bug #226353)
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection)
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/html docs/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}