summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-01-27 00:28:48 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-01-27 00:28:48 +0000
commitf243d6cc2b9b9964d329ce6afa5c113cb918c261 (patch)
tree3b5a65b3aef68f1bd05cb5a4201745550c9af7d6 /dev-libs/atlas
parentcleaned up some left-over comments (diff)
downloadgentoo-2-f243d6cc2b9b9964d329ce6afa5c113cb918c261.tar.gz
gentoo-2-f243d6cc2b9b9964d329ce6afa5c113cb918c261.tar.bz2
gentoo-2-f243d6cc2b9b9964d329ce6afa5c113cb918c261.zip
Atlas library ebuild submitted by tneidt@fidnet.com (Tod M. Neidt)
Diffstat (limited to 'dev-libs/atlas')
-rw-r--r--dev-libs/atlas/atlas-3.2.1.ebuild65
-rw-r--r--dev-libs/atlas/files/digest-atlas-3.2.11
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/atlas/atlas-3.2.1.ebuild b/dev-libs/atlas/atlas-3.2.1.ebuild
new file mode 100644
index 000000000000..e2768db6991c
--- /dev/null
+++ b/dev-libs/atlas/atlas-3.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+S=${WORKDIR}/ATLAS
+DESCRIPTION="Automatically Tuned Linear Algebra Software (BLAS implementation)."
+SRC_URI="http://www.netlib.org/atlas/${PN}${PV}.tgz"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+#Make is actually an interactive configuration step.
+#The configuration is highly sensitive to your specific machine.
+#Although it is quite good, it will default to accuracy over speed.
+#Powertweakers might want to configure interactively (also for cross-compile)
+# by uncommenting the next line and commenting the yes ""| make || die line .
+# make || die
+
+#atlas will automatically do a parallel make if possible.
+ yes "" | make || die
+
+#Let's go grab the architecture determined by the configure
+ cd ${S}/bin
+
+#There might be a better way to do this!?!
+#We can assume "Linux" for a Gentoo Linux system.
+#Need ATLAS_ARCH in src_install too.
+ ATLAS_ARCH=$(ls -d Linux*)
+
+ cd ${S}
+#This doesn't install into the live / file system.
+#It installs into ${S}/lib/Linux*
+ make install arch=${ATLAS_ARCH} || die
+
+}
+
+src_install () {
+
+ cd ${S}/lib/${ATLAS_ARCH}
+
+ insinto /usr/lib
+ dolib.a libatlas.a libcblas.a libf77blas.a libtstatlas.a
+
+#the atlas liblapack.a library is not a complete lapack library,
+#just the atlas optimizable objects. Store it some place safe
+#where we can grab it when building the complete lapack library.
+ insinto /usr/share/${PN}
+ doins liblapack.a
+
+ cd ${S}/include/${ATLAS_ARCH}
+
+ insinto /usr/include
+ doins *.h
+
+ cd ${S}
+
+ dodoc README INSTALL.txt
+ dodoc doc/*.txt
+ insinto /usr/share/doc/${P}/ps
+ doins doc/*.ps
+ dodoc bin/${ATLAS_ARCH}/INSTALL_LOG/SUMMARY.LOG
+}
diff --git a/dev-libs/atlas/files/digest-atlas-3.2.1 b/dev-libs/atlas/files/digest-atlas-3.2.1
new file mode 100644
index 000000000000..721df35be1bb
--- /dev/null
+++ b/dev-libs/atlas/files/digest-atlas-3.2.1
@@ -0,0 +1 @@
+MD5 713784ea1a5f3ac5b0837a79bbbe1089 atlas3.2.1.tgz 2088960