summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-24 23:07:36 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-24 23:07:36 +0000
commit901a22c7f0215ccbcf2418e50d4b4fb826ecc7f0 (patch)
tree4b26e56c1eed364f67230590b0334907fc1690f1 /dev-libs/beecrypt
parentadded pre16 for 2.6 kernels (temporary work-around in ewarn) (diff)
downloadgentoo-2-901a22c7f0215ccbcf2418e50d4b4fb826ecc7f0.tar.gz
gentoo-2-901a22c7f0215ccbcf2418e50d4b4fb826ecc7f0.tar.bz2
gentoo-2-901a22c7f0215ccbcf2418e50d4b4fb826ecc7f0.zip
added patch for python2.3, thanks to Vaclav Slavik (#39282)
Diffstat (limited to 'dev-libs/beecrypt')
-rw-r--r--dev-libs/beecrypt/ChangeLog7
-rw-r--r--dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild6
-rw-r--r--dev-libs/beecrypt/files/beecrypt-3.1.0-python2.3.patch25
3 files changed, 35 insertions, 3 deletions
diff --git a/dev-libs/beecrypt/ChangeLog b/dev-libs/beecrypt/ChangeLog
index da3e5a3ed903..a26354f404cf 100644
--- a/dev-libs/beecrypt/ChangeLog
+++ b/dev-libs/beecrypt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/beecrypt
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/ChangeLog,v 1.11 2004/01/15 19:02:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/ChangeLog,v 1.12 2004/01/24 23:07:36 liquidx Exp $
+
+ 24 Jan 2004; Alastair Tse <liquidx@gentoo.org> beecrypt-3.1.0-r1.ebuild,
+ files/beecrypt-3.1.0-python2.3.patch:
+ added patch for python2.3, thanks to Vaclav Slavik <vaclav.slavik@matfyz.cz>
+ (#39282)
15 Jan 2004; <agriffis@gentoo.org> beecrypt-3.1.0-r1.ebuild:
stable on alpha and ia64
diff --git a/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild b/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
index fdfda1a1d649..f55851bc23d7 100644
--- a/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
+++ b/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild,v 1.5 2004/01/15 19:02:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild,v 1.6 2004/01/24 23:07:36 liquidx Exp $
DESCRIPTION="Beecrypt is a general-purpose cryptography library."
HOMEPAGE="http://sourceforge.net/projects/beecrypt"
@@ -10,7 +10,7 @@ LICENSE="LGPL-2"
KEYWORDS="~x86 ~ppc ~sparc alpha ~amd64 ia64"
SLOT="0"
-DEPEND="python? ( =dev-lang/python-2.2* )
+DEPEND="python? ( >=dev-lang/python-2.2 )
!<app-arch/rpm-4.2.1"
IUSE="python"
@@ -28,6 +28,8 @@ src_unpack() {
# (11 Nov 2003 agriffis)
epatch ${FILESDIR}/beecrypt-3.1.0-alpha.patch
fi
+ # fix for python paths (#39282)
+ epatch ${FILESDIR}/beecrypt-3.1.0-python2.3.patch
}
src_compile() {
diff --git a/dev-libs/beecrypt/files/beecrypt-3.1.0-python2.3.patch b/dev-libs/beecrypt/files/beecrypt-3.1.0-python2.3.patch
new file mode 100644
index 000000000000..7b92fdecfe0e
--- /dev/null
+++ b/dev-libs/beecrypt/files/beecrypt-3.1.0-python2.3.patch
@@ -0,0 +1,25 @@
+diff -ru beecrypt.orig/python/Makefile.in beecrypt/python/Makefile.in
+--- beecrypt.orig/python/Makefile.in 2003-08-17 08:57:46.000000000 +0200
++++ beecrypt/python/Makefile.in 2004-01-24 21:32:32.000000000 +0100
+@@ -163,11 +163,11 @@
+
+ LINT = splint
+
+-PYVER = 2.2
++PYVER = $(shell python -c 'import sys; print ".".join(sys.version.split()[0].split(".")[0:2])')
+
+ SUBDIRS = test
+
+-pylibdir = $(shell python -c 'import sys; print sys.path[1]')
++pythondir = $(shell python -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1,0)')
+ pyincdir = $(prefix)/include/python${PYVER}
+
+ EXTRA_DIST = debug-py.c
+@@ -183,7 +183,6 @@
+
+ LDADD =
+
+-pythondir = $(pylibdir)/site-packages
+ python_LTLIBRARIES = _bc.la
+
+ _bc_la_SOURCES = _bc-py.c mpw-py.c rng-py.c