summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-13 18:56:12 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-13 18:56:12 +0000
commit802ad0607cf0b088d5ba9b6b6692f2b239b52533 (patch)
tree3c30a41bbc781815bf7d2afd00038df085c06db1 /dev-libs/boehm-gc
parentAdd qt4 use dependency on poppler. Bug #378381 (diff)
downloadgentoo-2-802ad0607cf0b088d5ba9b6b6692f2b239b52533.tar.gz
gentoo-2-802ad0607cf0b088d5ba9b6b6692f2b239b52533.tar.bz2
gentoo-2-802ad0607cf0b088d5ba9b6b6692f2b239b52533.zip
Convert USE=nocxx to USE=cxx.
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/boehm-gc')
-rw-r--r--dev-libs/boehm-gc/ChangeLog7
-rw-r--r--dev-libs/boehm-gc/boehm-gc-6.8.ebuild25
-rw-r--r--dev-libs/boehm-gc/boehm-gc-7.0-r1.ebuild23
-rw-r--r--dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild23
-rw-r--r--dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild18
5 files changed, 28 insertions, 68 deletions
diff --git a/dev-libs/boehm-gc/ChangeLog b/dev-libs/boehm-gc/ChangeLog
index 8be9f31052dc..152f5f8116ed 100644
--- a/dev-libs/boehm-gc/ChangeLog
+++ b/dev-libs/boehm-gc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/boehm-gc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/ChangeLog,v 1.77 2011/03/04 14:59:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/ChangeLog,v 1.78 2011/11/13 18:56:12 vapier Exp $
+
+ 13 Nov 2011; Mike Frysinger <vapier@gentoo.org> boehm-gc-6.8.ebuild,
+ boehm-gc-7.0-r1.ebuild, boehm-gc-7.1-r1.ebuild,
+ boehm-gc-7.2_alpha4-r1.ebuild:
+ Convert USE=nocxx to USE=cxx.
*boehm-gc-7.2_alpha4-r1 (04 Mar 2011)
*boehm-gc-7.1-r1 (04 Mar 2011)
diff --git a/dev-libs/boehm-gc/boehm-gc-6.8.ebuild b/dev-libs/boehm-gc/boehm-gc-6.8.ebuild
index 08e508045307..1bc0dec07567 100644
--- a/dev-libs/boehm-gc/boehm-gc-6.8.ebuild
+++ b/dev-libs/boehm-gc/boehm-gc-6.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-6.8.ebuild,v 1.10 2009/09/23 17:16:29 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-6.8.ebuild,v 1.11 2011/11/13 18:56:12 vapier Exp $
inherit eutils
@@ -14,12 +14,7 @@ SRC_URI="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/${MY_P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE="nocxx threads"
-
-RDEPEND=""
-
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+IUSE="cxx threads"
src_unpack() {
unpack ${A}
@@ -30,17 +25,9 @@ src_unpack() {
}
src_compile() {
- local myconf=""
-
- if use nocxx ; then
- myconf="${myconf} --disable-cplusplus"
- else
- myconf="${myconf} --enable-cplusplus"
- fi
-
- use threads || myconf="${myconf} --disable-threads"
-
- econf ${myconf} || die "Configure failed..."
+ econf \
+ $(use_enable cxx cplusplus) \
+ $(use threads || echo --disable-threads)
emake || die
}
diff --git a/dev-libs/boehm-gc/boehm-gc-7.0-r1.ebuild b/dev-libs/boehm-gc/boehm-gc-7.0-r1.ebuild
index fe24bae8e780..f00945647437 100644
--- a/dev-libs/boehm-gc/boehm-gc-7.0-r1.ebuild
+++ b/dev-libs/boehm-gc/boehm-gc-7.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-7.0-r1.ebuild,v 1.3 2011/03/04 14:59:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-7.0-r1.ebuild,v 1.4 2011/11/13 18:56:12 vapier Exp $
inherit eutils
@@ -14,12 +14,7 @@ SRC_URI="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/${MY_P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="nocxx threads"
-
-RDEPEND=""
-
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+IUSE="cxx threads"
src_unpack() {
unpack ${A}
@@ -31,17 +26,9 @@ src_unpack() {
}
src_compile() {
- local myconf=""
-
- if use nocxx ; then
- myconf="${myconf} --disable-cplusplus"
- else
- myconf="${myconf} --enable-cplusplus"
- fi
-
- use threads || myconf="${myconf} --disable-threads"
-
- econf ${myconf}
+ econf \
+ $(use_enable cxx cplusplus) \
+ $(use threads || echo --disable-threads)
emake || die
}
diff --git a/dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild b/dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild
index e981dfbbae9e..f3bae3307e89 100644
--- a/dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild
+++ b/dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild,v 1.1 2011/03/04 14:59:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild,v 1.2 2011/11/13 18:56:12 vapier Exp $
inherit eutils
@@ -14,12 +14,7 @@ SRC_URI="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/${MY_P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="alpha amd64 ~arm ~hppa ~ia64 ppc ppc64 ~sparc x86"
-IUSE="nocxx threads"
-
-RDEPEND=""
-
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+IUSE="cxx threads"
src_unpack() {
unpack ${A}
@@ -31,17 +26,9 @@ src_unpack() {
}
src_compile() {
- local myconf=""
-
- if use nocxx ; then
- myconf="${myconf} --disable-cplusplus"
- else
- myconf="${myconf} --enable-cplusplus"
- fi
-
- use threads || myconf="${myconf} --disable-threads"
-
- econf ${myconf}
+ econf \
+ $(use_enable cxx cplusplus) \
+ $(use threads || echo --disable-threads)
emake || die
}
diff --git a/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild b/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild
index 12277d02b216..fc750ab25f57 100644
--- a/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild
+++ b/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild,v 1.1 2011/03/04 14:59:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild,v 1.2 2011/11/13 18:56:12 vapier Exp $
inherit eutils
@@ -14,24 +14,18 @@ SRC_URI="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/${MY_P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="nocxx threads"
+IUSE="cxx threads"
DEPEND="dev-libs/libatomic_ops"
RDEPEND="${DEPEND}"
src_compile() {
sed '/Cflags/s:$:/gc:g' -i bdw-gc.pc.in || die
- local myconf="--with-libatomic-ops=yes"
- if use nocxx ; then
- myconf="${myconf} --disable-cplusplus"
- else
- myconf="${myconf} --enable-cplusplus"
- fi
-
- use threads || myconf="${myconf} --disable-threads"
-
- econf ${myconf}
+ econf \
+ --with-libatomic-ops=yes \
+ $(use_enable cxx cplusplus) \
+ $(use threads || echo --disable-threads)
emake || die
}