summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2004-02-03 07:55:10 +0000
committerGeorge Shapovalov <george@gentoo.org>2004-02-03 07:55:10 +0000
commit4025572aac6d009e20cddd80bed254ed5ecf2f95 (patch)
tree0452e56fd16a56ab7f770046f12630191a272506 /dev-libs/boost
parent (Manifest recommit) (diff)
downloadgentoo-2-4025572aac6d009e20cddd80bed254ed5ecf2f95.tar.gz
gentoo-2-4025572aac6d009e20cddd80bed254ed5ecf2f95.tar.bz2
gentoo-2-4025572aac6d009e20cddd80bed254ed5ecf2f95.zip
new snapshot and a fix for src_install
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog8
-rw-r--r--dev-libs/boost/boost-1.30.2.ebuild4
-rw-r--r--dev-libs/boost/boost-1.31.0_alpha1.ebuild4
-rw-r--r--dev-libs/boost/boost-1.31.0_alpha2.ebuild115
-rw-r--r--dev-libs/boost/files/digest-boost-1.31.0_alpha21
5 files changed, 127 insertions, 5 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 4fec7ba21d14..56cf4538e52c 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.7 2003/12/19 16:44:07 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.8 2004/02/03 07:55:10 george Exp $
+
+*boost-1.31.0_alpha2 (02 Feb 2004)
+
+ 02 Feb 2004; George Shapovalov <george@gentoo.org> boost-1.31.0_alpha2.ebuild :
+ new cvs snapshot, fixed the install procedure following the #37850,
+ thanks to Karl-Johan Karlsson <creideiki+gentoo-bugzilla@lisator.liu.se> for suggestions
*boost-1.31.0_alpha1 (18 Dec 2003)
diff --git a/dev-libs/boost/boost-1.30.2.ebuild b/dev-libs/boost/boost-1.30.2.ebuild
index 153a7ded7129..fa8b39ba7e8a 100644
--- a/dev-libs/boost/boost-1.30.2.ebuild
+++ b/dev-libs/boost/boost-1.30.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.30.2.ebuild,v 1.1 2003/08/25 00:58:12 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.30.2.ebuild,v 1.2 2004/02/03 07:55:10 george Exp $
DESCRIPTION="Boost provides free peer-reviewed portable C++ source libraries."
HOMEPAGE="http://www.boost.org"
diff --git a/dev-libs/boost/boost-1.31.0_alpha1.ebuild b/dev-libs/boost/boost-1.31.0_alpha1.ebuild
index b80eac4019f4..82a58855a7ea 100644
--- a/dev-libs/boost/boost-1.31.0_alpha1.ebuild
+++ b/dev-libs/boost/boost-1.31.0_alpha1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.31.0_alpha1.ebuild,v 1.2 2004/01/06 16:36:23 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.31.0_alpha1.ebuild,v 1.3 2004/02/03 07:55:10 george Exp $
MyPV="2003d18"
diff --git a/dev-libs/boost/boost-1.31.0_alpha2.ebuild b/dev-libs/boost/boost-1.31.0_alpha2.ebuild
new file mode 100644
index 000000000000..adb41b92f21f
--- /dev/null
+++ b/dev-libs/boost/boost-1.31.0_alpha2.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.31.0_alpha2.ebuild,v 1.1 2004/02/03 07:55:10 george Exp $
+
+MyPV="2004202"
+
+DESCRIPTION="Boost provides free peer-reviewed portable C++ source libraries."
+HOMEPAGE="http://www.boost.org"
+#SRC_URI="http://easynews.dl.sourceforge.net/sourceforge/boost/boost-${PV}.tar.bz2"
+SRC_URI="mirror://gentoo/${PN}-${MyPV}.tar.bz2"
+
+S=${WORKDIR}/${PN}
+
+LICENSE="freedist"
+KEYWORDS="~x86 ~ppc ~amd64"
+SLOT="1"
+IUSE="icc"
+
+# This would be a good place for someone to figure out how to get
+# boost to build nicely with icc, as it's documented to be doable.
+
+DEPEND="virtual/glibc"
+RDEPEND=">=dev-util/yacc-1.9.1-r1
+ >=dev-lang/python-2.2.1
+ icc? ( >=dev-lang/icc-7.1 )"
+
+src_compile() {
+ local PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | sed 's/Python \([0-9][0-9]*\.[0-9][0-9]*\)\..*/\1/')
+ local BOOST_TOOLSET
+ local arch
+
+ if [ "`use icc`" ] ; then
+ BOOST_TOOLSET="intel-linux"
+ else
+ BOOST_TOOLSET="gcc"
+ fi
+
+ # Build bjam, a jam variant, which is used instead of make
+ cd ${S}/tools/build/jam_src
+ ./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
+ cd ${S}
+
+ if [ "${ARCH}" == "amd64" ]; then
+ arch=
+ else
+ arch=${ARCH}
+ fi
+
+ if [ "`use icc`" ] ; then
+ ./tools/build/jam_src/bin.linux${arch}/bjam -j2 \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sINTEL_LINUX_VERSION="70" || die "Failed to build boost libraries."
+ else
+ ./tools/build/jam_src/bin.linux${arch}/bjam ${MAKEOPTS} \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET}
+
+ einfo "Don't worry if there are a few (probably 6) failures above."
+ einfo "Some targets merely need to be combined. Here goes:"
+
+ ./tools/build/jam_src/bin.linux${arch}/bjam \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET} || die "Failed to build boost libraries."
+ fi
+}
+
+src_install () {
+ # Unfortunately boost doesn't provide a standard way to
+ # install itself. So it's done "manually" here.
+
+ # install libraries
+ find bin/boost/libs -type f -name \*.a -exec dolib.a {} \;
+ find bin/boost/libs -type f -name "*.so*" -exec dolib.so {} \;
+
+ # install source/header files
+
+ find boost -type f \
+ -exec install -D -m0644 {} ${D}/usr/include/{} \;
+
+ # install build tools
+ cd tools/build
+ #do_whatever is too limiting here, need to move bunch of different stuff recursively
+ dodir /usr/share/${PN}
+ cp -a b* c* index.html v1/ v2/ ${D}/usr/share/${PN}
+ cd ${S}
+
+ # install documentation
+ dodoc README
+ dohtml index.htm google_logo_40wht.gif c++boost.gif boost.css
+ dohtml -A pdf -r more
+ dohtml -r people
+ dohtml -r doc
+
+ find libs -type f -not -regex '^libs/[^/]*/build/.*' \
+ -and -not -regex '^libs/.*/test[^/]?/.*' \
+ -and -not -regex '^libs/.*/bench[^/]?/.*' \
+ -and -not -regex '^libs/[^/]*/tools/.*' \
+ -and -not -name \*.bat \
+ -and -not -name Jamfile\* \
+ -and -not -regex '^libs/[^/]*/src/.*' \
+ -and -not -iname makefile \
+ -and -not -name \*.mak \
+ -and -not -name .\* \
+ -and -not -name \*.dsw \
+ -and -not -name \*.dsp \
+ -exec \
+ install -D -m0644 \{\} ${D}/usr/share/doc/${P}/html/\{\} \;
+}
diff --git a/dev-libs/boost/files/digest-boost-1.31.0_alpha2 b/dev-libs/boost/files/digest-boost-1.31.0_alpha2
new file mode 100644
index 000000000000..fa5bf0c56ed3
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.31.0_alpha2
@@ -0,0 +1 @@
+MD5 5c013e8af25cafc0f6e6dbc40d3b6244 boost-2004202.tar.bz2 7389870