summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-08-04 13:39:55 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-08-04 13:39:55 +0000
commit93c46fc07beb57efa86e0db0289603227799fd45 (patch)
treeb5ea981155c5d5f32ec55a1e846168a1d56bf1ff /dev-libs/boost
parentStable for amd64, wrt bug #428326 (diff)
downloadgentoo-2-93c46fc07beb57efa86e0db0289603227799fd45.tar.gz
gentoo-2-93c46fc07beb57efa86e0db0289603227799fd45.tar.bz2
gentoo-2-93c46fc07beb57efa86e0db0289603227799fd45.zip
Apply gcc-4.7 patch for boost-1.48. Bug #407761. Thanks to Dennis 'dlan' Lan <dennis.yxun@gmail.com>
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog7
-rw-r--r--dev-libs/boost/boost-1.48.0-r2.ebuild3
-rw-r--r--dev-libs/boost/files/boost-1.48.0-gcc47.patch14
3 files changed, 22 insertions, 2 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 5fe9ffaf15dd..7a38700a04fa 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.254 2012/07/21 17:18:43 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.255 2012/08/04 13:39:55 hwoarang Exp $
+
+ 04 Aug 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/boost-1.48.0-gcc47.patch, boost-1.48.0-r2.ebuild:
+ Apply gcc-4.7 patch for boost-1.48. Bug #407761. Thanks to Dennis 'dlan' Lan
+ <dennis.yxun@gmail.com>
21 Jul 2012; Jeroen Roovers <jer@gentoo.org> boost-1.49.0-r1.ebuild:
Stable for HPPA (bug #425354).
diff --git a/dev-libs/boost/boost-1.48.0-r2.ebuild b/dev-libs/boost/boost-1.48.0-r2.ebuild
index 737bab2f7d22..3e539f09e2a3 100644
--- a/dev-libs/boost/boost-1.48.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.48.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.48.0-r2.ebuild,v 1.7 2012/06/14 18:48:26 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.48.0-r2.ebuild,v 1.8 2012/08/04 13:39:55 hwoarang Exp $
EAPI="4"
PYTHON_DEPEND="python? *"
@@ -126,6 +126,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-python_linking.patch"
epatch "${FILESDIR}/${P}-disable_icu_rpath.patch"
epatch "${FILESDIR}/remove-toolset-${PV}.patch"
+ epatch "${FILESDIR}/${P}-gcc47.patch"
}
src_configure() {
diff --git a/dev-libs/boost/files/boost-1.48.0-gcc47.patch b/dev-libs/boost/files/boost-1.48.0-gcc47.patch
new file mode 100644
index 000000000000..a7caebcbe7dd
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.48.0-gcc47.patch
@@ -0,0 +1,14 @@
+diff --git a/boost/config/stdlib/libstdcpp3.hpp b/boost/config/stdlib/libstdcpp3.hpp
+index 52d5837..aaa8890 100644
+--- a/boost/config/stdlib/libstdcpp3.hpp
++++ b/boost/config/stdlib/libstdcpp3.hpp
+@@ -33,7 +33,8 @@
+
+ #ifdef __GLIBCXX__ // gcc 3.4 and greater:
+ # if defined(_GLIBCXX_HAVE_GTHR_DEFAULT) \
+- || defined(_GLIBCXX__PTHREADS)
++ || defined(_GLIBCXX__PTHREADS) \
++ || defined(_GLIBCXX_HAS_GTHREADS)
+ //
+ // If the std lib has thread support turned on, then turn it on in Boost
+ // as well. We do this because some gcc-3.4 std lib headers define _REENTANT