summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-02-20 22:11:11 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-02-20 22:11:11 +0000
commitf858ca50d4981ad7f6b8b1ab1d57cb65cfab3ff7 (patch)
tree933f15b059822df730b0fce9324fab6553b60322 /dev-libs/botan/botan-1.5.5.ebuild
parentMarked ~alpha (bug #122726) (diff)
downloadgentoo-2-f858ca50d4981ad7f6b8b1ab1d57cb65cfab3ff7.tar.gz
gentoo-2-f858ca50d4981ad7f6b8b1ab1d57cb65cfab3ff7.tar.bz2
gentoo-2-f858ca50d4981ad7f6b8b1ab1d57cb65cfab3ff7.zip
Clean up leading whitespaces, add additional quoting, and drop the virtual/libc dep
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-libs/botan/botan-1.5.5.ebuild')
-rw-r--r--dev-libs/botan/botan-1.5.5.ebuild88
1 files changed, 44 insertions, 44 deletions
diff --git a/dev-libs/botan/botan-1.5.5.ebuild b/dev-libs/botan/botan-1.5.5.ebuild
index 7ebccf907ffb..85a56a764409 100644
--- a/dev-libs/botan/botan-1.5.5.ebuild
+++ b/dev-libs/botan/botan-1.5.5.ebuild
@@ -1,5 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+# $Header $
# Comments/fixes to lloyd@randombit.net (author)
@@ -14,66 +15,65 @@ IUSE="bzip2 gmp ssl zlib"
S="${WORKDIR}/Botan-${PV}"
-RDEPEND="virtual/libc
- bzip2? ( >=app-arch/bzip2-1.0.1 )
- zlib? ( >=sys-libs/zlib-1.1.4 )
- gmp? ( >=dev-libs/gmp-4.1.2 )
- ssl? ( >=dev-libs/openssl-0.9.7d )"
+RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.1 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ gmp? ( >=dev-libs/gmp-4.1.2 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )"
# configure.pl requires DirHandle, Getopt::Long, File::Spec, and File::Copy;
# all seem included in dev-lang/perl ATM.
DEPEND="${RDEPEND}
- dev-lang/perl"
+ dev-lang/perl"
src_compile() {
- # Modules that should work under any semi-recent Unix
- local modules="alloc_mmap,es_egd,es_ftw,es_unix,fd_unix,ml_unix,tm_unix,tm_posix,mux_pthr"
+ # Modules that should work under any semi-recent Unix
+ local modules="alloc_mmap,es_egd,es_ftw,es_unix,fd_unix,ml_unix,tm_unix,tm_posix,mux_pthr"
- if useq bzip2; then modules="$modules,comp_bzip2"; fi
- if useq zlib; then modules="$modules,comp_zlib"; fi
- if useq gmp; then modules="$modules,eng_gmp"; fi
- if useq ssl; then modules="$modules,eng_ossl"; fi
+ if useq bzip2; then modules="$modules,comp_bzip2"; fi
+ if useq zlib; then modules="$modules,comp_zlib"; fi
+ if useq gmp; then modules="$modules,eng_gmp"; fi
+ if useq ssl; then modules="$modules,eng_ossl"; fi
- # This is also supported on i586+ - hope this is correct.
- # documention says sparc though not enables because of
- # http://bugs.gentoo.org/show_bug.cgi?id=71760#c11
- if [ ${ARCH} = 'alpha' -o ${ARCH} = 'amd64' ] || \
- [ ${ARCH} = 'x86' -a ${CHOST:0:4} != "i386" -a ${CHOST:0:4} != "i486" ]; then
- modules="$modules,tm_hard"
- fi
+ # This is also supported on i586+ - hope this is correct.
+ # documention says sparc though not enables because of
+ # http://bugs.gentoo.org/show_bug.cgi?id=71760#c11
+ if [ ${ARCH} = 'alpha' -o ${ARCH} = 'amd64' ] || \
+ [ ${ARCH} = 'x86' -a ${CHOST:0:4} != "i386" -a ${CHOST:0:4} != "i486" ]; then
+ modules="$modules,tm_hard"
+ fi
- # If we have assembly code for this machine, use it
- if [ "${ARCH}" = 'x86' ]; then
- modules="$modules,mp_ia32"
- elif [ "${ARCH}" = 'amd64' ]; then
- modules="$modules,mp_amd64"
- elif [ "${ARCH}" = 'alpha' -o "${ARCH}" = 'ia64' -o "${ARCH}" = 'ppc64'
- -o "${PROFILE_ARCH}" = 'mips64' ]; then
- modules="$modules,mp_asm64"
- fi
+ # If we have assembly code for this machine, use it
+ if [ "${ARCH}" = 'x86' ]; then
+ modules="$modules,mp_ia32"
+ elif [ "${ARCH}" = 'amd64' ]; then
+ modules="$modules,mp_amd64"
+ elif [ "${ARCH}" = 'alpha' -o "${ARCH}" = 'ia64' -o "${ARCH}" = 'ppc64'
+ -o "${PROFILE_ARCH}" = 'mips64' ]; then
+ modules="$modules,mp_asm64"
+ fi
- # Enable v9 instructions for sparc64
- if [ "${PROFILE_ARCH}" = "sparc64" ]; then
- CHOSTARCH='sparc32-v9'
- else
- CHOSTARCH=$(echo ${CHOST} | cut -d - -f 1)
- fi
+ # Enable v9 instructions for sparc64
+ if [ "${PROFILE_ARCH}" = "sparc64" ]; then
+ CHOSTARCH='sparc32-v9'
+ else
+ CHOSTARCH=$(echo ${CHOST} | cut -d - -f 1)
+ fi
- cd ${S}
- einfo "Enabling modules: " ${modules}
+ cd "${S}"
+ einfo "Enabling modules: " ${modules}
- # FIXME: We might actually be on *BSD or OS X...
- ./configure.pl --noauto gcc-linux-${CHOSTARCH} --modules=$modules ||
- die "configure.pl failed"
- emake "LIB_OPT=${CXXFLAGS}" "MACH_OPT=" || die "emake failed"
+ # FIXME: We might actually be on *BSD or OS X...
+ ./configure.pl --noauto gcc-linux-${CHOSTARCH} --modules=$modules ||
+ die "configure.pl failed"
+ emake "LIB_OPT=${CXXFLAGS}" "MACH_OPT=" || die "emake failed"
}
src_test() {
- chmod -R ugo+rX ${S}
- emake check || die "emake check failed"
- env LD_LIBRARY_PATH=${S} ./check --validate || die "validation tests failed"
+ chmod -R ugo+rX "${S}"
+ emake check || die "emake check failed"
+ env LD_LIBRARY_PATH="${S}" ./check --validate || die "validation tests failed"
}
src_install() {
- make INSTALLROOT="${D}/usr" install || die "make install failed"
+ make INSTALLROOT="${D}/usr" install || die "make install failed"
}