summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-09 20:10:25 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-09 20:10:25 +0000
commit8752b626ada4f07b8c32d412669b2be148ec6503 (patch)
tree090cb9790eb4911c8ab921a13f623038158d4970 /dev-libs/botan
parentFix building with GLIBC 2.10+ wrt #280640. (diff)
downloadgentoo-2-8752b626ada4f07b8c32d412669b2be148ec6503.tar.gz
gentoo-2-8752b626ada4f07b8c32d412669b2be148ec6503.tar.bz2
gentoo-2-8752b626ada4f07b8c32d412669b2be148ec6503.zip
Version bump.
(Portage version: 13958-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/ChangeLog8
-rw-r--r--dev-libs/botan/botan-1.8.0.ebuild103
-rw-r--r--dev-libs/botan/botan-1.8.5.ebuild81
3 files changed, 88 insertions, 104 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index bf1a3c9ffb1b..2f9e3c89152d 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/botan
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.41 2009/08/09 12:52:09 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.42 2009/08/09 20:10:25 arfrever Exp $
+
+*botan-1.8.5 (09 Aug 2009)
+
+ 09 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -botan-1.8.0.ebuild, +botan-1.8.5.ebuild:
+ Version bump.
09 Aug 2009; nixnut <nixnut@gentoo.org> botan-1.8.2.ebuild:
ppc stable #277122
diff --git a/dev-libs/botan/botan-1.8.0.ebuild b/dev-libs/botan/botan-1.8.0.ebuild
deleted file mode 100644
index 8e7d5d16a4cc..000000000000
--- a/dev-libs/botan/botan-1.8.0.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.8.0.ebuild,v 1.7 2009/04/29 11:30:57 armin76 Exp $
-
-inherit eutils multilib toolchain-funcs
-
-MY_PN="Botan"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="A C++ crypto library"
-HOMEPAGE="http://botan.randombit.net/"
-SRC_URI="http://files.randombit.net/botan/${MY_P}.tgz"
-
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-SLOT="0"
-LICENSE="BSD"
-IUSE="bzip2 gmp ssl threads zlib"
-
-S="${WORKDIR}/${MY_P}"
-
-RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
- zlib? ( >=sys-libs/zlib-1.2.3 )
- gmp? ( >=dev-libs/gmp-4.2.2 )
- ssl? ( >=dev-libs/openssl-0.9.8g )"
-
-# configure.pl requires Getopt::Long, File::Spec, and File::Copy;
-# all seem included in dev-lang/perl ATM.
-DEPEND="${RDEPEND}
- dev-lang/perl"
-
-src_compile() {
- # Modules that should work under any semi-recent Unix
- local modules="alloc_mmap,egd,fd_unix,posix_rt"
- local disable_modules="proc_walk,unix_procs,cpu_counter"
-
- if useq bzip2; then modules="${modules},bzip2"; fi
- if useq zlib; then modules="${modules},zlib"; fi
- if useq gmp; then modules="${modules},gnump"; fi
- if useq ssl; then modules="${modules},openssl"; fi
- if useq threads; then modules="${modules},pthreads"; else
- disable_modules="${disable_modules},pthreads"
- fi
-
- # This is also supported on i586+ - hope this is correct.
- # documention says sparc though not enables because of
- # http://bugs.gentoo.org/show_bug.cgi?id=71760#c11
-
- # If we have assembly code for this machine, use it
- if [ "${ARCH}" = "x86" ]; then
- modules="${modules},mp_ia32"
- #below is untested.
- #modules="${modules},mp_ia32,mulop_ia32,serpent_ia32,ia32_eng,md4_ia32,md5_ia32,sha1_ia32,asm_ia32"
- elif [ "${ARCH}" = "amd64" ]; then
- modules="${modules},mp_amd64"
- # monty_amd64 and mulop_amd64 had compile failures 20090103 Botan-1.8
- #disable_modules="${disable_modules},monty_generic,mulop_generic"
- #modules="${modules},monty_amd64,mp_amd64,mulop_amd64"
- elif [ "${ARCH}" = "alpha" -o "${ARCH}" = "ia64" -o \
- "${ARCH}" = "ppc64" -o "${PROFILE_ARCH}" = "mips64" ]; then
- modules="${modules},mp_asm64"
- fi
-
- # Enable v9 instructions for sparc64
- if [ "${PROFILE_ARCH}" = "sparc64" ]; then
- CHOSTARCH="sparc32-v9"
- else
- CHOSTARCH="$(echo ${CHOST} | cut -d - -f 1)"
- fi
-
- cd "${S}"
- elog "Enabling modules: " ${modules}
- elog "Disabling modules: " ${disable_modules}
-
- # FIXME: We might actually be on *BSD or OS X...
- ./configure.pl \
- --prefix="${D}"/usr \
- --libdir=/$(get_libdir) \
- --docdir=/share/doc/ \
- --cc=gcc \
- --os=linux \
- --cpu=${CHOSTARCH} \
- --with-endian="$(tc-endian)" \
- --with-tr1=system \
- --enable-modules=${modules} \
- --disable-modules=${disable_modules} \
- || die "configure.pl failed"
- emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" \
- "LIB_OPT=${CXXFLAGS}" "MACH_OPT=" || die "emake failed"
-}
-
-src_test() {
- chmod -R ugo+rX "${S}"
- emake CXX="$(tc-getCXX)" check || die "emake check failed"
- env LD_LIBRARY_PATH="${S}" ./check --validate || die "validation tests failed"
-}
-
-src_install() {
- make install || die "make install failed"
- sed -i -e "s:${D}::g" \
- "${D}"/usr/bin/botan-config \
- "${D}"/usr/$(get_libdir)/pkgconfig/botan-1.8.pc || die 'bad sed'
- mv "${D}"/usr/share/doc/Botan-${PV} "${D}"/usr/share/doc/${PF} || \
- die 'could not rename directory'
-}
diff --git a/dev-libs/botan/botan-1.8.5.ebuild b/dev-libs/botan/botan-1.8.5.ebuild
new file mode 100644
index 000000000000..7e20c86c9124
--- /dev/null
+++ b/dev-libs/botan/botan-1.8.5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.8.5.ebuild,v 1.1 2009/08/09 20:10:25 arfrever Exp $
+
+EAPI="2"
+
+inherit multilib toolchain-funcs
+
+MY_PN="Botan"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="http://botan.randombit.net/"
+SRC_URI="http://files.randombit.net/botan/${MY_P}.tgz"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="BSD"
+IUSE="bzip2 gmp ssl threads zlib"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )
+ gmp? ( >=dev-libs/gmp-4.2.2 )
+ ssl? ( >=dev-libs/openssl-0.9.8g )"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/python-2.4"
+
+src_configure() {
+ local disable_modules="proc_walk,unix_procs,cpu_counter"
+
+ if ! useq threads; then
+ disable_modules="${disable_modules},pthreads"
+ fi
+
+ # Enable v9 instructions for sparc64
+ if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
+ CHOSTARCH="sparc32-v9"
+ else
+ CHOSTARCH="${CHOST%%-*}"
+ fi
+
+ cd "${S}"
+ elog "Disabling modules: ${disable_modules}"
+
+ # FIXME: We might actually be on *BSD or OS X...
+ ./configure.py \
+ --prefix="${D}/usr" \
+ --libdir=/$(get_libdir) \
+ --docdir=/share/doc/ \
+ --cc=gcc \
+ --os=linux \
+ --cpu=${CHOSTARCH} \
+ --with-endian="$(tc-endian)" \
+ --with-tr1=system \
+ $(use_with bzip2) \
+ $(use_with gmp gnump) \
+ $(use_with ssl openssl) \
+ $(use_with zlib) \
+ --disable-modules=${disable_modules} \
+ || die "configure.py failed"
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" LIB_OPT="${CXXFLAGS}" MACH_OPT="" || die "emake failed"
+}
+
+src_test() {
+ chmod -R ugo+rX "${S}"
+ emake CXX="$(tc-getCXX)" CHECK_OPT="${CXXFLAGS}" check || die "emake check failed"
+ LD_LIBRARY_PATH="${S}" ./check --validate || die "validation tests failed"
+}
+
+src_install() {
+ emake install || die "emake install failed"
+ sed -i -e "s:${D}::g" \
+ "${D}/usr/bin/botan-config" \
+ "${D}/usr/$(get_libdir)/pkgconfig/botan-1.8.pc" || die "sed failed"
+ mv "${D}/usr/share/doc/Botan-${PV}" "${D}/usr/share/doc/${PF}" || die "could not rename directory"
+}