summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-11-11 05:40:39 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-11-11 05:40:39 +0000
commitc980944f58c143cb3d6ee47cd800b50b912b1adf (patch)
tree8570bd51b64dd67e51b1961e3c74be475b25471b /dev-libs/botan
parentCleanup (diff)
downloadgentoo-2-c980944f58c143cb3d6ee47cd800b50b912b1adf.tar.gz
gentoo-2-c980944f58c143cb3d6ee47cd800b50b912b1adf.tar.bz2
gentoo-2-c980944f58c143cb3d6ee47cd800b50b912b1adf.zip
Cleanup
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/ChangeLog5
-rw-r--r--dev-libs/botan/botan-1.6.1.ebuild91
-rw-r--r--dev-libs/botan/files/digest-botan-1.6.13
3 files changed, 4 insertions, 95 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index 4ed2cbe542ca..cdaeef5497e0 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/botan
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.29 2007/11/11 04:12:38 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.30 2007/11/11 05:40:38 alonbl Exp $
+
+ 11 Nov 2007; Alon Bar-Lev <alonbl@gentoo.org> -botan-1.6.1.ebuild:
+ Cleanup
11 Nov 2007; Dawid Węgliński <cla@gentoo.org> botan-1.6.1-r1.ebuild:
Stable on x86 (bug #198684)
diff --git a/dev-libs/botan/botan-1.6.1.ebuild b/dev-libs/botan/botan-1.6.1.ebuild
deleted file mode 100644
index 69a08284461e..000000000000
--- a/dev-libs/botan/botan-1.6.1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.6.1.ebuild,v 1.5 2007/08/13 20:19:35 dertobi123 Exp $
-
-inherit eutils multilib
-
-MY_PN="Botan"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="A C++ crypto library"
-HOMEPAGE="http://botan.randombit.net/"
-SRC_URI="http://botan.randombit.net/files/${MY_P}.tgz"
-
-KEYWORDS="~amd64 ppc sparc x86"
-SLOT="0"
-LICENSE="BSD"
-IUSE="bzip2 gmp ssl zlib"
-
-S="${WORKDIR}/${MY_P}"
-
-RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.3 )
- zlib? ( >=sys-libs/zlib-1.2.3 )
- gmp? ( >=dev-libs/gmp-4.2.1 )
- ssl? ( >=dev-libs/openssl-0.9.8c )"
-
-# configure.pl requires Getopt::Long, File::Spec, and File::Copy;
-# all seem included in dev-lang/perl ATM.
-DEPEND="${RDEPEND}
- dev-lang/perl"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-asm.patch"
-}
-
-src_compile() {
- # Modules that should work under any semi-recent Unix
- local modules="alloc_mmap,es_egd,es_ftw,es_unix,fd_unix,ml_unix,tm_unix,tm_posix,mux_pthr"
-
- if useq bzip2; then modules="$modules,comp_bzip2"; fi
- if useq zlib; then modules="$modules,comp_zlib"; fi
- if useq gmp; then modules="$modules,eng_gmp"; fi
- if useq ssl; then modules="$modules,eng_ossl"; fi
-
- # This is also supported on i586+ - hope this is correct.
- # documention says sparc though not enables because of
- # http://bugs.gentoo.org/show_bug.cgi?id=71760#c11
-
- if [ "${ARCH}" = "alpha" -o "${ARCH}" = "amd64" ] || \
- [ "${ARCH}" = "x86" -a "${CHOST:0:4}" != "i386" -a "${CHOST:0:4}" != "i486" ]; then
- modules="$modules,tm_hard"
- fi
-
- # If we have assembly code for this machine, use it
- if [ "${ARCH}" = "x86" ]; then
- modules="$modules,mp_ia32,alg_ia32"
- elif [ "${ARCH}" = "amd64" ]; then
- modules="$modules,mp_amd64,alg_amd64"
- elif [ "${ARCH}" = "alpha" -o "${ARCH}" = "ia64" -o \
- "${ARCH}" = "ppc64" -o "${PROFILE_ARCH}" = "mips64" ]; then
- modules="$modules,mp_asm64"
- fi
-
- # Enable v9 instructions for sparc64
- if [ "${PROFILE_ARCH}" = "sparc64" ]; then
- CHOSTARCH="sparc32-v9"
- else
- CHOSTARCH="$(echo ${CHOST} | cut -d - -f 1)"
- fi
-
- cd "${S}"
- elog "Enabling modules: " ${modules}
-
- # FIXME: We might actually be on *BSD or OS X...
- ./configure.pl \
- --noauto gcc-linux-${CHOSTARCH} \
- --libdir=/usr/$(get_libdir) \
- --modules=$modules ||
- die "configure.pl failed"
- emake "LIB_OPT=${CXXFLAGS}" "MACH_OPT=" || die "emake failed"
-}
-
-src_test() {
- chmod -R ugo+rX "${S}"
- emake check || die "emake check failed"
- env LD_LIBRARY_PATH="${S}" ./check --validate || die "validation tests failed"
-}
-
-src_install() {
- make INSTALLROOT="${D}/usr" install || die "make install failed"
-}
diff --git a/dev-libs/botan/files/digest-botan-1.6.1 b/dev-libs/botan/files/digest-botan-1.6.1
deleted file mode 100644
index b092471132dc..000000000000
--- a/dev-libs/botan/files/digest-botan-1.6.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 c7330b4db6408d47db34af7887b8bfca Botan-1.6.1.tgz 1845323
-RMD160 e729d03ac8aba3a8c157cd956f4ddf08d99fe33b Botan-1.6.1.tgz 1845323
-SHA256 4ff3ec8c0c5c21fcb5b56e2c54a4eeddf7101a883e13a816630ccff288c0a9c4 Botan-1.6.1.tgz 1845323