summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-10-29 09:11:50 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-10-29 09:11:50 +0000
commitbf342a72fb5000e915585ff64785a04a7f32f346 (patch)
tree6bf420a4907ef7e03caf109a3f7978da6cad0ab4 /dev-libs/cln
parentFix for #9663 (diff)
downloadgentoo-2-bf342a72fb5000e915585ff64785a04a7f32f346.tar.gz
gentoo-2-bf342a72fb5000e915585ff64785a04a7f32f346.tar.bz2
gentoo-2-bf342a72fb5000e915585ff64785a04a7f32f346.zip
new package: CLN, a class library (C++) for numbers
Diffstat (limited to 'dev-libs/cln')
-rw-r--r--dev-libs/cln/ChangeLog13
-rw-r--r--dev-libs/cln/cln-1.1.5.ebuild42
-rw-r--r--dev-libs/cln/files/digest-cln-1.1.51
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/cln/ChangeLog b/dev-libs/cln/ChangeLog
new file mode 100644
index 000000000000..0be44fc15b96
--- /dev/null
+++ b/dev-libs/cln/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cln/ChangeLog,v 1.1 2002/10/29 09:11:50 george Exp $
+
+*cln-1.1.15 (31 Aug 2002)
+
+ 28 Oct 2002; George Shapovalov <george@gentoo.org> cln-1.1.15.ebuild, ChangeLog :
+
+ cleaned app (KEYWORDS, SLOT..., C[XX]FLAGS filters) and added to portage
+
+ 31 Aug 2002; Pierre-Henri Jondot <Pierre-Henri.Jondot@wanadoo.fr> Changelog :
+ ebuild submitted by Pierre-Henri Jondot <Pierre-Henri.Jondot@wanadoo.fr>
+
diff --git a/dev-libs/cln/cln-1.1.5.ebuild b/dev-libs/cln/cln-1.1.5.ebuild
new file mode 100644
index 000000000000..99076068c4b2
--- /dev/null
+++ b/dev-libs/cln/cln-1.1.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cln/cln-1.1.5.ebuild,v 1.1 2002/10/29 09:11:50 george Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="CLN, a class library (C++) for numbers"
+
+HOMEPAGE="http://www.ginac.de/CLN/"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+SRC_URI="ftp://ftp.santafe.edu/pub/gnu/${P}.tar.gz"
+#SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/gnu/${P}.tar.gz"
+DEPEND="dev-libs/gmp"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ # at least with gcc 2.95 and 3.1, cln won't like -O3 flag...
+ replace-flags -O[3..9] -O2
+
+ # and with gcc 2.95.3, it doesn't like funroll-loops as well...
+ [ -z "${CC}" ] && export CC=gcc
+ [ "`${CC} -dumpversion`" = "2.95.3" ] && filter-flags "-funroll-loops -frerun-loop-opt"
+
+ ./configure \
+ --build=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share/doc/${P} \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ #it doesn't also like parallel make :)
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}
diff --git a/dev-libs/cln/files/digest-cln-1.1.5 b/dev-libs/cln/files/digest-cln-1.1.5
new file mode 100644
index 000000000000..179c916e1279
--- /dev/null
+++ b/dev-libs/cln/files/digest-cln-1.1.5
@@ -0,0 +1 @@
+MD5 55d9e26806bfe9023c09caf2d7e7e91b cln-1.1.5.tar.gz 2042960