summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-12-07 06:11:28 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-12-07 06:11:28 +0000
commit62d1a1b328303ab33690f490f8fe7cfcd135dcaa (patch)
tree3e1f09fbc736139c460c61402125314d0543e0c1 /dev-libs/crypto++
parentRemoved macos keyword, as we changed our keyword to ppc-macos. (Manifest reco... (diff)
downloadgentoo-2-62d1a1b328303ab33690f490f8fe7cfcd135dcaa.tar.gz
gentoo-2-62d1a1b328303ab33690f490f8fe7cfcd135dcaa.tar.bz2
gentoo-2-62d1a1b328303ab33690f490f8fe7cfcd135dcaa.zip
Removed sse2 optimisations due to gcc problems. Bug #64646 and #63922 refer. Cleaned out old versions.
Diffstat (limited to 'dev-libs/crypto++')
-rw-r--r--dev-libs/crypto++/ChangeLog9
-rw-r--r--dev-libs/crypto++/crypto++-5.1-r1.ebuild57
-rw-r--r--dev-libs/crypto++/crypto++-5.1.ebuild28
-rw-r--r--dev-libs/crypto++/crypto++-5.2-r1.ebuild4
-rw-r--r--dev-libs/crypto++/crypto++-5.2.1.ebuild7
-rw-r--r--dev-libs/crypto++/crypto++-5.2.ebuild46
-rw-r--r--dev-libs/crypto++/files/digest-crypto++-5.11
-rw-r--r--dev-libs/crypto++/files/digest-crypto++-5.1-r12
-rw-r--r--dev-libs/crypto++/files/digest-crypto++-5.21
9 files changed, 14 insertions, 141 deletions
diff --git a/dev-libs/crypto++/ChangeLog b/dev-libs/crypto++/ChangeLog
index 151b02477f34..aa9ddcc7bd6c 100644
--- a/dev-libs/crypto++/ChangeLog
+++ b/dev-libs/crypto++/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/crypto++
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/ChangeLog,v 1.10 2004/11/04 10:03:45 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/ChangeLog,v 1.11 2004/12/07 06:11:28 dragonheart Exp $
+
+ 07 Dec 2004; Daniel Black <dragonheart@gentoo.org> -crypto++-5.1-r1.ebuild,
+ -crypto++-5.1.ebuild, crypto++-5.2-r1.ebuild, crypto++-5.2.1.ebuild,
+ -crypto++-5.2.ebuild:
+ Removed sse2 optimisations due to gcc problems. Bug #64646 and #63922 refer.
+ Cleaned out old versions. Thanks to Krzysiek Pawlik
+ <krzysiek.pawlik@people.pl> for the sse2 flag removal ebuild patch
04 Nov 2004; Daniel Black <dragonheart@gentoo.org> crypto++-5.1-r1.ebuild,
crypto++-5.1.ebuild, crypto++-5.2-r1.ebuild, crypto++-5.2.1.ebuild,
diff --git a/dev-libs/crypto++/crypto++-5.1-r1.ebuild b/dev-libs/crypto++/crypto++-5.1-r1.ebuild
deleted file mode 100644
index 59aa259cd880..000000000000
--- a/dev-libs/crypto++/crypto++-5.1-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/crypto++-5.1-r1.ebuild,v 1.8 2004/11/04 10:05:17 dragonheart Exp $
-
-inherit flag-o-matic eutils
-
-#-O3 causes segfaults
-replace-flags -O3 -O2
-
-DESCRIPTION="Crypto++ is a C++ class library of cryptographic schemes"
-HOMEPAGE="http://cryptopp.com"
-SRC_URI="mirror://sourceforge/cryptopp/crypto${PV//.}.zip
- mirror://gentoo/distfiles/crypto++-gcc-3.4.diff.bz2"
-
-LICENSE="cryptopp"
-SLOT="0"
-KEYWORDS="x86 ~ppc ~amd64"
-DEPEND="app-arch/zip"
-RDEPEND=""
-IUSE=""
-
-S=${WORKDIR}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/crypto++-5.1-amd64.diff
-
- unpack crypto++-gcc-3.4.diff.bz2
- epatch crypto++-gcc-3.4.diff
-}
-
-src_compile() {
-
- emake -f GNUmakefile CXXFLAGS="${CXXFLAGS}" || die
- if ! ./cryptest.exe v
- then
- eerror "crypto++ self-tests failed"
- eerror "Try to remove some optimization flags and re-emerge"
- die
- fi;
-}
-
-src_install() {
- # For consistency across GNU/Linux distributions,
- # "crypto++" has been preferred over "crytopp"...
- newlib.a libcryptopp.a libcrypto++.a
- # ...unbreak programs which don't expect this
- dosym libcrypto++.a /usr/lib/libcryptopp.a
- insinto /usr/include/crypto++
- doins *.h
- # should the .exe extension be removed??
- dobin cryptest.exe
- # unbreak programs which expect cryptopp
- into /usr/include
- dosym crypto++ /usr/include/cryptopp
-}
diff --git a/dev-libs/crypto++/crypto++-5.1.ebuild b/dev-libs/crypto++/crypto++-5.1.ebuild
deleted file mode 100644
index b7596fdb7d71..000000000000
--- a/dev-libs/crypto++/crypto++-5.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/crypto++-5.1.ebuild,v 1.5 2004/11/04 10:05:17 dragonheart Exp $
-
-DESCRIPTION="Crypto++ is a C++ class library of cryptographic schemes"
-HOMEPAGE="http://cryptopp.com"
-SRC_URI="mirror://sourceforge/cryptopp/crypto${PV//.}.zip"
-
-LICENSE="cryptopp"
-SLOT="0"
-KEYWORDS="x86"
-DEPEND="app-arch/zip"
-RDEPEND=""
-IUSE=""
-
-S=${WORKDIR}
-
-src_compile() {
- emake -f GNUmakefile CXXFLAGS="${CXXFLAGS}" || die
-}
-
-src_install() {
- # For consistency across GNU/Linux distributions,
- # "crypto++" has been preferred over "crytopp"
- newlib.a libcryptopp.a libcrypto++.a
- insinto /usr/include/crypto++
- doins *.h
-}
diff --git a/dev-libs/crypto++/crypto++-5.2-r1.ebuild b/dev-libs/crypto++/crypto++-5.2-r1.ebuild
index 3ac740f9c394..e8ad769ad284 100644
--- a/dev-libs/crypto++/crypto++-5.2-r1.ebuild
+++ b/dev-libs/crypto++/crypto++-5.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/crypto++-5.2-r1.ebuild,v 1.3 2004/11/04 10:05:17 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/crypto++-5.2-r1.ebuild,v 1.4 2004/12/07 06:11:28 dragonheart Exp $
inherit flag-o-matic eutils
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/cryptopp/crypto${PV//.}.zip"
LICENSE="cryptopp"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="x86 ~ppc ~amd64"
DEPEND="app-arch/zip"
RDEPEND=""
IUSE=""
diff --git a/dev-libs/crypto++/crypto++-5.2.1.ebuild b/dev-libs/crypto++/crypto++-5.2.1.ebuild
index fd1059ed934b..dd11c56193ba 100644
--- a/dev-libs/crypto++/crypto++-5.2.1.ebuild
+++ b/dev-libs/crypto++/crypto++-5.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/crypto++-5.2.1.ebuild,v 1.3 2004/11/04 10:05:17 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/crypto++-5.2.1.ebuild,v 1.4 2004/12/07 06:11:28 dragonheart Exp $
inherit flag-o-matic eutils
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/cryptopp/cryptopp${PV//.}.zip"
LICENSE="cryptopp"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="x86 ~ppc ~amd64"
DEPEND="app-arch/zip"
RDEPEND=""
IUSE=""
@@ -21,8 +21,9 @@ src_compile() {
# -O3 causes segfaults
replace-flags -O3 -O2
filter-flags -fomit-frame-pointer
+ filter-flags -msse2
- emake -f GNUmakefile CXXFLAGS="${CXXFLAGS}" || die
+ emake -f GNUmakefile CXXFLAGS="-mno-sse2 ${CXXFLAGS}" || die
}
diff --git a/dev-libs/crypto++/crypto++-5.2.ebuild b/dev-libs/crypto++/crypto++-5.2.ebuild
deleted file mode 100644
index d0e3e3632a28..000000000000
--- a/dev-libs/crypto++/crypto++-5.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/crypto++-5.2.ebuild,v 1.5 2004/11/04 10:05:17 dragonheart Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Crypto++ is a C++ class library of cryptographic schemes"
-HOMEPAGE="http://cryptopp.com"
-SRC_URI="mirror://sourceforge/cryptopp/crypto${PV//.}.zip"
-
-LICENSE="cryptopp"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-DEPEND="app-arch/zip"
-RDEPEND=""
-IUSE=""
-
-S=${WORKDIR}
-
-src_compile() {
- # -O3 causes segfaults
- replace-flags -O3 -O2
-
- emake -f GNUmakefile CXXFLAGS="${CXXFLAGS}" || die
- if ! ./cryptest.exe v
- then
- eerror "crypto++ self-tests failed"
- eerror "Try to remove some optimization flags and re-emerge"
- die
- fi;
-}
-
-src_install() {
- # For consistency across GNU/Linux distributions,
- # "crypto++" has been preferred over "crytopp"...
- newlib.a libcryptopp.a libcrypto++.a
- # ...unbreak programs which don't expect this
- dosym libcrypto++.a /usr/lib/libcryptopp.a
- insinto /usr/include/crypto++
- doins *.h
- # should the .exe extension be removed??
- dobin cryptest.exe
- # unbreak programs which expect cryptopp
- into /usr/include
- dosym crypto++ /usr/include/cryptopp
-}
diff --git a/dev-libs/crypto++/files/digest-crypto++-5.1 b/dev-libs/crypto++/files/digest-crypto++-5.1
deleted file mode 100644
index d3625c273a47..000000000000
--- a/dev-libs/crypto++/files/digest-crypto++-5.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 f4bfd4ac39dc1b7f0764d61a1ec4df16 crypto51.zip 829560
diff --git a/dev-libs/crypto++/files/digest-crypto++-5.1-r1 b/dev-libs/crypto++/files/digest-crypto++-5.1-r1
deleted file mode 100644
index 728b5fb0cdba..000000000000
--- a/dev-libs/crypto++/files/digest-crypto++-5.1-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 f4bfd4ac39dc1b7f0764d61a1ec4df16 crypto51.zip 829560
-MD5 70790a6dea63b6a02f1b1d3b5d26ae1a crypto++-gcc-3.4.diff.bz2 13033
diff --git a/dev-libs/crypto++/files/digest-crypto++-5.2 b/dev-libs/crypto++/files/digest-crypto++-5.2
deleted file mode 100644
index d722342b1fac..000000000000
--- a/dev-libs/crypto++/files/digest-crypto++-5.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5c09d632ef36e889f1727fb50cb21c4d crypto52.zip 1045252