summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-08-29 17:08:33 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-08-29 17:08:33 +0000
commite827e9f1971c3edf0d8f220111a582a3badb7413 (patch)
tree60852cfbee1ec5ec296f9abf6ae5833bd53cdae4 /dev-libs/dietlibc
parentbump to rc2, remove old betas, thanks Pavel. (diff)
downloadgentoo-2-e827e9f1971c3edf0d8f220111a582a3badb7413.tar.gz
gentoo-2-e827e9f1971c3edf0d8f220111a582a3badb7413.tar.bz2
gentoo-2-e827e9f1971c3edf0d8f220111a582a3badb7413.zip
new snapshot wrt #227429
(Portage version: 2.2_rc8/cvs/Linux 2.6.22-vs2.2.0.6-gentoo x86_64)
Diffstat (limited to 'dev-libs/dietlibc')
-rw-r--r--dev-libs/dietlibc/ChangeLog8
-rw-r--r--dev-libs/dietlibc/dietlibc-0.32_pre20080829.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-libs/dietlibc/ChangeLog b/dev-libs/dietlibc/ChangeLog
index b11209262c25..85d49cdf2bac 100644
--- a/dev-libs/dietlibc/ChangeLog
+++ b/dev-libs/dietlibc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/dietlibc
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/ChangeLog,v 1.74 2008/03/14 20:16:02 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/ChangeLog,v 1.75 2008/08/29 17:08:33 hollow Exp $
+
+*dietlibc-0.32_pre20080829 (29 Aug 2008)
+
+ 29 Aug 2008; Benedikt Böhm <hollow@gentoo.org>
+ +dietlibc-0.32_pre20080829.ebuild:
+ new snapshot wrt #227429
14 Mar 2008; Benedikt Böhm <hollow@gentoo.org> metadata.xml:
fix metadata
diff --git a/dev-libs/dietlibc/dietlibc-0.32_pre20080829.ebuild b/dev-libs/dietlibc/dietlibc-0.32_pre20080829.ebuild
new file mode 100644
index 000000000000..2ed4bb7f93e6
--- /dev/null
+++ b/dev-libs/dietlibc/dietlibc-0.32_pre20080829.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/dietlibc-0.32_pre20080829.ebuild,v 1.1 2008/08/29 17:08:33 hollow Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A minimal libc"
+HOMEPAGE="http://www.fefe.de/dietlibc/"
+SRC_URI="http://people.linux-vserver.org/~hollow/dietlibc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND=""
+
+DIETHOME=/usr/diet
+
+pkg_setup() {
+ # Replace sparc64 related C[XX]FLAGS (see bug #45716)
+ use sparc && replace-sparc64-flags
+
+ # gcc-hppa suffers support for SSP, compilation will fail
+ use hppa && strip-unsupported-flags
+
+ # debug flags
+ use debug && append-flags -g
+
+ # Makefile does not append CFLAGS
+ append-flags -nostdinc -W -Wall -Wextra -Wchar-subscripts \
+ -Wmissing-prototypes -Wmissing-declarations -Wno-switch \
+ -Wno-unused -Wredundant-decls
+}
+
+src_compile() {
+ emake prefix=${DIETHOME} CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ emake prefix=${DIETHOME} DESTDIR="${D}" install || die "make install failed"
+ dobin "${D}"${DIETHOME}/bin/* || die "dobin failed"
+ doman "${D}"${DIETHOME}/man/*/* || die "doman failed"
+ rm -r "${D}"${DIETHOME}/{man,bin}
+ dodoc AUTHOR BUGS CAVEAT CHANGES README THANKS TODO PORTING
+}