summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-22 18:55:26 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-22 18:55:26 +0000
commit8f8b8d13aa978db5c417503edb91479d282b5bf6 (patch)
tree0f798b6f6f6017fe4fe0eda2d731dbf247c08a8f /dev-libs/distorm64
parentStable on alpha, bug #290343 (diff)
downloadgentoo-2-8f8b8d13aa978db5c417503edb91479d282b5bf6.tar.gz
gentoo-2-8f8b8d13aa978db5c417503edb91479d282b5bf6.tar.bz2
gentoo-2-8f8b8d13aa978db5c417503edb91479d282b5bf6.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14874-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/distorm64')
-rw-r--r--dev-libs/distorm64/ChangeLog6
-rw-r--r--dev-libs/distorm64/distorm64-1.7.30-r1.ebuild28
2 files changed, 24 insertions, 10 deletions
diff --git a/dev-libs/distorm64/ChangeLog b/dev-libs/distorm64/ChangeLog
index 284a04ed8432..3d9611f1c451 100644
--- a/dev-libs/distorm64/ChangeLog
+++ b/dev-libs/distorm64/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/distorm64
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/distorm64/ChangeLog,v 1.3 2009/06/29 12:29:20 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/distorm64/ChangeLog,v 1.4 2009/11/22 18:55:26 arfrever Exp $
+
+ 22 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ distorm64-1.7.30-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
29 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
distorm64-1.7.30-r1.ebuild, +files/distorm64-1.7.30-python.patch,
diff --git a/dev-libs/distorm64/distorm64-1.7.30-r1.ebuild b/dev-libs/distorm64/distorm64-1.7.30-r1.ebuild
index f98fad38e73f..6fa445ced9f4 100644
--- a/dev-libs/distorm64/distorm64-1.7.30-r1.ebuild
+++ b/dev-libs/distorm64/distorm64-1.7.30-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/distorm64/distorm64-1.7.30-r1.ebuild,v 1.2 2009/06/29 12:29:20 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/distorm64/distorm64-1.7.30-r1.ebuild,v 1.3 2009/11/22 18:55:26 arfrever Exp $
EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
inherit eutils flag-o-matic python toolchain-funcs
@@ -17,6 +18,7 @@ IUSE="+python"
DEPEND="python? ( >=dev-lang/python-2.4 )"
RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${PN}"
@@ -27,16 +29,21 @@ src_prepare() {
src_compile() {
cd "${WORKDIR}/${PN}/build/linux"
- emake clib CC="$(tc-getCC)" || die "make clib failed!"
+ emake CC="$(tc-getCC)" clib || die "emake clib failed"
if use python; then
- python_version
- append-flags "-I/usr/include/python${PYVER}"
- emake py CC="$(tc-getCC)" || die "make py failed!"
+ building() {
+ # Build ../../src/pydistorm.o separately with each enabled version of Python.
+ rm -f ../../src/pydistorm.o
+
+ # Additional CFLAGS retrieved from build/linux/Makefile.
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -I$(python_get_includedir) -Wall -fPIC -DSUPPORT_64BIT_OFFSET -D_DLL" TARGET="distorm.so-${PYTHON_ABI}" py
+ }
+ python_execute_function building
fi
cd "${WORKDIR}/${PN}/linuxproj"
- emake disasm CC="$(tc-getCC)" || die "make disasm failed!"
+ emake CC="$(tc-getCC)" disasm || die "emake disasm failed"
}
@@ -46,11 +53,14 @@ src_install() {
dolib.so libdistorm64.so
if use python; then
- dodir "$(python_get_sitedir)"
- install libdistorm64.so "${D}$(python_get_sitedir)/distorm.so"
+ installation() {
+ dodir "$(python_get_sitedir)"
+ install distorm.so-${PYTHON_ABI} "${D}$(python_get_sitedir)/distorm.so"
+ }
+ python_execute_function -q installation
fi
- cd "${WORKDIR}/${PN}/"
+ cd "${WORKDIR}/${PN}"
newlib.a distorm64.a libdistorm64.a
dobin linuxproj/disasm