summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-08-28 03:03:03 +0000
committerMike Frysinger <vapier@gentoo.org>2013-08-28 03:03:03 +0000
commit5b3146f20230947ab93faa72d8280681c842f45f (patch)
tree20c677df47e162536ceb9100b280f9291272c7f5 /dev-libs/e_dbus
parentdeploy E_ECONF as an array replacement of the MY_ECONF string (diff)
downloadgentoo-2-5b3146f20230947ab93faa72d8280681c842f45f.tar.gz
gentoo-2-5b3146f20230947ab93faa72d8280681c842f45f.tar.bz2
gentoo-2-5b3146f20230947ab93faa72d8280681c842f45f.zip
Version bump.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'dev-libs/e_dbus')
-rw-r--r--dev-libs/e_dbus/ChangeLog7
-rw-r--r--dev-libs/e_dbus/e_dbus-1.7.8.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-libs/e_dbus/ChangeLog b/dev-libs/e_dbus/ChangeLog
index d5ce3260e1b5..0f11cc78129e 100644
--- a/dev-libs/e_dbus/ChangeLog
+++ b/dev-libs/e_dbus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/e_dbus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/ChangeLog,v 1.14 2013/07/21 10:42:42 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/ChangeLog,v 1.15 2013/08/28 03:03:03 vapier Exp $
+
+*e_dbus-1.7.8 (28 Aug 2013)
+
+ 28 Aug 2013; Mike Frysinger <vapier@gentoo.org> +e_dbus-1.7.8.ebuild:
+ Version bump.
21 Jul 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
connman is a global USE flag now
diff --git a/dev-libs/e_dbus/e_dbus-1.7.8.ebuild b/dev-libs/e_dbus/e_dbus-1.7.8.ebuild
new file mode 100644
index 000000000000..df0dbe73fc60
--- /dev/null
+++ b/dev-libs/e_dbus/e_dbus-1.7.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/e_dbus-1.7.8.ebuild,v 1.1 2013/08/28 03:03:03 vapier Exp $
+
+EAPI="4"
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's (Ecore) integration to DBus"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="bluetooth +connman +libnotify ofono static-libs test-binaries +udev"
+
+RDEPEND=">=dev-libs/eina-1.7.8
+ >=dev-libs/ecore-1.7.8
+ sys-apps/dbus
+ connman? ( >=net-misc/connman-0.75 )
+ libnotify? ( >=media-libs/evas-1.7.8 )
+ udev? ( sys-power/upower sys-fs/udisks:0 )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ E_ECONF+=(
+ $(use_enable bluetooth ebluez)
+ $(use_enable connman econnman0_7x)
+ $(use_enable doc)
+ --disable-ehal
+ $(use_enable libnotify enotify)
+ $(use_enable ofono eofono)
+ $(use_enable test-binaries edbus-test)
+ $(use_enable test-binaries edbus-test-client)
+ $(use_enable udev eukit)
+ )
+ if use test-binaries ; then
+ E_ECONF+=(
+ $(use_enable bluetooth edbus-bluez-test)
+ $(use_enable connman edbus-connman0_7x-test)
+ $(use_enable libnotify edbus-notification-daemon-test)
+ $(use_enable libnotify edbus-notify-test)
+ $(use_enable ofono edbus-ofono-test)
+ $(use_enable udev edbus-ukit-test)
+ )
+ else
+ E_ECONF+=(
+ --disable-edbus-bluez-test
+ --disable-edbus-connman0_7x-test
+ --disable-edbus-notification-daemon-test
+ --disable-edbus-notify-test
+ --disable-edbus-ofono-test
+ --disable-edbus-ukit-test
+ --disable-edbus-async-test
+ --disable-edbus-performance-test
+ )
+ fi
+ enlightenment_src_configure
+}