summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-04-24 07:30:32 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-04-24 07:30:32 +0000
commit1e777fad0fcc770844ecb49ba4a98245404e89ba (patch)
tree1ab94ff5e641e70f4fcae651342064f216de62e3 /dev-libs/elfutils
parentInitial commit, bug 220451; Thanks to Babikhin Kirill for original ebuild (diff)
downloadgentoo-2-1e777fad0fcc770844ecb49ba4a98245404e89ba.tar.gz
gentoo-2-1e777fad0fcc770844ecb49ba4a98245404e89ba.tar.bz2
gentoo-2-1e777fad0fcc770844ecb49ba4a98245404e89ba.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/elfutils')
-rw-r--r--dev-libs/elfutils/ChangeLog7
-rw-r--r--dev-libs/elfutils/elfutils-0.146.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-libs/elfutils/ChangeLog b/dev-libs/elfutils/ChangeLog
index 5f8ba2d2fbd8..495e1ff734a0 100644
--- a/dev-libs/elfutils/ChangeLog
+++ b/dev-libs/elfutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/elfutils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.131 2010/03/31 18:16:11 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.132 2010/04/24 07:30:32 dirtyepic Exp $
+
+*elfutils-0.146 (24 Apr 2010)
+
+ 24 Apr 2010; Ryan Hill <dirtyepic@gentoo.org> +elfutils-0.146.ebuild:
+ Version bump.
31 Mar 2010; <solar@gentoo.org> elfutils-0.127.ebuild,
elfutils-0.131-r1.ebuild, elfutils-0.131-r2.ebuild,
diff --git a/dev-libs/elfutils/elfutils-0.146.ebuild b/dev-libs/elfutils/elfutils-0.146.ebuild
new file mode 100644
index 000000000000..a3b8f9ab012c
--- /dev/null
+++ b/dev-libs/elfutils/elfutils-0.146.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.146.ebuild,v 1.1 2010/04/24 07:30:32 dirtyepic Exp $
+
+inherit eutils
+
+DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
+HOMEPAGE="http://people.redhat.com/drepper/"
+#SRC_URI="ftp://sources.redhat.com/pub/systemtap/${PN}/${P}.tar.gz"
+#SRC_URI="mirror://debian/pool/main/e/elfutils/elfutils_${PV}.orig.tar.gz"
+SRC_URI="https://fedorahosted.org/releases/e/l/elfutils/${P}.tar.bz2"
+
+LICENSE="GPL-2-with-exceptions"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 lzma nls test zlib elibc_glibc"
+
+# This pkg does not actually seem to compile currently in a uClibc
+# environment (xrealloc errs), but we need to ensure that glibc never
+# gets pulled in as a dep since this package does not respect virtual/libc
+RDEPEND="zlib? ( >=sys-libs/zlib-1.2.2.3 )
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}
+ elibc_glibc? ( !prefix? ( >=sys-libs/glibc-2.7 ) )
+ nls? ( sys-devel/gettext )
+ >=sys-devel/flex-2.5.4a
+ sys-devel/m4
+ >=sys-devel/binutils-2.15.90.0.1
+ >=sys-devel/gcc-4.1.2
+ !dev-libs/libelf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.118-PaX-support.patch
+ epatch "${FILESDIR}"/${PN}-0.143-configure.patch #287130
+ find . -name Makefile.in -print0 | xargs -0 sed -i -e 's:-W\(error\|extra\)::g'
+ use test || sed -i -e 's: tests::' Makefile.in #226349
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --program-prefix="eu-" \
+ $(use_with zlib) \
+ $(use_with bzip2 bzlib) \
+ $(use_with lzma)
+
+ emake || die
+}
+
+src_test() {
+ env LD_LIBRARY_PATH="${S}/libelf:${S}/libebl:${S}/libdw:${S}/libasm" \
+ emake -j1 check || die "test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS NOTES README THANKS TODO
+}