summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2007-07-20 18:41:58 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2007-07-20 18:41:58 +0000
commit74a186b54804651e6e82f013270847a469bd9da8 (patch)
treeb3c6651ffeb1480c4edd2216d9b726ec17ffa06e /dev-libs/expat/expat-2.0.1.ebuild
parentVersion bumped, Bug #173467, #181597. (diff)
downloadgentoo-2-74a186b54804651e6e82f013270847a469bd9da8.tar.gz
gentoo-2-74a186b54804651e6e82f013270847a469bd9da8.tar.bz2
gentoo-2-74a186b54804651e6e82f013270847a469bd9da8.zip
Version bump, closes bug 183900.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'dev-libs/expat/expat-2.0.1.ebuild')
-rw-r--r--dev-libs/expat/expat-2.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/expat/expat-2.0.1.ebuild b/dev-libs/expat/expat-2.0.1.ebuild
new file mode 100644
index 000000000000..8f336b6a3021
--- /dev/null
+++ b/dev-libs/expat/expat-2.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-2.0.1.ebuild,v 1.1 2007/07/20 18:41:58 cryos Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="XML parsing libraries"
+HOMEPAGE="http://expat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/expat/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc Changes README
+ dohtml doc/*
+}
+
+pkg_postinst() {
+ ewarn "Please note that the soname of the library changed!"
+ ewarn "If you are upgrading from a previous version you need"
+ ewarn "to fix dynamic linking inconsistencies by executing:"
+ ewarn "revdep-rebuild --library libexpat.so.0"
+}