summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-04-21 23:29:12 +0000
committerJon Hood <squinky86@gentoo.org>2004-04-21 23:29:12 +0000
commitcd03cf278ac14616edab8b048bda2a2e20869892 (patch)
tree225c789b6590b822217fd247da9ae29ba1f04a14 /dev-libs/geoip/geoip-1.3.2.ebuild
parentadded keyword for sparc (bug #48626) (Manifest recommit) (diff)
downloadgentoo-2-cd03cf278ac14616edab8b048bda2a2e20869892.tar.gz
gentoo-2-cd03cf278ac14616edab8b048bda2a2e20869892.tar.bz2
gentoo-2-cd03cf278ac14616edab8b048bda2a2e20869892.zip
version bump (#48618)
Diffstat (limited to 'dev-libs/geoip/geoip-1.3.2.ebuild')
-rw-r--r--dev-libs/geoip/geoip-1.3.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/geoip/geoip-1.3.2.ebuild b/dev-libs/geoip/geoip-1.3.2.ebuild
new file mode 100644
index 000000000000..77618d3c9287
--- /dev/null
+++ b/dev-libs/geoip/geoip-1.3.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/geoip-1.3.2.ebuild,v 1.1 2004/04/21 23:29:12 squinky86 Exp $
+
+MY_P=${P/geoip/GeoIP}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS entries don't exist"
+HOMEPAGE="http://www.maxmind.com/geoip/api/c.shtml"
+SRC_URI="http://www.maxmind.com/download/geoip/api/c/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/glibc
+ sys-libs/zlib"
+
+src_compile() {
+ econf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+}