summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-02-18 12:12:54 +0000
committerPacho Ramos <pacho@gentoo.org>2015-02-18 12:12:54 +0000
commitadf2f431d278a158325ea11ae5c742b532bf8c2f (patch)
tree671b7791b118713a99d127783b39532f92634c1b /dev-libs/gom
parentVersion bump (diff)
downloadgentoo-2-adf2f431d278a158325ea11ae5c742b532bf8c2f.tar.gz
gentoo-2-adf2f431d278a158325ea11ae5c742b532bf8c2f.tar.bz2
gentoo-2-adf2f431d278a158325ea11ae5c742b532bf8c2f.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/gom')
-rw-r--r--dev-libs/gom/ChangeLog9
-rw-r--r--dev-libs/gom/gom-0.3.0.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-libs/gom/ChangeLog b/dev-libs/gom/ChangeLog
index d89bd9209c40..1bd37fb3d53a 100644
--- a/dev-libs/gom/ChangeLog
+++ b/dev-libs/gom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/gom
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gom/ChangeLog,v 1.3 2014/12/19 13:35:24 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gom/ChangeLog,v 1.4 2015/02/18 12:12:54 pacho Exp $
+
+*gom-0.3.0 (18 Feb 2015)
+
+ 18 Feb 2015; Pacho Ramos <pacho@gentoo.org> +gom-0.3.0.ebuild:
+ Version bump
19 Dec 2014; Pacho Ramos <pacho@gentoo.org> gom-0.2.1.ebuild:
amd64 stable, bug 529964
diff --git a/dev-libs/gom/gom-0.3.0.ebuild b/dev-libs/gom/gom-0.3.0.ebuild
new file mode 100644
index 000000000000..42e6cfe20c3d
--- /dev/null
+++ b/dev-libs/gom/gom-0.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gom/gom-0.3.0.ebuild,v 1.1 2015/02/18 12:12:54 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="GObject to SQLite object mapper library"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gom"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="+introspection"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-db/sqlite-3.7:3
+ >=dev-libs/glib-2.36:2
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}