summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-06-04 16:47:40 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-06-04 16:47:40 +0000
commitb95fa253d8022dab9b0f96e6c089bc2cece64505 (patch)
tree28b0fa5f98a225e5024307383a244b71ea6702cf /dev-libs/grok
parentVersion bump (diff)
downloadgentoo-2-b95fa253d8022dab9b0f96e6c089bc2cece64505.tar.gz
gentoo-2-b95fa253d8022dab9b0f96e6c089bc2cece64505.tar.bz2
gentoo-2-b95fa253d8022dab9b0f96e6c089bc2cece64505.zip
Fixed grok ebuild and patch.
Thanks to jlec for actively monitoring commits and always helping me to fight my ignorance. (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-libs/grok')
-rw-r--r--dev-libs/grok/ChangeLog7
-rw-r--r--dev-libs/grok/files/0.9.2-Makefile.patch47
-rw-r--r--dev-libs/grok/grok-0.9.2.ebuild5
3 files changed, 50 insertions, 9 deletions
diff --git a/dev-libs/grok/ChangeLog b/dev-libs/grok/ChangeLog
index 2a7fd4f6f782..4c313cb4dac1 100644
--- a/dev-libs/grok/ChangeLog
+++ b/dev-libs/grok/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/grok
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/grok/ChangeLog,v 1.1 2014/05/31 12:59:08 ercpe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/grok/ChangeLog,v 1.2 2014/06/04 16:47:40 ercpe Exp $
+
+ 04 Jun 2014; Johann Schmitz <ercpe@gentoo.org> files/0.9.2-Makefile.patch,
+ grok-0.9.2.ebuild:
+ Fixed grok ebuild and patch. Thanks to jlec for actively monitoring commits
+ and always helping me to fight my ignorance.
*grok-0.9.2 (31 May 2014)
diff --git a/dev-libs/grok/files/0.9.2-Makefile.patch b/dev-libs/grok/files/0.9.2-Makefile.patch
index b5eeb0908bc2..f10531646ad0 100644
--- a/dev-libs/grok/files/0.9.2-Makefile.patch
+++ b/dev-libs/grok/files/0.9.2-Makefile.patch
@@ -1,8 +1,43 @@
diff --git a/grok-0.9.2/Makefile b/grok-0.9.2/Makefile
-index adfe869..d5531b2 100644
+index adfe869..fdced25 100644
--- a/grok-0.9.2/Makefile
+++ b/grok-0.9.2/Makefile
-@@ -97,6 +97,7 @@ install: libgrok.$(LIBSUFFIX) grok discogrok $(GROKHEADER)
+@@ -25,10 +25,12 @@ else
+ GPERF?=/usr/bin/gperf
+ endif
+
++LIBS=-lpcre -levent -rdynamic -ltokyocabinet
++
+ # For linux, we need libdl for dlopen()
+ # On FreeBSD, comment this line out.
+ ifeq ($(PLATFORM), GNULinux)
+-LDFLAGS+=-ldl
++LIBS+=-ldl
+ endif
+
+ # #############################################
+@@ -41,8 +43,7 @@ VERSION=$(shell sh $(BASE)/version.sh)
+ #CFLAGS+=-g
+ #LDFLAGS+=-g
+
+-CFLAGS+=-pipe -fPIC -I. -O2
+-LDFLAGS+=-lpcre -levent -rdynamic -ltokyocabinet
++CFLAGS+=-fPIC -I.
+
+ LIBSUFFIX=$(shell sh $(BASE)/platform.sh libsuffix)
+ VERLIBSUFFIX=$(shell sh $(BASE)/platform.sh libsuffix $(MAJOR))
+@@ -50,8 +51,8 @@ DYNLIBFLAG=$(shell sh $(BASE)/platform.sh dynlibflag)
+ LIBNAMEFLAG=$(shell sh $(BASE)/platform.sh libnameflag $(MAJOR) $(INSTALLLIB))
+
+ # Sane includes
+-CFLAGS+=-I/usr/local/include
+-LDFLAGS+=-L/usr/local/lib
++#CFLAGS+=-I/usr/local/include
++#LDFLAGS+=-L/usr/local/lib
+
+ # Platform so we know what to dlopen
+ CFLAGS+=-DPLATFORM_$(PLATFORM)
+@@ -97,6 +98,7 @@ install: libgrok.$(LIBSUFFIX) grok discogrok $(GROKHEADER)
install -m 755 grok $(DESTDIR)$(PREFIX)/bin
install -m 755 discogrok $(DESTDIR)$(PREFIX)/bin
install -m 644 libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/lib
@@ -10,21 +45,21 @@ index adfe869..d5531b2 100644
for header in $(GROKHEADER); do \
install -m 644 $$header $(DESTDIR)$(PREFIX)/include; \
done
-@@ -162,14 +163,14 @@ cleanver:
+@@ -162,14 +164,14 @@ cleanver:
# Binary creation
grok: LDFLAGS+=-levent
grok: $(GROKOBJ) conf.tab.o conf.yy.o main.o grok_config.o
- $(CC) $(LDFLAGS) $^ -o $@
-+ $(CC) $^ $(LDFLAGS) -o $@
++ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
discogrok: $(GROKOBJ) discover_main.o
- $(CC) $(LDFLAGS) $^ -o $@
-+ $(CC) $^ $(LDFLAGS) -o $@
++ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
libgrok.$(LIBSUFFIX):
libgrok.$(LIBSUFFIX): $(GROKOBJ)
- $(CC) $(LDFLAGS) -fPIC $(DYNLIBFLAG) $(LIBNAMEFLAG) $^ -o $@
-+ $(CC) $^ $(LDFLAGS) -fPIC $(DYNLIBFLAG) $(LIBNAMEFLAG) -o $@
++ $(CC) $(LDFLAGS) -fPIC $(DYNLIBFLAG) $(LIBNAMEFLAG) $^ $(LIBS) -o $@
libgrok.$(VERLIBSUFFIX): libgrok.$(LIBSUFFIX);
ln -s $< $@
diff --git a/dev-libs/grok/grok-0.9.2.ebuild b/dev-libs/grok/grok-0.9.2.ebuild
index 81e432b809bd..8a6cf0ab3880 100644
--- a/dev-libs/grok/grok-0.9.2.ebuild
+++ b/dev-libs/grok/grok-0.9.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/grok/grok-0.9.2.ebuild,v 1.1 2014/05/31 12:59:08 ercpe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/grok/grok-0.9.2.ebuild,v 1.2 2014/06/04 16:47:40 ercpe Exp $
EAPI=5
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="DRY and RAD for regular expressions"
HOMEPAGE="https://github.com/jordansissel/grok http://code.google.com/p/semicomplete/wiki/Grok"
@@ -24,4 +24,5 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${PV}-*.patch
+ tc-export CC
}