summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-06-10 14:06:57 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-06-10 14:06:57 +0000
commitab728d7772cb85faf7bfbdebb3d70894f7a3cf01 (patch)
treefc47b6b738bf87cd16c548500ffb99401e0810af /dev-libs/hashit
parentInitial import of ucode for IWL 6000 series cards. (diff)
downloadgentoo-2-ab728d7772cb85faf7bfbdebb3d70894f7a3cf01.tar.gz
gentoo-2-ab728d7772cb85faf7bfbdebb3d70894f7a3cf01.tar.bz2
gentoo-2-ab728d7772cb85faf7bfbdebb3d70894f7a3cf01.zip
Bump, fix of pkgconfig bits. Thanks to dabbott for the patch, fixes #321533
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/hashit')
-rw-r--r--dev-libs/hashit/ChangeLog11
-rw-r--r--dev-libs/hashit/files/hashit-0.9.7-pkgconfig.patch20
-rw-r--r--dev-libs/hashit/hashit-0.9.7.ebuild23
3 files changed, 52 insertions, 2 deletions
diff --git a/dev-libs/hashit/ChangeLog b/dev-libs/hashit/ChangeLog
index 72ea9a1ad0f7..b8106d78f476 100644
--- a/dev-libs/hashit/ChangeLog
+++ b/dev-libs/hashit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/hashit
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/hashit/ChangeLog,v 1.12 2009/09/23 17:20:19 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hashit/ChangeLog,v 1.13 2010/06/10 14:06:57 patrick Exp $
+
+*hashit-0.9.7 (10 Jun 2010)
+
+ 10 Jun 2010; Patrick Lauer <patrick@gentoo.org> +hashit-0.9.7.ebuild,
+ +files/hashit-0.9.7-pkgconfig.patch:
+ Bump, fix of pkgconfig bits. Thanks to dabbott for the patch, fixes
+ #321533
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> hashit-0.9.3.ebuild:
Remove virtual/libc
diff --git a/dev-libs/hashit/files/hashit-0.9.7-pkgconfig.patch b/dev-libs/hashit/files/hashit-0.9.7-pkgconfig.patch
new file mode 100644
index 000000000000..e88a28dba5d3
--- /dev/null
+++ b/dev-libs/hashit/files/hashit-0.9.7-pkgconfig.patch
@@ -0,0 +1,20 @@
+--- a/hashit-0.9.7/CMakeLists.txt 2010-03-12 08:35:03.000000000 -0500
++++ b/hashit-0.9.7/CMakeLists.txt 2010-05-28 19:24:52.000000000 -0400
+@@ -9,7 +9,7 @@
+ INCLUDE (FindPkgConfig)
+
+ IF (NOT PKG_CONFIG_FOUND)
+- MESSAGE (FATAL_ERROR "pkg-config not found...")
++ MESSAGE (FATAL_ERROR "pkgconfig not found...")
+ ENDIF (NOT PKG_CONFIG_FOUND)
+
+ ADD_DEFINITIONS (-DDATADIR=\\\"${CMAKE_INSTALL_PREFIX}/share\\\")
+@@ -28,7 +28,7 @@
+
+ INSTALL (TARGETS hashit LIBRARY DESTINATION lib${LIB_SUFFIX})
+ INSTALL (FILES src/hashit.h DESTINATION include)
+-INSTALL (FILES libhashit.pc DESTINATION lib${LIB_SUFFIX}/pkg-config)
++INSTALL (FILES libhashit.pc DESTINATION lib${LIB_SUFFIX}/pkgconfig)
+
+ SET_TARGET_PROPERTIES (hashit PROPERTIES VERSION 1.0 SOVERSION 1)
+ SET (LIBRARY_OUTPUT_PATH src)
diff --git a/dev-libs/hashit/hashit-0.9.7.ebuild b/dev-libs/hashit/hashit-0.9.7.ebuild
new file mode 100644
index 000000000000..ca1a5ce2afb2
--- /dev/null
+++ b/dev-libs/hashit/hashit-0.9.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hashit/hashit-0.9.7.ebuild,v 1.1 2010/06/10 14:06:57 patrick Exp $
+
+EAPI=3
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Generic hash library implemented in C which supports multiple collision handling methods."
+HOMEPAGE="http://www.pleyades.net/david/hashit.php"
+SRC_URI="http://www.pleyades.net/david/projects/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-pkgconfig.patch"
+}