summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-11-05 11:56:17 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-11-05 11:56:17 +0000
commita525305f72c13040a37bf1720f070077a8173411 (patch)
tree470d7a4a9e799d04ed47a47293a0a9bb9b21d3b3 /dev-libs/icu
parentMove to SUSE team (diff)
downloadgentoo-2-a525305f72c13040a37bf1720f070077a8173411.tar.gz
gentoo-2-a525305f72c13040a37bf1720f070077a8173411.tar.bz2
gentoo-2-a525305f72c13040a37bf1720f070077a8173411.zip
Revision bump to fix bug#441794 and more wip goodies.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'dev-libs/icu')
-rw-r--r--dev-libs/icu/ChangeLog8
-rw-r--r--dev-libs/icu/icu-50_rc-r3.ebuild (renamed from dev-libs/icu/icu-50_rc-r2.ebuild)75
2 files changed, 45 insertions, 38 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index 425a2ffbe901..71ed0ffc3424 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.214 2012/11/04 12:26:19 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.215 2012/11/05 11:56:17 scarabeus Exp $
+
+*icu-50_rc-r3 (05 Nov 2012)
+
+ 05 Nov 2012; Tomáš Chvátal <scarabeus@gentoo.org> +icu-50_rc-r3.ebuild,
+ -icu-50_rc-r2.ebuild:
+ Revision bump to fix bug#441794 and more wip goodies.
04 Nov 2012; Tomáš Chvátal <scarabeus@gentoo.org> icu-50_rc-r2.ebuild:
Silence repoman.
diff --git a/dev-libs/icu/icu-50_rc-r2.ebuild b/dev-libs/icu/icu-50_rc-r3.ebuild
index df90feb879cc..578cd107ff32 100644
--- a/dev-libs/icu/icu-50_rc-r2.ebuild
+++ b/dev-libs/icu/icu-50_rc-r3.ebuild
@@ -1,56 +1,34 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-50_rc-r2.ebuild,v 1.2 2012/11/04 12:26:19 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-50_rc-r3.ebuild,v 1.1 2012/11/05 11:56:17 scarabeus Exp $
EAPI=5
-BASE_URI="http://download.icu-project.org/files/icu4c/${PV/_/}"
-SRC_ARCHIVE="icu4c-${PV//./_}-src.tgz"
-DOCS_ARCHIVE="icu4c-${PV//./_}-docs.zip"
-
-inherit eutils toolchain-funcs versionator base
-
-MAJOR_VERSION="$(get_version_component_range 1)"
-if [[ ${PV/_rc/} != ${PV} ]]; then
- MINOR_VERSION="1"
-else
- MINOR_VERSION="$(get_version_component_range 2)"
-fi
+inherit eutils toolchain-funcs base autotools
DESCRIPTION="International Components for Unicode"
HOMEPAGE="http://www.icu-project.org/"
-
-SRC_URI="${BASE_URI}/${SRC_ARCHIVE}
- doc? ( ${BASE_URI}/${DOCS_ARCHIVE} )
-"
+SRC_URI="http://download.icu-project.org/files/icu4c/${PV/_/}/icu4c-${PV//./_}-src.tgz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="debug doc examples static-libs"
-DEPEND="doc? ( app-arch/unzip )"
RDEPEND="!dev-libs/icu:0/50"
+DEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ )
+"
S="${WORKDIR}/${PN}/source"
-QA_DT_NEEDED="/usr/lib.*/libicudata\.so\.${MAJOR_VERSION}\.${MINOR_VERSION}.*"
-QA_FLAGS_IGNORED="/usr/lib.*/libicudata\.so\.${MAJOR_VERSION}\.${MINOR_VERSION}.*"
-
PATCHES=(
"${FILESDIR}/${PN}-4.8.1-fix_binformat_fonts.patch"
"${FILESDIR}/${PN}-4.8.1.1-fix_ltr.patch"
)
-src_unpack() {
- unpack "${SRC_ARCHIVE}"
- if use doc; then
- mkdir -p docs
- cd docs
- unpack "${DOCS_ARCHIVE}"
- fi
-}
-
src_prepare() {
local variable
@@ -65,6 +43,22 @@ src_prepare() {
-i config/Makefile.inc.in \
|| die
done
+
+ # Disable renaming as it is stupind thing to do
+ sed -i \
+ -e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 1/" \
+ common/unicode/uconfig.h || die
+
+ # Fix linking of icudata
+ sed -i \
+ -e "s:LDFLAGSICUDT=-nodefaultlibs -nostdlib:LDFLAGSICUDT=:" \
+ config/mh-linux || die
+
+ # Append doxygen configuration to configure
+ sed -i \
+ -e 's:icudefs.mk:icudefs.mk Doxyfile:' \
+ configure.in || die
+ eautoreconf
}
src_configure() {
@@ -73,13 +67,13 @@ src_configure() {
# bootstrap for cross compilation
if tc-is-cross-compiler; then
CFLAGS="" CXXFLAGS="" ASFLAGS="" LDFLAGS="" \
- CC=$(tc-getBUILD_CC) CXX=$(tc-getBUILD_CXX) AR=$(tc-getBUILD_AR) \
- RANLIB=$(tc-getBUILD_RANLIB) LD=$(tc-getBUILD_LD) \
+ CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" AR="$(tc-getBUILD_AR)" \
+ RANLIB="$(tc-getBUILD_RANLIB)" LD="$(tc-getBUILD_LD)" \
./configure --disable-renaming --disable-debug \
--disable-samples --enable-static || die
emake
mkdir -p "${WORKDIR}/host/"
- cp -a {bin,lib,config} "${WORKDIR}/host/"
+ cp -a {bin,lib,config,tools} "${WORKDIR}/host/"
emake clean
cross_opts="--with-cross-build=${WORKDIR}/host"
@@ -93,6 +87,15 @@ src_configure() {
${cross_opts}
}
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen -u Doxyfile || die
+ doxygen Doxyfile || die
+ fi
+}
+
src_test() {
# INTLTEST_OPTS: intltest options
# -e: Exhaustive testing
@@ -112,8 +115,6 @@ src_install() {
dohtml ../readme.html
dodoc ../unicode-license.txt
- if use doc; then
- insinto /usr/share/doc/${PF}/html/api
- doins -r "${WORKDIR}/docs/"*
- fi
+
+ use doc && dohtml -p api -r doc/html/
}