summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2012-05-24 20:50:26 +0000
committerIan Whyman <thev00d00@gentoo.org>2012-05-24 20:50:26 +0000
commit3393f7eca2a9349fc0e3a9cdbe9dc383f5650604 (patch)
treeb1bf42b8b19b62f7e24aba2e618d2191f64ef749 /dev-libs/libcec
parent2.1.10.63 version bump. This fixes bug #416431 (absolute symlink adjustment (diff)
downloadgentoo-2-3393f7eca2a9349fc0e3a9cdbe9dc383f5650604.tar.gz
gentoo-2-3393f7eca2a9349fc0e3a9cdbe9dc383f5650604.tar.bz2
gentoo-2-3393f7eca2a9349fc0e3a9cdbe9dc383f5650604.zip
Version Bump
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libcec')
-rw-r--r--dev-libs/libcec/ChangeLog7
-rw-r--r--dev-libs/libcec/libcec-1.6.3.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-libs/libcec/ChangeLog b/dev-libs/libcec/ChangeLog
index 42b1c8f2d328..eb89e5036f70 100644
--- a/dev-libs/libcec/ChangeLog
+++ b/dev-libs/libcec/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libcec
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcec/ChangeLog,v 1.7 2012/05/22 22:53:41 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcec/ChangeLog,v 1.8 2012/05/24 20:50:26 thev00d00 Exp $
+
+*libcec-1.6.3 (24 May 2012)
+
+ 24 May 2012; Ian Whyman <thev00d00@gentoo.org> +libcec-1.6.3.ebuild:
+ Bump to latest
22 May 2012; Jeff Horelick <jdhore@gentoo.org> libcec-1.6.2.ebuild:
marked x86 per bug 415907
diff --git a/dev-libs/libcec/libcec-1.6.3.ebuild b/dev-libs/libcec/libcec-1.6.3.ebuild
new file mode 100644
index 000000000000..bcb8072c2918
--- /dev/null
+++ b/dev-libs/libcec/libcec-1.6.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcec/libcec-1.6.3.ebuild,v 1.1 2012/05/24 20:50:26 thev00d00 Exp $
+
+EAPI=4
+
+inherit autotools linux-info vcs-snapshot
+
+DESCRIPTION="Library for communicating with the Pulse-Eight USB HDMI-CEC Adaptor"
+HOMEPAGE="http://libcec.pulse-eight.com"
+SRC_URI="http://github.com/Pulse-Eight/${PN}/tarball/${P} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=sys-fs/udev-151"
+DEPEND="${RDEPEND}
+ dev-libs/lockdev
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~USB_ACM"
+
+src_prepare() {
+ sed -i '/^CXXFLAGS/s:-fPIC::' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete
+}