summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-12-01 16:37:13 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-12-01 16:37:13 +0000
commit551d56ca13d71b82690fa858dfaeeb1d8ec26961 (patch)
tree5593ed49f2d111cb6a9d66a9e702587f019cb860 /dev-libs/libee
parentFix missing RDEPEND. Fix license (diff)
downloadgentoo-2-551d56ca13d71b82690fa858dfaeeb1d8ec26961.tar.gz
gentoo-2-551d56ca13d71b82690fa858dfaeeb1d8ec26961.tar.bz2
gentoo-2-551d56ca13d71b82690fa858dfaeeb1d8ec26961.zip
Fix usage of autotools-utils.eclass, bug 392093. Thanks to mgorny and slepnoga
(Portage version: 2.1.10.33/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libee')
-rw-r--r--dev-libs/libee/ChangeLog8
-rw-r--r--dev-libs/libee/libee-0.3.2-r1.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-libs/libee/ChangeLog b/dev-libs/libee/ChangeLog
index ce2bfdd22428..37cacb24b040 100644
--- a/dev-libs/libee/ChangeLog
+++ b/dev-libs/libee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libee
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libee/ChangeLog,v 1.3 2011/11/26 19:33:47 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libee/ChangeLog,v 1.4 2011/12/01 16:37:13 maksbotan Exp $
+
+*libee-0.3.2-r1 (01 Dec 2011)
+
+ 01 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> +libee-0.3.2-r1.ebuild:
+ Fix usage of autotools-utils.eclass, bug 392093. Thanks to mgorny and
+ slepnoga
*libee-0.3.2 (26 Nov 2011)
diff --git a/dev-libs/libee/libee-0.3.2-r1.ebuild b/dev-libs/libee/libee-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..d9fc9a09236b
--- /dev/null
+++ b/dev-libs/libee/libee-0.3.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libee/libee-0.3.2-r1.ebuild,v 1.1 2011/12/01 16:37:13 maksbotan Exp $
+
+EAPI=4
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils
+
+DESCRIPTION="An Event Expression Library inspired by CEE"
+HOMEPAGE="http://www.libee.org"
+SRC_URI="http://www.libee.org/files/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~x86"
+IUSE="debug static-libs"
+
+DEPEND="dev-libs/libxml2
+ dev-libs/libestr"
+RDEPEND="${DEPEND}"
+
+DOCS=(INSTALL ChangeLog)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ --enable-testbench
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile -j1
+}