summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-07-03 16:55:05 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-07-03 16:55:05 +0000
commit9a3f14a507855172fa478efb473e5551f757a517 (patch)
treeb7d044f6c3d799d1f49d701cb918a01f3d519d73 /dev-libs/libev/libev-3.90-r2.ebuild
parentRevision bump with bugfixes (diff)
downloadgentoo-2-9a3f14a507855172fa478efb473e5551f757a517.tar.gz
gentoo-2-9a3f14a507855172fa478efb473e5551f757a517.tar.bz2
gentoo-2-9a3f14a507855172fa478efb473e5551f757a517.zip
Fixed compilation error in ev++.h, bug #325391.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libev/libev-3.90-r2.ebuild')
-rw-r--r--dev-libs/libev/libev-3.90-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/libev/libev-3.90-r2.ebuild b/dev-libs/libev/libev-3.90-r2.ebuild
new file mode 100644
index 000000000000..51460459b61f
--- /dev/null
+++ b/dev-libs/libev/libev-3.90-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/libev-3.90-r2.ebuild,v 1.1 2010/07/03 16:55:04 matsuu Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+MY_P="${P/0}"
+DESCRIPTION="A high-performance event loop/event model with lots of feature"
+HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
+SRC_URI="http://dist.schmorp.de/libev/${MY_P}.tar.gz
+ http://dist.schmorp.de/libev/Attic/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="elibc_glibc"
+
+# Bug #283558
+DEPEND="elibc_glibc? ( >=sys-libs/glibc-2.9_p20081201 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.42-gentoo.patch" \
+ "${FILESDIR}/${P}-ev++.patch"
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc Changes README || die
+}