summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-31 13:28:51 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-31 13:28:51 +0000
commit5d8a19fae7a5ad1e82a7923112762303ec8f679a (patch)
treef2a974148815bd75cd760fad150d9f3ea2f6a48d /dev-libs/libexplain
parentAdd ~x86-fbsd. (diff)
downloadgentoo-2-5d8a19fae7a5ad1e82a7923112762303ec8f679a.tar.gz
gentoo-2-5d8a19fae7a5ad1e82a7923112762303ec8f679a.tar.bz2
gentoo-2-5d8a19fae7a5ad1e82a7923112762303ec8f679a.zip
dev-libs/libexplain: Handle docs correctly
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-libs/libexplain')
-rw-r--r--dev-libs/libexplain/ChangeLog5
-rw-r--r--dev-libs/libexplain/libexplain-1.1.ebuild15
2 files changed, 16 insertions, 4 deletions
diff --git a/dev-libs/libexplain/ChangeLog b/dev-libs/libexplain/ChangeLog
index f1d17b0078c6..ee788e306ce8 100644
--- a/dev-libs/libexplain/ChangeLog
+++ b/dev-libs/libexplain/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/libexplain
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/ChangeLog,v 1.23 2013/01/31 13:16:20 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/ChangeLog,v 1.24 2013/01/31 13:28:51 jlec Exp $
+
+ 31 Jan 2013; Justin Lecher <jlec@gentoo.org> libexplain-1.1.ebuild:
+ Handle docs correctly
31 Jan 2013; Justin Lecher <jlec@gentoo.org> libexplain-0.52.ebuild,
libexplain-1.0.ebuild, libexplain-1.1.ebuild:
diff --git a/dev-libs/libexplain/libexplain-1.1.ebuild b/dev-libs/libexplain/libexplain-1.1.ebuild
index 48df500e36d7..c6f8f27b16bc 100644
--- a/dev-libs/libexplain/libexplain-1.1.ebuild
+++ b/dev-libs/libexplain/libexplain-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/libexplain-1.1.ebuild,v 1.2 2013/01/31 13:16:20 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/libexplain-1.1.ebuild,v 1.3 2013/01/31 13:28:51 jlec Exp $
EAPI=5
@@ -18,7 +18,7 @@ SRC_URI="http://libexplain.sourceforge.net/${MY_P}.tar.gz"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="GPL-3 LGPL-3"
-IUSE="static-libs"
+IUSE="doc static-libs"
RDEPEND="
sys-libs/libcap
@@ -26,7 +26,11 @@ RDEPEND="
sys-process/lsof"
DEPEND="${RDEPEND}
>=sys-kernel/linux-headers-2.6.35
- app-text/ghostscript-gpl"
+ doc? (
+ app-text/ghostscript-gpl
+ sys-apps/groff
+ )
+"
S=${WORKDIR}/${MY_P}
@@ -49,3 +53,8 @@ src_prepare() {
autotools-utils_src_prepare
}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile all-doc
+}