summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-01-04 19:36:43 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-01-04 19:36:43 +0000
commita0abf81766332366b54e807bb8cfb7e8819dd83b (patch)
tree6081da6bdcc8189335bc1fc0fd99001478e7f5f0 /dev-libs/libgcrypt
parentAdd dev-libs/libgcrypt:idea (diff)
downloadgentoo-2-a0abf81766332366b54e807bb8cfb7e8819dd83b.tar.gz
gentoo-2-a0abf81766332366b54e807bb8cfb7e8819dd83b.tar.bz2
gentoo-2-a0abf81766332366b54e807bb8cfb7e8819dd83b.zip
Add idea algirithm patch, modified version of http://www.kfwebs.net/articles/article/42/GnuPG-2.0---IDEA-support, bug#159870
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-libs/libgcrypt')
-rw-r--r--dev-libs/libgcrypt/ChangeLog11
-rw-r--r--dev-libs/libgcrypt/files/digest-libgcrypt-1.2.3-r19
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.2.3-r1.ebuild81
3 files changed, 99 insertions, 2 deletions
diff --git a/dev-libs/libgcrypt/ChangeLog b/dev-libs/libgcrypt/ChangeLog
index 8a03bb2cb476..85e849c99398 100644
--- a/dev-libs/libgcrypt/ChangeLog
+++ b/dev-libs/libgcrypt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libgcrypt
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.81 2006/12/28 11:32:04 grobian Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.82 2007/01/04 19:36:43 alonbl Exp $
+
+*libgcrypt-1.2.3-r1 (04 Jan 2007)
+
+ 04 Jan 2007; Alon Bar-Lev <alonbl@gentoo.org> +libgcrypt-1.2.3-r1.ebuild:
+ Add idea algirithm patch, modified version of
+ http://www.kfwebs.net/articles/article/42/GnuPG-2.0---IDEA-support,
+ bug#159870
28 Dec 2006; Fabian Groffen <grobian@gentoo.org> libgcrypt-1.2.0.ebuild,
libgcrypt-1.2.1.ebuild, libgcrypt-1.2.1-r1.ebuild, libgcrypt-1.2.2.ebuild,
diff --git a/dev-libs/libgcrypt/files/digest-libgcrypt-1.2.3-r1 b/dev-libs/libgcrypt/files/digest-libgcrypt-1.2.3-r1
new file mode 100644
index 000000000000..65ae49faf878
--- /dev/null
+++ b/dev-libs/libgcrypt/files/digest-libgcrypt-1.2.3-r1
@@ -0,0 +1,9 @@
+MD5 5cf59068f593221bf94dc962630bd84d libgcrypt-1.2.1-patches.tar.gz 2631
+RMD160 314b601285d48bd57b89dca1e20779256c7ed3e4 libgcrypt-1.2.1-patches.tar.gz 2631
+SHA256 f1900ed55883dc8619fd4e5eabe16cb463873884683bbeb9c9a6d9dc53a18ed6 libgcrypt-1.2.1-patches.tar.gz 2631
+MD5 06635a645f187ed233f28b5bc4c5a442 libgcrypt-1.2.3-idea.diff.bz2 2917
+RMD160 33ebc7c13cecb58e6260f08fe227e88bd9d65eb7 libgcrypt-1.2.3-idea.diff.bz2 2917
+SHA256 7010751217c4c42e0fd58ea6bb386b28a979287108068b17ca383d41eb70d498 libgcrypt-1.2.3-idea.diff.bz2 2917
+MD5 64304da2d9e21239246c66f1d449b2c6 libgcrypt-1.2.3.tar.gz 985735
+RMD160 6e6290ec4bb89e19ac312e76d0f0a12856bfe3bc libgcrypt-1.2.3.tar.gz 985735
+SHA256 2b384172b54074aef4ec23b3fcc8292c86c7c4fb0efb943e7dea9d886a1d4846 libgcrypt-1.2.3.tar.gz 985735
diff --git a/dev-libs/libgcrypt/libgcrypt-1.2.3-r1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..a26274eaeff1
--- /dev/null
+++ b/dev-libs/libgcrypt/libgcrypt-1.2.3-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.2.3-r1.ebuild,v 1.1 2007/01/04 19:36:43 alonbl Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="general purpose crypto library based on the code used in GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/libgcrypt/${P}.tar.gz
+ mirror://gentoo/${PN}-1.2.1-patches.tar.gz
+ !bindist? ( idea? mirror://gentoo/${P}-idea.diff.bz2 )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls bindist idea"
+
+RDEPEND="nls? ( virtual/libintl )
+ dev-libs/libgpg-error"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ epunt_cxx
+
+ # fix for miss detection of 32 bit ppc
+ cd "${S}"
+ epatch "${WORKDIR}"/${PN}-1.2.1-ppc64-fix.patch
+
+ if use idea; then
+ if use bindist; then
+ einfo "Skipping IDEA support to comply with binary distribution (bug #148907)."
+ else
+ ewarn "Please read http://www.gnupg.org/(en)/faq/why-not-idea.html"
+ epatch "${WORKDIR}/${P}-idea.diff"
+ fi
+ fi
+
+ eautoreconf
+}
+
+src_compile() {
+ local myconf
+
+ use ppc64 && myconf="${myconf} --disable-asm"
+
+ econf $(use_enable nls) --disable-dependency-tracking --with-pic \
+ --enable-noexecstack ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README* THANKS TODO VERSION
+
+ # backwards compat symlinks
+ dosym libgcrypt.so.11 /usr/lib/libgcrypt.so.7
+}
+
+pkg_postinst() {
+ if use !bindist && use idea; then
+ einfo "-----------------------------------------------------------------------------------"
+ einfo "IDEA"
+ ewarn "you have compiled ${PN} with support for the IDEA algorithm, this code"
+ ewarn "is distributed under the GPL in countries where it is permitted to do so"
+ ewarn "by law."
+ einfo
+ einfo "Please read http://www.gnupg.org/(en)/faq/why-not-idea.html for more information."
+ einfo
+ ewarn "If you are in a country where the IDEA algorithm is patented, you are permitted"
+ ewarn "to use it at no cost for 'non revenue generating data transfer between private"
+ ewarn "individuals'."
+ einfo
+ einfo "Countries where the patent applies are listed here"
+ einfo "http://www.mediacrypt.com/_contents/10_idea/101030_ea_pi.asp"
+ einfo
+ einfo "Further information and other licenses are availble from http://www.mediacrypt.com/"
+ einfo "-----------------------------------------------------------------------------------"
+ fi
+}