summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-11-21 23:27:46 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-11-21 23:27:46 +0000
commitb903ed94600806fb2a3104c40dc92758d451e7c3 (patch)
treeb8b26e477c71e6f428fa8c0f63829622a185e163 /dev-libs/libgee
parentstable ppc, bug #443824, thanks peratu (diff)
downloadgentoo-2-b903ed94600806fb2a3104c40dc92758d451e7c3.tar.gz
gentoo-2-b903ed94600806fb2a3104c40dc92758d451e7c3.tar.bz2
gentoo-2-b903ed94600806fb2a3104c40dc92758d451e7c3.zip
Version bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-libs/libgee')
-rw-r--r--dev-libs/libgee/ChangeLog7
-rw-r--r--dev-libs/libgee/libgee-0.8.2.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-libs/libgee/ChangeLog b/dev-libs/libgee/ChangeLog
index 53250170a11a..e2f764d0e767 100644
--- a/dev-libs/libgee/ChangeLog
+++ b/dev-libs/libgee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgee
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/ChangeLog,v 1.54 2012/11/21 23:19:05 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/ChangeLog,v 1.55 2012/11/21 23:27:46 eva Exp $
+
+*libgee-0.8.2 (21 Nov 2012)
+
+ 21 Nov 2012; Gilles Dartiguelongue <eva@gentoo.org> +libgee-0.8.2.ebuild:
+ Version bump.
*libgee-0.6.6.1 (21 Nov 2012)
diff --git a/dev-libs/libgee/libgee-0.8.2.ebuild b/dev-libs/libgee/libgee-0.8.2.ebuild
new file mode 100644
index 000000000000..fbc207fb25fe
--- /dev/null
+++ b/dev-libs/libgee/libgee-0.8.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/libgee-0.8.2.ebuild,v 1.1 2012/11/21 23:27:46 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.18"
+
+inherit gnome2 multilib vala
+
+DESCRIPTION="GObject-based interfaces and classes for commonly used data structures."
+HOMEPAGE="http://live.gnome.org/Libgee"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.8"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-linux"
+IUSE="+introspection"
+
+# FIXME: add doc support, requires valadoc
+RDEPEND="
+ >=dev-libs/glib-2.12:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-lang/vala-0.17.5
+ $(vala_depend)"
+
+DOCS="AUTHORS ChangeLog* MAINTAINERS NEWS README"
+
+src_configure() {
+ G2CONF="${G2CONF} $(use_enable introspection)"
+ gnome2_src_configure
+}
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}