summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 16:48:20 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 16:48:20 +0000
commitbbe58a154ce057bd07b7b100d738d25bb95a7acd (patch)
tree019c203160f28a33f6f035cd4a67b23091b3386d /dev-libs/libgee
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-bbe58a154ce057bd07b7b100d738d25bb95a7acd.tar.gz
gentoo-2-bbe58a154ce057bd07b7b100d738d25bb95a7acd.tar.bz2
gentoo-2-bbe58a154ce057bd07b7b100d738d25bb95a7acd.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/libgee')
-rw-r--r--dev-libs/libgee/ChangeLog7
-rw-r--r--dev-libs/libgee/libgee-0.10.0.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-libs/libgee/ChangeLog b/dev-libs/libgee/ChangeLog
index 09e6ea9f67cf..3366af70876a 100644
--- a/dev-libs/libgee/ChangeLog
+++ b/dev-libs/libgee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgee
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/ChangeLog,v 1.64 2013/03/28 15:50:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/ChangeLog,v 1.65 2013/03/28 16:48:20 pacho Exp $
+
+*libgee-0.10.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +libgee-0.10.0.ebuild:
+ Version bump for Gnome 3.8
28 Mar 2013; Agostino Sarubbo <ago@gentoo.org> libgee-0.6.7.ebuild,
libgee-0.8.4.ebuild:
diff --git a/dev-libs/libgee/libgee-0.10.0.ebuild b/dev-libs/libgee/libgee-0.10.0.ebuild
new file mode 100644
index 000000000000..451cff719aa6
--- /dev/null
+++ b/dev-libs/libgee/libgee-0.10.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/libgee-0.10.0.ebuild,v 1.1 2013/03/28 16:48:20 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.18"
+
+inherit gnome2 multilib vala
+
+DESCRIPTION="GObject-based interfaces and classes for commonly used data structures"
+HOMEPAGE="https://live.gnome.org/Libgee"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.8"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-linux"
+IUSE="+introspection"
+
+# FIXME: add doc support, requires valadoc
+RDEPEND=">=dev-libs/glib-2.32:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ $(vala_depend)"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog* MAINTAINERS NEWS README"
+ gnome2_src_configure $(use_enable introspection)
+}