summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-08-16 14:55:32 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-08-16 14:55:32 +0000
commit6581a6e3d8df33483bf458d000d39b778a62de75 (patch)
treeebbcc2a64662e4e98bec6b585981b5b1aa2036f6 /dev-libs/libindicate-qt/files
parentRemove old; bump latest to EAPI 4; remove FAKEGEM_NAME; use short syntax for ... (diff)
downloadgentoo-2-6581a6e3d8df33483bf458d000d39b778a62de75.tar.gz
gentoo-2-6581a6e3d8df33483bf458d000d39b778a62de75.tar.bz2
gentoo-2-6581a6e3d8df33483bf458d000d39b778a62de75.zip
Add patch by György Balló <ballogyor@gmail.com> to make building of tests optional. Fixes bug #431588.
(Portage version: 2.1.11.10/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libindicate-qt/files')
-rw-r--r--dev-libs/libindicate-qt/files/libindicate-qt-0.2.5.91-optionaltests.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/libindicate-qt/files/libindicate-qt-0.2.5.91-optionaltests.patch b/dev-libs/libindicate-qt/files/libindicate-qt-0.2.5.91-optionaltests.patch
new file mode 100644
index 000000000000..70a54fdbe6f8
--- /dev/null
+++ b/dev-libs/libindicate-qt/files/libindicate-qt-0.2.5.91-optionaltests.patch
@@ -0,0 +1,24 @@
+https://code.launchpad.net/~ballogy/libindicate-qt/make-examples-and-tests-optional/+merge/82829
+=== modified file 'CMakeLists.txt'
+--- CMakeLists.txt 2010-03-08 09:02:19 +0000
++++ CMakeLists.txt 2011-11-20 20:28:23 +0000
+@@ -36,8 +36,16 @@
+ DESTINATION lib${LIB_SUFFIX}/pkgconfig)
+
+ add_subdirectory(src)
+-add_subdirectory(examples)
+-add_subdirectory(tests)
++
++option( BUILD_EXAMPLES "build examples" ON )
++if (BUILD_EXAMPLES)
++ add_subdirectory(examples)
++endif (BUILD_EXAMPLES)
++
++option( BUILD_TESTS "build tests" ON )
++if (BUILD_TESTS)
++ add_subdirectory(tests)
++endif (BUILD_TESTS)
+
+ # Packaging
+ set(ARCHIVE_NAME libindicate-qt-${indicate_qt_VERSION})
+