summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2012-02-01 17:54:16 +0000
committerDaniel Pielmeier <billie@gentoo.org>2012-02-01 17:54:16 +0000
commit033d2a075b267916a69742c3dadf08a9668142d2 (patch)
treefb3e7dbc1aadf24f627a2091d93cf5abd2ae79ce /dev-libs/libisofs
parentVersion bump. (diff)
downloadgentoo-2-033d2a075b267916a69742c3dadf08a9668142d2.tar.gz
gentoo-2-033d2a075b267916a69742c3dadf08a9668142d2.tar.bz2
gentoo-2-033d2a075b267916a69742c3dadf08a9668142d2.zip
Version bump.
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'dev-libs/libisofs')
-rw-r--r--dev-libs/libisofs/ChangeLog7
-rw-r--r--dev-libs/libisofs/libisofs-1.2.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-libs/libisofs/ChangeLog b/dev-libs/libisofs/ChangeLog
index 12b2e38e502e..baef31adf005 100644
--- a/dev-libs/libisofs/ChangeLog
+++ b/dev-libs/libisofs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libisofs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisofs/ChangeLog,v 1.92 2012/01/27 19:12:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisofs/ChangeLog,v 1.93 2012/02/01 17:54:16 billie Exp $
+
+*libisofs-1.2.0 (01 Feb 2012)
+
+ 01 Feb 2012; Daniel Pielmeier <billie@gentoo.org> +libisofs-1.2.0.ebuild:
+ Version bump.
27 Jan 2012; Agostino Sarubbo <ago@gentoo.org> libisofs-1.1.6.ebuild:
Stable for amd64, wrt bug #400017
diff --git a/dev-libs/libisofs/libisofs-1.2.0.ebuild b/dev-libs/libisofs/libisofs-1.2.0.ebuild
new file mode 100644
index 000000000000..d1e2128f0513
--- /dev/null
+++ b/dev-libs/libisofs/libisofs-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisofs/libisofs-1.2.0.ebuild,v 1.1 2012/02/01 17:54:16 billie Exp $
+
+EAPI=4
+
+DESCRIPTION="libisofs is an open-source library for reading, mastering and writing optical discs."
+HOMEPAGE="http://libburnia-project.org/"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="acl debug static-libs verbose-debug xattr zlib"
+
+RDEPEND="acl? ( virtual/acl )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
+ $(use_enable verbose-debug) \
+ $(use_enable acl libacl) \
+ $(use_enable xattr) \
+ $(use_enable zlib) \
+ --disable-libjte \
+ --disable-ldconfig-at-install
+}
+
+src_install() {
+ default
+
+ dodoc Roadmap doc/{checksums.txt,susp_aaip*,Tutorial,zisofs_format.txt}
+
+ find "${D}" -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}