summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-04-20 05:44:09 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-04-20 05:44:09 +0000
commitc08b53cb0e48fd80ebafcebc3d67ef406a610083 (patch)
tree63bed58f00f67a6c8981a7de3320e1ca41c0fcd1 /dev-libs/liblist/liblist-2.1.ebuild
parentSkip pkcs11/kerberos support when USE=static by Alon Bar-Lev #266404 by Jan P... (diff)
downloadgentoo-2-c08b53cb0e48fd80ebafcebc3d67ef406a610083.tar.gz
gentoo-2-c08b53cb0e48fd80ebafcebc3d67ef406a610083.tar.bz2
gentoo-2-c08b53cb0e48fd80ebafcebc3d67ef406a610083.zip
New ebuild for a generic list library, a required dependency for ferret.
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/liblist/liblist-2.1.ebuild')
-rw-r--r--dev-libs/liblist/liblist-2.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-libs/liblist/liblist-2.1.ebuild b/dev-libs/liblist/liblist-2.1.ebuild
new file mode 100644
index 000000000000..35be0f9a4ea3
--- /dev/null
+++ b/dev-libs/liblist/liblist-2.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblist/liblist-2.1.ebuild,v 1.1 2009/04/20 05:44:09 nerdboy Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="This package provides generic linked-list manipulation routines, plus queues and stacks."
+HOMEPAGE="http://www.gentoogeek.org/viewvc/C/liblist/"
+SRC_URI="http://www.gentoogeek.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:/usr/lib:/usr/$(get_libdir):g" Makefile \
+ examples/cache/Makefile || die "sed 1 failed"
+}
+
+src_compile() {
+ make CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ newman list.3 llist.3
+ newman stack.man lstack.3
+ newman queue.man lqueue.3
+ dolib.a liblist.a
+ insinto /usr/include
+ doins list.h queue.h stack.h
+ dodoc README
+
+ if use examples; then
+ dolib.a examples/cache/libcache.a
+ dobin examples/cache/cachetest
+ newman cache.3 lcache.3
+ insinto /usr/share/doc/${P}/examples
+ doins examples/{*.c,Makefile,README}
+ insinto /usr/share/doc/${P}/examples/cache
+ doins examples/cache/{*.c,Makefile,README}
+ doins
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${P}
+ doins paper/paper.ps
+ fi
+}
+
+pkg_postinst() {
+ elog "Note the man pages for this package have been renamed to avoid"
+ elog "name collisions with some system functions, however, the libs"
+ elog "and header files have not been changed."
+ elog "The new names are llist, lcache, lqueue, and lstack."
+}