summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2010-06-19 16:37:01 +0000
committerSteve Arnold <nerdboy@gentoo.org>2010-06-19 16:37:01 +0000
commit458b603682ce56e08eee7acc2bdc4663eaf85f89 (patch)
tree78d97e1bc50807f063878752758b224e8f3427df /dev-libs/liblist
parentMove gnome-keyring from RDEPEND to DEPEND. According to http://crbug.com/1235... (diff)
downloadgentoo-2-458b603682ce56e08eee7acc2bdc4663eaf85f89.tar.gz
gentoo-2-458b603682ce56e08eee7acc2bdc4663eaf85f89.tar.bz2
gentoo-2-458b603682ce56e08eee7acc2bdc4663eaf85f89.zip
Updated to new 'binki-version' who is now the upstream maintainer.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/liblist')
-rw-r--r--dev-libs/liblist/ChangeLog7
-rw-r--r--dev-libs/liblist/liblist-2.3.1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-libs/liblist/ChangeLog b/dev-libs/liblist/ChangeLog
index 651d42ac56c0..7aed7614a94c 100644
--- a/dev-libs/liblist/ChangeLog
+++ b/dev-libs/liblist/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/liblist
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblist/ChangeLog,v 1.3 2010/01/03 05:27:01 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblist/ChangeLog,v 1.4 2010/06/19 16:37:01 nerdboy Exp $
+
+*liblist-2.3.1 (19 Jun 2010)
+
+ 19 Jun 2010; Steve Arnold <nerdboy@gentoo.org> +liblist-2.3.1.ebuild:
+ Updated to new 'binki-version' who is now the upstream maintainer (yay).
03 Jan 2010; Steve Arnold <nerdboy@gentoo.org> liblist-2.1-r1.ebuild,
files/liblist-2.1-sharedlib.patch:
diff --git a/dev-libs/liblist/liblist-2.3.1.ebuild b/dev-libs/liblist/liblist-2.3.1.ebuild
new file mode 100644
index 000000000000..818b75459525
--- /dev/null
+++ b/dev-libs/liblist/liblist-2.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblist/liblist-2.3.1.ebuild,v 1.1 2010/06/19 16:37:01 nerdboy Exp $
+
+EAPI=2
+
+inherit multilib
+
+DESCRIPTION="This package provides generic linked-list manipulation routines, plus queues and stacks"
+HOMEPAGE="http://ohnopub.net/liblist"
+SRC_URI="ftp://ohnopublishing.net/mirror/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples static-libs"
+
+src_configure() {
+ econf $(use_enable doc docs) \
+ $(use_enable examples) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc README || die
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/examples
+ doins examples/{*.c,Makefile,README} || die
+ insinto /usr/share/doc/${P}/examples/cache
+ doins examples/cache/{*.c,README} || die
+ fi
+
+ if ! use static-libs; then
+ rm -v "${D}"/usr/$(get_libdir)/liblist.la || die
+ if use examples; then
+ rm -v "${D}"/usr/$(get_libdir)/libcache.la || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ elog "Note the man pages for this package have been renamed to avoid"
+ elog "name collisions with some system functions, however, the libs"
+ elog "and header files have not been changed."
+ elog "The new names are llist, lcache, lqueue, and lstack."
+}