summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-07-24 04:20:32 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-07-24 04:20:32 +0000
commit0a762dc4cdff81b6f3ba444812a626b3455904e1 (patch)
treeb7f0a91b000257b864805536c1105f5cc1f6fe6c /dev-libs/libofx
parentAdd app-editors/vim dependency for ex, bug #375397. (diff)
downloadgentoo-2-0a762dc4cdff81b6f3ba444812a626b3455904e1.tar.gz
gentoo-2-0a762dc4cdff81b6f3ba444812a626b3455904e1.tar.bz2
gentoo-2-0a762dc4cdff81b6f3ba444812a626b3455904e1.zip
Version bump.
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libofx')
-rw-r--r--dev-libs/libofx/ChangeLog7
-rw-r--r--dev-libs/libofx/libofx-0.9.4.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-libs/libofx/ChangeLog b/dev-libs/libofx/ChangeLog
index b36c0e31fdbb..99512df444bd 100644
--- a/dev-libs/libofx/ChangeLog
+++ b/dev-libs/libofx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libofx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/ChangeLog,v 1.57 2011/07/18 15:06:45 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/ChangeLog,v 1.58 2011/07/24 04:20:32 ssuominen Exp $
+
+*libofx-0.9.4 (24 Jul 2011)
+
+ 24 Jul 2011; Samuli Suominen <ssuominen@gentoo.org> +libofx-0.9.4.ebuild:
+ Version bump.
18 Jul 2011; Andreas K. Huettel <dilfridge@gentoo.org> libofx-0.9.2.ebuild:
Test phase requires gnupg, bug 362263
diff --git a/dev-libs/libofx/libofx-0.9.4.ebuild b/dev-libs/libofx/libofx-0.9.4.ebuild
new file mode 100644
index 000000000000..dfb0274da133
--- /dev/null
+++ b/dev-libs/libofx/libofx-0.9.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/libofx-0.9.4.ebuild,v 1.1 2011/07/24 04:20:32 ssuominen Exp $
+
+EAPI=4
+
+DESCRIPTION="A library to support the Open Financial eXchange XML format"
+HOMEPAGE="http://libofx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs test"
+
+RDEPEND=">=app-text/opensp-1.5
+ dev-cpp/libxmlpp:2.6
+ >=net-misc/curl-7.9.7"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? ( app-crypt/gnupg )"
+
+src_prepare() {
+ # Be sure DTD gets installed in correct path after redefining docdir in install
+ sed -i \
+ -e 's:$(DESTDIR)$(docdir):$(DESTDIR)$(LIBOFX_DTD_DIR):' \
+ dtd/Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-doxygen
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
+
+ rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL}
+ find "${D}" -name '*.la' -exec rm -f {} +
+}