summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-04-28 02:22:45 +0000
committerMike Frysinger <vapier@gentoo.org>2013-04-28 02:22:45 +0000
commitf58c744ddc2240b05c2f26ee477c0faccf4e736b (patch)
tree179f4e4ef63ff4dd3367137d508cbf3b98669e46 /dev-libs/libpcre
parenttypo fix (diff)
downloadgentoo-2-f58c744ddc2240b05c2f26ee477c0faccf4e736b.tar.gz
gentoo-2-f58c744ddc2240b05c2f26ee477c0faccf4e736b.tar.bz2
gentoo-2-f58c744ddc2240b05c2f26ee477c0faccf4e736b.zip
Add -pthread to static pkg-config entries when appropriate #454478 by Till Heikamp.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'dev-libs/libpcre')
-rw-r--r--dev-libs/libpcre/ChangeLog9
-rw-r--r--dev-libs/libpcre/libpcre-8.32-r1.ebuild77
-rw-r--r--dev-libs/libpcre/libpcre-8.32.ebuild6
3 files changed, 90 insertions, 2 deletions
diff --git a/dev-libs/libpcre/ChangeLog b/dev-libs/libpcre/ChangeLog
index d40b16f0ef63..bc0ea6a05049 100644
--- a/dev-libs/libpcre/ChangeLog
+++ b/dev-libs/libpcre/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libpcre
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/ChangeLog,v 1.209 2013/02/21 05:15:55 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/ChangeLog,v 1.210 2013/04/28 02:22:45 vapier Exp $
+
+*libpcre-8.32-r1 (28 Apr 2013)
+
+ 28 Apr 2013; Mike Frysinger <vapier@gentoo.org> +libpcre-8.32-r1.ebuild,
+ libpcre-8.32.ebuild:
+ Add -pthread to static pkg-config entries when appropriate #454478 by Till
+ Heikamp.
21 Feb 2013; Zac Medico <zmedico@gentoo.org> libpcre-8.32.ebuild:
Add ~arm-linux keyword.
diff --git a/dev-libs/libpcre/libpcre-8.32-r1.ebuild b/dev-libs/libpcre/libpcre-8.32-r1.ebuild
new file mode 100644
index 000000000000..35100fdf9567
--- /dev/null
+++ b/dev-libs/libpcre/libpcre-8.32-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-8.32-r1.ebuild,v 1.1 2013/04/28 02:22:44 vapier Exp $
+
+EAPI="4"
+
+inherit eutils multilib libtool flag-o-matic toolchain-funcs
+
+DESCRIPTION="Perl-compatible regular expression library"
+HOMEPAGE="http://www.pcre.org/"
+MY_P="pcre-${PV/_rc/-RC}"
+if [[ ${PV} != *_rc* ]] ; then
+ # Only the final releases are available here.
+ SRC_URI="mirror://sourceforge/pcre/${MY_P}.tar.bz2
+ ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
+else
+ SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/Testing/${MY_P}.tar.bz2"
+fi
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 +cxx +jit libedit pcre16 +readline +recursion-limit static-libs unicode zlib"
+REQUIRED_USE="readline? ( !libedit )
+ libedit? ( !readline )"
+
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )
+ libedit? ( dev-libs/libedit )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ userland_GNU? ( >=sys-apps/findutils-4.4.0 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ local pc
+ for pc in *.pc.in ; do
+ echo "Libs.private: @PTHREAD_CFLAGS@" >> ${pc} #454478
+ done
+ sed -i -e "s:-lpcre ::" libpcrecpp.pc.in || die
+ elibtoolize
+}
+
+src_configure() {
+ [[ ${CHOST} == *-mint* ]] && append-cppflags -D_GNU_SOURCE
+ econf \
+ --with-match-limit-recursion=$(usex recursion-limit 8192 MATCH_LIMIT) \
+ $(use_enable bzip2 pcregrep-libbz2) \
+ $(use_enable cxx cpp) \
+ $(use_enable jit) $(use_enable jit pcregrep-jit) \
+ $(use_enable pcre16) \
+ $(use_enable libedit pcretest-libedit) \
+ $(use_enable readline pcretest-libreadline) \
+ $(use_enable static-libs static) \
+ $(use_enable unicode utf) $(use_enable unicode unicode-properties) \
+ $(use_enable zlib pcregrep-libz) \
+ --enable-pcre8 \
+ --enable-shared \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ gen_usr_ldscript -a pcre
+ prune_libtool_files
+}
+
+pkg_preinst() {
+ preserve_old_lib /$(get_libdir)/libpcre.so.0
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /$(get_libdir)/libpcre.so.0
+}
diff --git a/dev-libs/libpcre/libpcre-8.32.ebuild b/dev-libs/libpcre/libpcre-8.32.ebuild
index a04228f1edf6..90b8a85f7bdf 100644
--- a/dev-libs/libpcre/libpcre-8.32.ebuild
+++ b/dev-libs/libpcre/libpcre-8.32.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-8.32.ebuild,v 1.2 2013/02/21 05:15:55 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-8.32.ebuild,v 1.3 2013/04/28 02:22:45 vapier Exp $
EAPI="4"
@@ -35,6 +35,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
src_prepare() {
+ local pc
+ for pc in *.pc.in ; do
+ echo "Libs.private: @PTHREAD_CFLAGS@" >> ${pc} #454478
+ done
sed -i -e "s:-lpcre ::" libpcrecpp.pc.in || die
elibtoolize
}