summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYi Quang <khai@gentoo.org>2004-10-09 21:20:19 +0000
committerYi Quang <khai@gentoo.org>2004-10-09 21:20:19 +0000
commite3971ff59306248ad1597043c0e232375492e514 (patch)
tree40c2894f896745c894f5659eb63ed20728113d7d /dev-libs/libsigc++/libsigc++-2.0.5.ebuild
parentStable on sparc wrt security bug #66912. (Manifest recommit) (diff)
downloadgentoo-2-e3971ff59306248ad1597043c0e232375492e514.tar.gz
gentoo-2-e3971ff59306248ad1597043c0e232375492e514.tar.bz2
gentoo-2-e3971ff59306248ad1597043c0e232375492e514.zip
version bump, patch to fix compile with gcc-3.4
Diffstat (limited to 'dev-libs/libsigc++/libsigc++-2.0.5.ebuild')
-rw-r--r--dev-libs/libsigc++/libsigc++-2.0.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/libsigc++/libsigc++-2.0.5.ebuild b/dev-libs/libsigc++/libsigc++-2.0.5.ebuild
new file mode 100644
index 000000000000..305182d47faa
--- /dev/null
+++ b/dev-libs/libsigc++/libsigc++-2.0.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-2.0.5.ebuild,v 1.1 2004/10/09 21:20:19 khai Exp $
+
+DESCRIPTION="Typesafe callback system for standard C++"
+HOMEPAGE="http://libsigc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libsigc/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="1.3"
+KEYWORDS="~x86 ~ppc ~alpha amd64 ~sparc"
+IUSE="debug"
+inherit eutils
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gcc-3.4.patch
+}
+src_compile() {
+ local myconf
+ use debug \
+ && myconf="--enable-debug=yes" \
+ || myconf="--enable-debug=no"
+ # added libtoolize, add "-I scripts" to aclocal, autoconf before econf
+ # all these changes are necessary on amd64
+ # Danny van Dyk (kugelfang@gentoo.org)
+ libtoolize -c -f --automake
+ aclocal -I scripts
+ automake --gnu --add-missing
+ autoconf
+ econf ${myconf} || die
+ emake || die "emake failure"
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog COPYING* README INSTALL NEWS TODO
+}
+
+pkg_postinst() {
+ ewarn "To allow parallel installation of sig++-1.0, sig++-1.2, and sig++2.0"
+ ewarn "the header files are now installed in a version specific"
+ ewarn "subdirectory. Be sure to unmerge any libsig++ versions"
+ ewarn "< 1.0.4 that you may have previously installed."
+}