summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-12-22 14:23:51 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-12-22 14:23:51 +0000
commit23cf03d8ab3e47dac6135789d54bc53c39ac580e (patch)
tree273c662c3d72b5b51da503241988e8fecc055ad0 /dev-libs/libsmtp
parentStable on sparc (Manifest recommit) (diff)
downloadgentoo-2-23cf03d8ab3e47dac6135789d54bc53c39ac580e.tar.gz
gentoo-2-23cf03d8ab3e47dac6135789d54bc53c39ac580e.tar.bz2
gentoo-2-23cf03d8ab3e47dac6135789d54bc53c39ac580e.zip
Initial commit; needed for smtp support in dev-libs/log4cxx.
Diffstat (limited to 'dev-libs/libsmtp')
-rw-r--r--dev-libs/libsmtp/ChangeLog10
-rw-r--r--dev-libs/libsmtp/Manifest5
-rw-r--r--dev-libs/libsmtp/files/digest-libsmtp-0.81
-rw-r--r--dev-libs/libsmtp/files/libsmtp-0.8-gentoo.diff128
-rw-r--r--dev-libs/libsmtp/libsmtp-0.8.ebuild37
-rw-r--r--dev-libs/libsmtp/metadata.xml9
6 files changed, 190 insertions, 0 deletions
diff --git a/dev-libs/libsmtp/ChangeLog b/dev-libs/libsmtp/ChangeLog
new file mode 100644
index 000000000000..5f49bd52335f
--- /dev/null
+++ b/dev-libs/libsmtp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/libsmtp
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsmtp/ChangeLog,v 1.1 2004/12/22 14:23:51 ka0ttic Exp $
+
+*libsmtp-0.8 (22 Dec 2004)
+
+ 22 Dec 2004; Aaron Walker <ka0ttic@gentoo.org> +metadata.xml,
+ +files/libsmtp-0.8-gentoo.diff, +libsmtp-0.8.ebuild:
+ Initial commit; needed for smtp support in dev-libs/log4cxx.
+
diff --git a/dev-libs/libsmtp/Manifest b/dev-libs/libsmtp/Manifest
new file mode 100644
index 000000000000..4197879ac265
--- /dev/null
+++ b/dev-libs/libsmtp/Manifest
@@ -0,0 +1,5 @@
+MD5 8fa8e3793620af6edc731773bc5ffddc libsmtp-0.8.ebuild 772
+MD5 b41951ca7ae6eb577de22350abd13f92 ChangeLog 328
+MD5 f8d10f350e91f30316ea4e1bd1e76470 metadata.xml 254
+MD5 048850bcec357fbed8ef287a0bd8762c files/digest-libsmtp-0.8 63
+MD5 0c17bbeaf05fa9afc7f243f0c670e0a4 files/libsmtp-0.8-gentoo.diff 5082
diff --git a/dev-libs/libsmtp/files/digest-libsmtp-0.8 b/dev-libs/libsmtp/files/digest-libsmtp-0.8
new file mode 100644
index 000000000000..1287ecb82417
--- /dev/null
+++ b/dev-libs/libsmtp/files/digest-libsmtp-0.8
@@ -0,0 +1 @@
+MD5 2252e4f3c3e5498f626859e696b5f9e6 libsmtp-0.8.tar.gz 191362
diff --git a/dev-libs/libsmtp/files/libsmtp-0.8-gentoo.diff b/dev-libs/libsmtp/files/libsmtp-0.8-gentoo.diff
new file mode 100644
index 000000000000..72aede75384e
--- /dev/null
+++ b/dev-libs/libsmtp/files/libsmtp-0.8-gentoo.diff
@@ -0,0 +1,128 @@
+diff -urN libsmtp-0.8.orig/examples/multipart.c libsmtp-0.8/examples/multipart.c
+--- libsmtp-0.8.orig/examples/multipart.c 2004-12-22 08:22:05.415981248 -0500
++++ libsmtp-0.8/examples/multipart.c 2004-12-22 08:33:32.158580504 -0500
+@@ -341,4 +341,5 @@
+ /* Free the allocated struct mem */
+ libsmtp_free (mailsession);
+ return 0;
+-}
+\ No newline at end of file
++}
++
+diff -urN libsmtp-0.8.orig/examples/singlepart.c libsmtp-0.8/examples/singlepart.c
+--- libsmtp-0.8.orig/examples/singlepart.c 2004-12-22 08:22:05.434978360 -0500
++++ libsmtp-0.8/examples/singlepart.c 2004-12-22 08:33:32.159580352 -0500
+@@ -293,4 +293,5 @@
+ /* Free the allocated struct mem */
+ free (mailsession);
+ return 0;
+-}
+\ No newline at end of file
++}
++
+diff -urN libsmtp-0.8.orig/examples/smtpmail.c libsmtp-0.8/examples/smtpmail.c
+--- libsmtp-0.8.orig/examples/smtpmail.c 2004-12-22 08:22:05.511966656 -0500
++++ libsmtp-0.8/examples/smtpmail.c 2004-12-22 08:33:32.160580200 -0500
+@@ -247,4 +247,5 @@
+ /* Free the allocated struct mem */
+ libsmtp_free (mailsession);
+ return 0;
+-}
+\ No newline at end of file
++}
++
+diff -urN libsmtp-0.8.orig/include/libsmtp_mime.h libsmtp-0.8/include/libsmtp_mime.h
+--- libsmtp-0.8.orig/include/libsmtp_mime.h 2004-12-22 08:22:05.592954344 -0500
++++ libsmtp-0.8/include/libsmtp_mime.h 2004-12-22 08:33:22.892989088 -0500
+@@ -191,4 +191,5 @@
+ #define LIBSMTP_BADCHARSET 2055
+
+ #define LIBSMTP_MAX_MIME_ERRNO 2055
+-/* #endif LIBSMTP_USE_MIME */
+\ No newline at end of file
++/* #endif LIBSMTP_USE_MIME */
++
+diff -urN libsmtp-0.8.orig/mime/comm.c libsmtp-0.8/mime/comm.c
+--- libsmtp-0.8.orig/mime/comm.c 2004-12-22 08:22:04.856066368 -0500
++++ libsmtp-0.8/mime/comm.c 2004-12-22 08:33:05.151686176 -0500
+@@ -158,7 +158,7 @@
+ /* Text and message parts will have a charset setting */
+ if ((libsmtp_temp_part->Type==LIBSMTP_MIME_TEXT) ||
+ (libsmtp_temp_part->Type==LIBSMTP_MIME_MESSAGE))
+- if ((libsmtp_temp_string=libsmtp_int_lookup_mime_charset(libsmtp_temp_part)))
++ if ((libsmtp_temp_string=(char *)libsmtp_int_lookup_mime_charset(libsmtp_temp_part)))
+ {
+ g_string_sprintf (libsmtp_temp_gstring, "; charset=\"%s\"", \
+ libsmtp_temp_string);
+diff -urN libsmtp-0.8.orig/mime/parts.c libsmtp-0.8/mime/parts.c
+--- libsmtp-0.8.orig/mime/parts.c 2004-12-22 08:22:04.905058920 -0500
++++ libsmtp-0.8/mime/parts.c 2004-12-22 08:33:05.213676752 -0500
+@@ -396,7 +396,7 @@
+ /* Text and message parts will have a charset setting */
+ if ((libsmtp_temp_part->Type==LIBSMTP_MIME_TEXT) ||
+ (libsmtp_temp_part->Type==LIBSMTP_MIME_MESSAGE))
+- if ((libsmtp_temp_string=libsmtp_int_lookup_mime_charset(libsmtp_temp_part)))
++ if ((libsmtp_temp_string=(char *)libsmtp_int_lookup_mime_charset(libsmtp_temp_part)))
+ {
+ g_string_sprintf (libsmtp_temp_gstring, ";\r\n charset=\"%s\"", \
+ libsmtp_temp_string);
+diff -urN libsmtp-0.8.orig/smtp/libsmtp_comm.c libsmtp-0.8/smtp/libsmtp_comm.c
+--- libsmtp-0.8.orig/smtp/libsmtp_comm.c 2004-12-22 08:22:05.102028976 -0500
++++ libsmtp-0.8/smtp/libsmtp_comm.c 2004-12-22 08:32:35.081257576 -0500
+@@ -82,13 +82,13 @@
+ g_string_assign (libsmtp_gstring_read, libsmtp_int_rec_buffer);
+
+ /* Ok, take the first part of the response ... */
+- libsmtp_int_temp_buffer = strtok ((char *)libsmtp_int_rec_buffer, " ");
++ libsmtp_int_temp_buffer = (char *)strtok ((char *)libsmtp_int_rec_buffer, " ");
+
+ /* and extract the response code */
+ libsmtp_session->LastResponseCode = atoi(libsmtp_int_temp_buffer);
+
+ /* Then fetch the rest of the string and save it */
+- libsmtp_int_temp_buffer = strtok (NULL, "\0");
++ libsmtp_int_temp_buffer = (char *)strtok (NULL, "\0");
+ libsmtp_session->LastResponse = g_string_new (libsmtp_int_temp_buffer);
+ break;
+ }
+@@ -718,4 +718,5 @@
+ /* Wrong stage, dude ! */
+ libsmtp_session->ErrorCode = LIBSMTP_BADSTAGE;
+ return LIBSMTP_BADSTAGE;
+-}
+\ No newline at end of file
++}
++
+diff -urN libsmtp-0.8.orig/smtp/libsmtp_connection.c libsmtp-0.8/smtp/libsmtp_connection.c
+--- libsmtp-0.8.orig/smtp/libsmtp_connection.c 2004-12-22 08:22:05.188015904 -0500
++++ libsmtp-0.8/smtp/libsmtp_connection.c 2004-12-22 08:32:35.082257424 -0500
+@@ -206,4 +206,5 @@
+ }
+
+ return LIBSMTP_NOERR;
+-}
+\ No newline at end of file
++}
++
+diff -urN libsmtp-0.8.orig/smtp/libsmtp_data.c libsmtp-0.8/smtp/libsmtp_data.c
+--- libsmtp-0.8.orig/smtp/libsmtp_data.c 2004-12-22 08:22:05.078032624 -0500
++++ libsmtp-0.8/smtp/libsmtp_data.c 2004-12-22 08:32:35.090256208 -0500
+@@ -168,4 +168,5 @@
+ }
+
+ return LIBSMTP_NOERR;
+-}
+\ No newline at end of file
++}
++
+diff -urN libsmtp-0.8.orig/smtp/libsmtp_error.c libsmtp-0.8/smtp/libsmtp_error.c
+--- libsmtp-0.8.orig/smtp/libsmtp_error.c 2004-12-22 08:22:05.146022288 -0500
++++ libsmtp-0.8/smtp/libsmtp_error.c 2004-12-22 08:32:35.090256208 -0500
+@@ -110,4 +110,5 @@
+ return LIBSMTP_UNDEFERR;
+
+ return libsmtp_session->ErrorCode;
+-}
+\ No newline at end of file
++}
++
diff --git a/dev-libs/libsmtp/libsmtp-0.8.ebuild b/dev-libs/libsmtp/libsmtp-0.8.ebuild
new file mode 100644
index 000000000000..e067c7aab676
--- /dev/null
+++ b/dev-libs/libsmtp/libsmtp-0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsmtp/libsmtp-0.8.ebuild,v 1.1 2004/12/22 14:23:51 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="A small C library that allows direct SMTP connections conforming to RFC 822"
+HOMEPAGE="http://libsmtp.berlios.de/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND="virtual/libc
+ dev-libs/glib"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_install() {
+ dolib.a smtp/libsmtp.a mime/libsmtp_mime.a || die "dolib.a failed"
+ dodoc AUTHORS CHANGES INSTALL README doc/API doc/BUGS doc/MIME doc/TODO \
+ || die "dodoc failed"
+
+ if use doc ; then
+ cd ${S}/examples
+ rm -fr CVS
+ make clean
+ docinto examples
+ dodoc *
+ fi
+}
diff --git a/dev-libs/libsmtp/metadata.xml b/dev-libs/libsmtp/metadata.xml
new file mode 100644
index 000000000000..d31152aca840
--- /dev/null
+++ b/dev-libs/libsmtp/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ka0ttic@gentoo.org</email>
+ <name>Aaron Walker</name>
+ </maintainer>
+</pkgmetadata>