summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2010-12-10 13:22:38 +0000
committerDane Smith <c1pher@gentoo.org>2010-12-10 13:22:38 +0000
commit0fe379b22fdaeca7758651c491939b7355b72207 (patch)
treedd1e8befe1b17b9bebd8a9af942266fcf10e8750 /dev-libs/libtasn1/libtasn1-2.9-r1.ebuild
parentInitial commit, ebuild by g-cpan with some minor touchups. For the LINX engin... (diff)
downloadgentoo-2-0fe379b22fdaeca7758651c491939b7355b72207.tar.gz
gentoo-2-0fe379b22fdaeca7758651c491939b7355b72207.tar.bz2
gentoo-2-0fe379b22fdaeca7758651c491939b7355b72207.zip
Revbump for dev-libs/libtasn1. Removes automagic dependency on valgrind wrt bug 331951.
(Portage version: 2.2.0_alpha4/cvs/Linux i686)
Diffstat (limited to 'dev-libs/libtasn1/libtasn1-2.9-r1.ebuild')
-rw-r--r--dev-libs/libtasn1/libtasn1-2.9-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libtasn1/libtasn1-2.9-r1.ebuild b/dev-libs/libtasn1/libtasn1-2.9-r1.ebuild
new file mode 100644
index 000000000000..920392cbd700
--- /dev/null
+++ b/dev-libs/libtasn1/libtasn1-2.9-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtasn1/libtasn1-2.9-r1.ebuild,v 1.1 2010/12/10 13:22:38 c1pher Exp $
+
+EAPI="3"
+
+DESCRIPTION="ASN.1 library"
+HOMEPAGE="http://www.gnu.org/software/libtasn1/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="doc"
+
+DEPEND=">=dev-lang/perl-5.6
+ sys-devel/bison"
+RDEPEND=""
+
+src_configure(){
+ econf \
+ --disable-valgrind-tests
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS || die "dodoc failed"
+
+ if use doc; then
+ dodoc doc/libtasn1.ps || die "dodoc failed"
+ fi
+}