summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-14 23:02:20 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-14 23:02:20 +0000
commitb19781246f06d0408c32d25b62718da4a511a4c3 (patch)
treea86a2e64bc0524c0bb3ed98fdef187991f20ee5d /dev-libs/libxslt
parentStable on amd64 wrt bug #344771 (diff)
downloadgentoo-2-b19781246f06d0408c32d25b62718da4a511a4c3.tar.gz
gentoo-2-b19781246f06d0408c32d25b62718da4a511a4c3.tar.bz2
gentoo-2-b19781246f06d0408c32d25b62718da4a511a4c3.zip
Fix dependencies. Support installation for multiple Python ABIs (bug #312195).
(Portage version: 2.2.0_alpha4_p23/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libxslt')
-rw-r--r--dev-libs/libxslt/ChangeLog7
-rw-r--r--dev-libs/libxslt/libxslt-1.1.26.ebuild71
2 files changed, 72 insertions, 6 deletions
diff --git a/dev-libs/libxslt/ChangeLog b/dev-libs/libxslt/ChangeLog
index 6fdc05c2e7a2..c26f119d8963 100644
--- a/dev-libs/libxslt/ChangeLog
+++ b/dev-libs/libxslt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libxslt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.203 2010/01/25 19:29:16 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.204 2010/11/14 23:02:20 arfrever Exp $
+
+ 14 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ libxslt-1.1.26.ebuild:
+ Fix dependencies. Support installation for multiple Python ABIs (bug
+ #312195).
25 Jan 2010; Raúl Porcel <armin76@gentoo.org> libxslt-1.1.26.ebuild:
ia64/m68k/s390/sh/sparc stable wrt #296430
diff --git a/dev-libs/libxslt/libxslt-1.1.26.ebuild b/dev-libs/libxslt/libxslt-1.1.26.ebuild
index 01665a0d0f58..64c1ee8e909d 100644
--- a/dev-libs/libxslt/libxslt-1.1.26.ebuild
+++ b/dev-libs/libxslt/libxslt-1.1.26.ebuild
@@ -1,9 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.26.ebuild,v 1.12 2010/01/25 19:29:16 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.26.ebuild,v 1.13 2010/11/14 23:02:20 arfrever Exp $
-EAPI=2
-inherit autotools eutils toolchain-funcs
+EAPI="2"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit autotools eutils python toolchain-funcs
DESCRIPTION="XSLT libraries and tools"
HOMEPAGE="http://www.xmlsoft.org/"
@@ -15,13 +19,22 @@ KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~spar
IUSE="crypt debug python"
DEPEND=">=dev-libs/libxml2-2.6.27
- crypt? ( >=dev-libs/libgcrypt-1.1.42 )
- python? ( >=dev-lang/python-2.5 )"
+ crypt? ( >=dev-libs/libgcrypt-1.1.42 )"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
src_prepare() {
epatch "${FILESDIR}"/libxslt.m4-${P}.patch \
"${FILESDIR}"/${PN}-1.1.23-parallel-install.patch \
"${FILESDIR}"/${P}-undefined.patch
+
+ # Python bindings are built/tested/installed manually.
+ sed -e "s/@PYTHON_SUBDIR@//" -i Makefile.am || die "sed failed"
+
eautoreconf
epunt_cxx
}
@@ -43,9 +56,57 @@ src_configure() {
$(use_with debug mem-debug)
}
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources python
+ building() {
+ emake PYTHON_INCLUDES="$(python_get_includedir)" \
+ PYTHON_SITE_PACKAGES="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir python building
+ fi
+}
+
+src_test() {
+ default
+
+ if use python; then
+ testing() {
+ emake test
+ }
+ python_execute_function -s --source-dir python testing
+ fi
+}
+
src_install() {
emake DESTDIR="${D}" install || die
+
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" \
+ PYTHON_SITE_PACKAGES="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir python installation
+
+ python_clean_installation_image
+ fi
+
mv -vf "${D}"/usr/share/doc/${PN}-python-${PV} \
"${D}"/usr/share/doc/${PF}/python
dodoc AUTHORS ChangeLog FEATURES NEWS README TODO || die
}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize libxslt.py
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup libxslt.py
+ fi
+}