summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-11-04 22:57:47 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-11-04 22:57:47 +0000
commit1c536ef87c5c6fc67df3342672681a410e0818cf (patch)
treeb95c85773320a38140ae3a9f39c51d0e9e7c33d8 /dev-libs/link-grammar/link-grammar-4.2.4-r1.ebuild
parent2.1.3.18 bump. This fixes bugs #197797, #197932, #197965, #197990, (diff)
downloadgentoo-2-1c536ef87c5c6fc67df3342672681a410e0818cf.tar.gz
gentoo-2-1c536ef87c5c6fc67df3342672681a410e0818cf.tar.bz2
gentoo-2-1c536ef87c5c6fc67df3342672681a410e0818cf.zip
fix repoman warnings and fix bug #196803
(Portage version: 2.1.3.16)
Diffstat (limited to 'dev-libs/link-grammar/link-grammar-4.2.4-r1.ebuild')
-rw-r--r--dev-libs/link-grammar/link-grammar-4.2.4-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/link-grammar/link-grammar-4.2.4-r1.ebuild b/dev-libs/link-grammar/link-grammar-4.2.4-r1.ebuild
new file mode 100644
index 000000000000..8b2a2d8aadb7
--- /dev/null
+++ b/dev-libs/link-grammar/link-grammar-4.2.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/link-grammar-4.2.4-r1.ebuild,v 1.1 2007/11/04 22:57:47 eva Exp $
+
+inherit eutils
+
+DESCRIPTION="The Link Grammar Parser is a syntactic parser of English, based on
+link grammar, an original theory of English syntax."
+HOMEPAGE="http://bobo.link.cs.cmu.edu/link/"
+SRC_URI="http://www.abisource.com/downloads/link-grammar/${PV}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+#broken make files :-/
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix bug #196803
+ epatch "${FILESDIR}"/${P}-tokenize.c
+}
+
+src_compile() {
+ econf || die "configure failed"
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README
+}