summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-26 11:41:38 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-26 11:41:38 +0000
commit65a1c71296dbd0326801dfff67e9d042bb0f3355 (patch)
tree1af733aa95e3acccadaff006113eac895299c62d /dev-libs/link-grammar
parentx86 stable wrt security bug #354019 (diff)
downloadgentoo-2-65a1c71296dbd0326801dfff67e9d042bb0f3355.tar.gz
gentoo-2-65a1c71296dbd0326801dfff67e9d042bb0f3355.tar.bz2
gentoo-2-65a1c71296dbd0326801dfff67e9d042bb0f3355.zip
Version bump. Also fix building without hunspell support (bug #356455 by Faustus).
(Portage version: 2.1.9.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/link-grammar')
-rw-r--r--dev-libs/link-grammar/ChangeLog9
-rw-r--r--dev-libs/link-grammar/link-grammar-4.7.2.ebuild11
-rw-r--r--dev-libs/link-grammar/link-grammar-4.7.4.ebuild52
3 files changed, 67 insertions, 5 deletions
diff --git a/dev-libs/link-grammar/ChangeLog b/dev-libs/link-grammar/ChangeLog
index bedb958fd940..7aba23fa50fe 100644
--- a/dev-libs/link-grammar/ChangeLog
+++ b/dev-libs/link-grammar/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/link-grammar
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/ChangeLog,v 1.31 2011/02/24 20:49:23 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/ChangeLog,v 1.32 2011/02/26 11:41:38 pacho Exp $
+
+*link-grammar-4.7.4 (26 Feb 2011)
+
+ 26 Feb 2011; Pacho Ramos <pacho@gentoo.org> link-grammar-4.7.2.ebuild,
+ +link-grammar-4.7.4.ebuild:
+ Version bump. Also fix building without hunspell support (bug #356455 by
+ Faustus).
24 Feb 2011; Thomas Kahle <tomka@gentoo.org> link-grammar-4.7.2.ebuild:
x86 stable per bug 353436
diff --git a/dev-libs/link-grammar/link-grammar-4.7.2.ebuild b/dev-libs/link-grammar/link-grammar-4.7.2.ebuild
index 8d30f49e6f19..1d249f18a36c 100644
--- a/dev-libs/link-grammar/link-grammar-4.7.2.ebuild
+++ b/dev-libs/link-grammar/link-grammar-4.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/link-grammar-4.7.2.ebuild,v 1.3 2011/02/24 20:49:23 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/link-grammar-4.7.2.ebuild,v 1.4 2011/02/26 11:41:38 pacho Exp $
EAPI="3"
@@ -8,7 +8,7 @@ inherit java-pkg-opt-2
DESCRIPTION="Link Grammar Parser is a syntactic English parser based on
link grammar."
-HOMEPAGE="http://www.link.cs.cmu.edu/link/"
+HOMEPAGE="http://www.abisource.com/projects/link-grammar/ http://www.link.cs.cmu.edu/link/"
SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
LICENSE="as-is"
@@ -33,14 +33,17 @@ pkg_setup() {
}
src_configure() {
+ local myconf
+
+ use hunspell && myconf="${myconf} --with-hunspell-dictdir=/usr/share/myspell"
econf \
--enable-shared \
$(use_enable aspell) \
$(use_enable hunspell) \
- $(use_with hunspell hunspell-dictdir=/usr/share/myspell) \
$(use_enable java java-bindings) \
$(use_enable static-libs static) \
- $(use_enable threads pthreads)
+ $(use_enable threads pthreads) \
+ ${myconf}
}
src_install() {
diff --git a/dev-libs/link-grammar/link-grammar-4.7.4.ebuild b/dev-libs/link-grammar/link-grammar-4.7.4.ebuild
new file mode 100644
index 000000000000..7c4195681c30
--- /dev/null
+++ b/dev-libs/link-grammar/link-grammar-4.7.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/link-grammar-4.7.4.ebuild,v 1.1 2011/02/26 11:41:38 pacho Exp $
+
+EAPI="3"
+
+inherit java-pkg-opt-2
+
+DESCRIPTION="Link Grammar Parser is a syntactic English parser based on
+link grammar."
+HOMEPAGE="http://www.abisource.com/projects/link-grammar/ http://www.link.cs.cmu.edu/link/"
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Set the same default as used in app-text/enchant
+IUSE="aspell +hunspell java static-libs threads"
+
+DEPEND="aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )
+ java? ( >=virtual/jdk-1.5 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+ if use aspell && use hunspell; then
+ ewarn "You have enabled 'aspell' and 'hunspell' support, but both cannot coexist,"
+ ewarn "only aspell will be build. Press Ctrl+C and set only 'hunspell' USE flag if"
+ ewarn "you want hunspell support."
+ fi
+}
+
+src_configure() {
+ local myconf
+
+ use hunspell && myconf="${myconf} --with-hunspell-dictdir=/usr/share/myspell"
+ econf \
+ --enable-shared \
+ $(use_enable aspell) \
+ $(use_enable hunspell) \
+ $(use_enable java java-bindings) \
+ $(use_enable static-libs static) \
+ $(use_enable threads pthreads) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog README || die
+}