summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-05-04 00:40:07 +0000
committerNaohiro Aota <naota@gentoo.org>2013-05-04 00:40:07 +0000
commit0c26242ce7e12e688dc7edf1e5b3a868c23a0028 (patch)
tree6f607bd7c642fb420f8afaee67e14eb9c8bf90c6 /dev-libs/newt
parentversion bump (diff)
downloadgentoo-2-0c26242ce7e12e688dc7edf1e5b3a868c23a0028.tar.gz
gentoo-2-0c26242ce7e12e688dc7edf1e5b3a868c23a0028.tar.bz2
gentoo-2-0c26242ce7e12e688dc7edf1e5b3a868c23a0028.zip
version bump wrt #468126
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'dev-libs/newt')
-rw-r--r--dev-libs/newt/ChangeLog8
-rw-r--r--dev-libs/newt/files/newt-0.52.15-snack.patch22
-rw-r--r--dev-libs/newt/newt-0.52.15.ebuild82
3 files changed, 111 insertions, 1 deletions
diff --git a/dev-libs/newt/ChangeLog b/dev-libs/newt/ChangeLog
index fb1a23599de8..85fdb186b449 100644
--- a/dev-libs/newt/ChangeLog
+++ b/dev-libs/newt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/newt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.81 2013/01/12 05:57:16 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.82 2013/05/04 00:40:07 naota Exp $
+
+*newt-0.52.15 (04 May 2013)
+
+ 04 May 2013; Naohiro Aota <naota@gentoo.org> +files/newt-0.52.15-snack.patch,
+ +newt-0.52.15.ebuild:
+ version bump wrt #468126
12 Jan 2013; Naohiro Aota <naota@gentoo.org> +files/newt-0.52.12-tcl.patch,
+files/newt-0.52.14-tcl.patch, newt-0.52.12.ebuild, newt-0.52.13.ebuild,
diff --git a/dev-libs/newt/files/newt-0.52.15-snack.patch b/dev-libs/newt/files/newt-0.52.15-snack.patch
new file mode 100644
index 000000000000..4d1dfaf185a5
--- /dev/null
+++ b/dev-libs/newt/files/newt-0.52.15-snack.patch
@@ -0,0 +1,22 @@
+diff --git a/Makefile.in b/Makefile.in
+index 75764e1..ca95bb6 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -78,7 +78,7 @@ showkey: showkey.o $(LIBNEWT)
+
+ _snackmodule.so: snackmodule.c $(LIBNEWTSH)
+ @[ -n "$(PYTHONVERS)" ] && for ver in $(PYTHONVERS); do \
+- pyconfig=$$ver-config; \
++ pyconfig=$${ver/python/python-config-}; \
+ if ! $$pyconfig --cflags > /dev/null 2>&1 && \
+ python-config --cflags > /dev/null 2>&1; then \
+ echo $$pyconfig not found, using python-config; \
+@@ -90,7 +90,7 @@ _snackmodule.so: snackmodule.c $(LIBNEWTSH)
+ PLDFLAGS=`$$pyconfig --ldflags`; \
+ PLFLAGS=`$$pyconfig --libs`; \
+ echo $(CC) $(SHCFLAGS) $(CPPFLAGS) $$PIFLAGS $$PCFLAGS -c -o $$ver/snackmodule.o snackmodule.c; \
+- $(CC) $(SHCFLAGS) $(CPPFLAGS) $$PIFLAGS $$PCFLAGS -c -o $$ver/snackmodule.o snackmodule.c; \
++ $(CC) $(SHCFLAGS) $(CFLAGS) $(CPPFLAGS) $$PIFLAGS $$PCFLAGS -c -o $$ver/snackmodule.o snackmodule.c; \
+ echo $(CC) --shared $$PLDFLAGS $$PLFLAGS $(LDFLAGS) -o $$ver/_snackmodule.so $$ver/snackmodule.o -L. -lnewt $(LIBS); \
+ $(CC) --shared $$PLDFLAGS $$PLFLAGS $(LDFLAGS) -o $$ver/_snackmodule.so $$ver/snackmodule.o -L. -lnewt $(LIBS); \
+ done || :
diff --git a/dev-libs/newt/newt-0.52.15.ebuild b/dev-libs/newt/newt-0.52.15.ebuild
new file mode 100644
index 000000000000..69b260f9a61a
--- /dev/null
+++ b/dev-libs/newt/newt-0.52.15.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.15.ebuild,v 1.1 2013/05/04 00:40:07 naota Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils multilib python-r1 autotools
+
+DESCRIPTION="Redhat's Newt windowing toolkit development files"
+HOMEPAGE="https://fedorahosted.org/newt/"
+SRC_URI="https://fedorahosted.org/releases/n/e/newt/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gpm tcl nls"
+
+RDEPEND="=sys-libs/slang-2*
+ >=dev-libs/popt-1.6
+ elibc_uclibc? ( sys-libs/ncurses )
+ gpm? ( sys-libs/gpm )
+ tcl? ( >=dev-lang/tcl-8.5 )
+ "
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ # bug 73850
+ if use elibc_uclibc; then
+ sed -i -e 's:-lslang:-lslang -lncurses:g' Makefile.in || die
+ fi
+
+ sed -i Makefile.in \
+ -e 's|-ltcl8.4|-ltcl|g' \
+ -e 's|$(SHCFLAGS) -o|$(LDFLAGS) &|g' \
+ -e 's|-g -o|$(CFLAGS) $(LDFLAGS) -o|g' \
+ -e 's|-shared -o|$(CFLAGS) $(LDFLAGS) &|g' \
+ -e 's|instroot|DESTDIR|g' \
+ -e 's| make | $(MAKE) |g' \
+ || die "sed Makefile.in"
+
+ local langs=""
+ if [ -n "${LINGUAS}" ]; then
+ for lang in ${LINGUAS}; do
+ test -r po/${lang}.po && langs="${langs} ${lang}.po"
+ done
+ sed -i po/Makefile \
+ -e "/^CATALOGS = /cCATALOGS = ${langs}" \
+ || die "sed po/Makefile"
+ fi
+
+ epatch "${FILESDIR}"/${PN}-0.52.13-gold.patch \
+ "${FILESDIR}"/${PN}-0.52.15-snack.patch \
+ "${FILESDIR}"/${PN}-0.52.14-tcl.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with gpm gpm-support) \
+ $(use_with tcl) \
+ $(use_enable nls)
+}
+
+python_compile() {
+ emake PYTHONVERS="${PYTHON}" || die "emake failed"
+}
+
+python_install() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHONVERS="${PYTHON}" \
+ install || die "make install failed"
+ python_optimize
+}
+
+python_install_all() {
+ dodoc peanuts.py popcorn.py tutorial.sgml
+ doman whiptail.1
+}