summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-09-20 10:56:26 +0000
committerAlin Năstac <mrness@gentoo.org>2009-09-20 10:56:26 +0000
commit27a38d0c0713c07e9dce23644bb3c0995bb478ab (patch)
treef0a2367c9d920310b72d5e6f75b3cfce70a598be /dev-libs/openobex/openobex-1.5.ebuild
parentVersion bump (diff)
downloadgentoo-2-27a38d0c0713c07e9dce23644bb3c0995bb478ab.tar.gz
gentoo-2-27a38d0c0713c07e9dce23644bb3c0995bb478ab.tar.bz2
gentoo-2-27a38d0c0713c07e9dce23644bb3c0995bb478ab.zip
Avoid linking with libusb and libbluetooth when usb respectively bluetooth USE flags are disabled (#285040).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/openobex/openobex-1.5.ebuild')
-rw-r--r--dev-libs/openobex/openobex-1.5.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-libs/openobex/openobex-1.5.ebuild b/dev-libs/openobex/openobex-1.5.ebuild
index ee46fdbe781f..e80b2c67088d 100644
--- a/dev-libs/openobex/openobex-1.5.ebuild
+++ b/dev-libs/openobex/openobex-1.5.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openobex/openobex-1.5.ebuild,v 1.7 2009/08/29 18:05:23 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openobex/openobex-1.5.ebuild,v 1.8 2009/09/20 10:56:26 mrness Exp $
EAPI="2"
+inherit eutils autotools
+
DESCRIPTION="An implementation of the OBEX protocol used for transferring data to mobile devices"
HOMEPAGE="http://sourceforge.net/projects/openobex/"
SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.gz"
@@ -17,6 +19,11 @@ RDEPEND="bluetooth? ( || ( net-wireless/bluez net-wireless/bluez-libs ) )
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-use-flags.patch
+ eautoreconf
+}
+
src_configure() {
econf \
--enable-apps \