summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-01-31 19:08:02 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-01-31 19:08:02 +0000
commitad6201533fdab5bee10280b8316bc707abc53924 (patch)
tree2c16564772ef0b45e7192db732678245205c034e /dev-libs/ppl
parentStable on alpha, bug #248038 (diff)
downloadgentoo-2-ad6201533fdab5bee10280b8316bc707abc53924.tar.gz
gentoo-2-ad6201533fdab5bee10280b8316bc707abc53924.tar.bz2
gentoo-2-ad6201533fdab5bee10280b8316bc707abc53924.zip
Revision bump. Add missing dependency on GMP with C++ extensions. Fix
unwanted dependencies being autodectected by configure. Add doc USE flag and fix docs installing into the wrong place. (Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/ppl')
-rw-r--r--dev-libs/ppl/ChangeLog11
-rw-r--r--dev-libs/ppl/ppl-0.10-r1.ebuild54
2 files changed, 63 insertions, 2 deletions
diff --git a/dev-libs/ppl/ChangeLog b/dev-libs/ppl/ChangeLog
index 2c238c1f32ab..e1658bf58c35 100644
--- a/dev-libs/ppl/ChangeLog
+++ b/dev-libs/ppl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/ppl
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ChangeLog,v 1.4 2008/12/01 16:52:10 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ChangeLog,v 1.5 2009/01/31 19:08:02 dirtyepic Exp $
+
+*ppl-0.10-r1 (31 Jan 2009)
+
+ 31 Jan 2009; Ryan Hill <dirtyepic@gentoo.org> +ppl-0.10-r1.ebuild:
+ Revision bump. Add missing dependency on GMP with C++ extensions. Fix
+ unwanted dependencies being autodectected by configure. Add doc USE flag
+ and fix docs installing into the wrong place.
01 Dec 2008; Mike Frysinger <vapier@gentoo.org> ppl-0.10.ebuild:
Fix typo pointed out by Sigmatador.
diff --git a/dev-libs/ppl/ppl-0.10-r1.ebuild b/dev-libs/ppl/ppl-0.10-r1.ebuild
new file mode 100644
index 000000000000..2cff94b13fdf
--- /dev/null
+++ b/dev-libs/ppl/ppl-0.10-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ppl-0.10-r1.ebuild,v 1.1 2009/01/31 19:08:02 dirtyepic Exp $
+
+EAPI=2
+
+DESCRIPTION="The Parma Polyhedra Library (PPL) is a modern and reasonably complete library providing numerical abstractions especially targeted at applications in the field of analysis and verification of complex systems"
+HOMEPAGE="http://www.cs.unipr.it/ppl/"
+SRC_URI="http://www.cs.unipr.it/ppl/Download/ftp/releases/${PV}/${P}.tar.bz2
+ ftp://ftp.cs.unipr.it/pub/ppl/releases/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="doc prolog"
+
+RDEPEND="prolog? ( dev-lang/swi-prolog )
+ >=dev-libs/gmp-4.1.3[-nocxx]"
+DEPEND="${RDEPEND}
+ sys-devel/m4"
+
+
+src_configure() {
+
+ use prolog && want_prolog="swi_prolog"
+
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-debugging \
+ --disable-optimization \
+ --enable-interfaces="c cxx ${want_prolog}" \
+ || die
+}
+
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use doc; then
+ cd "${D}"/usr/share/doc/${PF}
+ mkdir ppl ppl-watchdog
+ # the library docs get installed into ${DOCDIR}/ppl/
+ # move them to the right place
+ mv * ppl-watchdog
+ mv ../ppl .
+ prepalldocs
+ else
+ rm -rf "${D}"/usr/share/doc/${PN}
+ rm -rf "${D}"/usr/share/doc/${PF}
+ fi
+
+ dodoc NEWS README README.configure STANDARDS TODO
+}