summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-17 13:48:21 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-17 13:48:21 +0000
commit657a4104ce70e830df90ede3d355889f6241a3a9 (patch)
treef2f3d8add2d75b03dc6fcf6e79c9c5b2eff1a90f /dev-libs/rasqal
parentFix bug 297163 in dev-libs/boost with upstream patch. (diff)
downloadgentoo-2-657a4104ce70e830df90ede3d355889f6241a3a9.tar.gz
gentoo-2-657a4104ce70e830df90ede3d355889f6241a3a9.tar.bz2
gentoo-2-657a4104ce70e830df90ede3d355889f6241a3a9.zip
Version bump.
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/rasqal')
-rw-r--r--dev-libs/rasqal/ChangeLog7
-rw-r--r--dev-libs/rasqal/rasqal-0.9.17.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-libs/rasqal/ChangeLog b/dev-libs/rasqal/ChangeLog
index a06995c83abb..3c870d710a4b 100644
--- a/dev-libs/rasqal/ChangeLog
+++ b/dev-libs/rasqal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/rasqal
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/ChangeLog,v 1.32 2009/06/22 13:10:03 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/ChangeLog,v 1.33 2009/12/17 13:48:21 ssuominen Exp $
+
+*rasqal-0.9.17 (17 Dec 2009)
+
+ 17 Dec 2009; Samuli Suominen <ssuominen@gentoo.org> +rasqal-0.9.17.ebuild:
+ Version bump.
22 Jun 2009; Alexis Ballier <aballier@gentoo.org> rasqal-0.9.16.ebuild:
keyword ~x86-fbsd
diff --git a/dev-libs/rasqal/rasqal-0.9.17.ebuild b/dev-libs/rasqal/rasqal-0.9.17.ebuild
new file mode 100644
index 000000000000..4de847ae97d6
--- /dev/null
+++ b/dev-libs/rasqal/rasqal-0.9.17.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/rasqal-0.9.17.ebuild,v 1.1 2009/12/17 13:48:21 ssuominen Exp $
+
+EAPI=2
+inherit libtool
+
+DESCRIPTION="library that handles Resource Description Framework (RDF)"
+HOMEPAGE="http://librdf.org/rasqal/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gmp pcre test xml"
+
+RDEPEND=">=media-libs/raptor-1.4.18
+ pcre? ( dev-libs/libpcre )
+ xml? ( dev-libs/libxml2 )
+ !gmp? ( dev-libs/mpfr )
+ gmp? ( dev-libs/gmp )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/flex
+ test? ( dev-perl/XML-DOM )"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ local regex="posix"
+ local decimal="mpfr"
+
+ use pcre && regex="pcre"
+ use gmp && decimal="gmp"
+
+ econf \
+ --disable-dependency-tracking \
+ --with-raptor=system \
+ $(use_enable pcre) \
+ $(use_enable xml xml2) \
+ --with-regex-library=${regex} \
+ --with-decimal=${decimal}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+ dohtml {NEWS,README,RELEASE}.html
+}