summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-02-06 18:54:35 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2013-02-06 18:54:35 +0000
commit3efdcd267bde3712aed4e1f04b2a66682b06440a (patch)
tree92b8453fa7b0d121ce5dd60abf23a8ad90db7e50 /dev-libs/soprano
parentVersion bump KDE SC 4.10.0 (diff)
downloadgentoo-2-3efdcd267bde3712aed4e1f04b2a66682b06440a.tar.gz
gentoo-2-3efdcd267bde3712aed4e1f04b2a66682b06440a.tar.bz2
gentoo-2-3efdcd267bde3712aed4e1f04b2a66682b06440a.zip
Version bump KDE SC 4.10.0
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'dev-libs/soprano')
-rw-r--r--dev-libs/soprano/ChangeLog9
-rw-r--r--dev-libs/soprano/soprano-2.9.0.ebuild101
2 files changed, 108 insertions, 2 deletions
diff --git a/dev-libs/soprano/ChangeLog b/dev-libs/soprano/ChangeLog
index 3fa4bcd5429f..8d7af16bc304 100644
--- a/dev-libs/soprano/ChangeLog
+++ b/dev-libs/soprano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/soprano
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/soprano/ChangeLog,v 1.99 2012/11/30 15:11:59 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/soprano/ChangeLog,v 1.100 2013/02/06 18:54:35 alexxy Exp $
+
+*soprano-2.9.0 (06 Feb 2013)
+
+ 06 Feb 2013; Alexey Shvetsov <alexxy@gentoo.org> +soprano-2.9.0.ebuild:
+ Version bump KDE SC 4.10.0
30 Nov 2012; <ago@gentoo.org> soprano-2.8.0.ebuild:
Stable for ppc, wrt bug #442394
diff --git a/dev-libs/soprano/soprano-2.9.0.ebuild b/dev-libs/soprano/soprano-2.9.0.ebuild
new file mode 100644
index 000000000000..d85cd606c177
--- /dev/null
+++ b/dev-libs/soprano/soprano-2.9.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/soprano/soprano-2.9.0.ebuild,v 1.1 2013/02/06 18:54:35 alexxy Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999* ]]; then
+ git_eclass="git-2"
+ EGIT_REPO_URI="git://anongit.kde.org/soprano"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit base cmake-utils flag-o-matic ${git_eclass}
+
+DESCRIPTION="Library that provides a nice Qt interface to RDF storage solutions"
+HOMEPAGE="http://sourceforge.net/projects/soprano"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="+dbus debug doc elibc_FreeBSD +raptor +redland test +virtuoso"
+
+RESTRICT=test
+# bug 281712
+
+COMMON_DEPEND="
+ >=x11-libs/qt-core-4.5.0:4
+ dbus? ( >=x11-libs/qt-dbus-4.5.0:4 )
+ raptor? ( >=media-libs/raptor-2.0.4:2 )
+ redland? (
+ >=dev-libs/rasqal-0.9.26
+ >=dev-libs/redland-1.0.14
+ )
+ virtuoso? ( dev-db/libiodbc:0 )
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( >=x11-libs/qt-test-4.5.0:4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ virtuoso? ( >=dev-db/virtuoso-server-6.1.6 )
+"
+
+CMAKE_IN_SOURCE_BUILD="1"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.4-make-broken-redland-fatal.cmake"
+)
+
+pkg_setup() {
+ if [[ ${PV} = *9999* && -z $I_KNOW_WHAT_I_AM_DOING ]]; then
+ echo
+ ewarn "WARNING! This is an experimental ebuild of ${PN} Git tree. Use at your own risk."
+ ewarn "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
+ echo
+ fi
+
+ if ! use virtuoso; then
+ echo
+ ewarn "You have explicitly disabled the default soprano backend."
+ ewarn "Applications using soprano may need at least one backend"
+ ewarn "to be functional. If you experience any problems, enable"
+ ewarn "the virtuoso USE flag."
+ echo
+ fi
+}
+
+src_configure() {
+ # Fix for missing pthread.h linking
+ # NOTE: temporarily fix until a better cmake files patch will be provided.
+ use elibc_FreeBSD && append-flags -pthread
+
+ local mycmakeargs=(
+ -DSOPRANO_BUILD_TESTS=OFF
+ -DCMAKE_SKIP_RPATH=OFF
+ -DSOPRANO_DISABLE_SESAME2_BACKEND=ON
+ -DSOPRANO_DISABLE_CLUCENE_INDEX=ON
+ $(cmake-utils_use !dbus SOPRANO_DISABLE_DBUS)
+ $(cmake-utils_use !raptor SOPRANO_DISABLE_RAPTOR_PARSER)
+ $(cmake-utils_use !redland SOPRANO_DISABLE_RAPTOR_SERIALIZER)
+ $(cmake-utils_use !redland SOPRANO_DISABLE_REDLAND_BACKEND)
+ $(cmake-utils_use !virtuoso SOPRANO_DISABLE_VIRTUOSO_BACKEND)
+ $(cmake-utils_use doc SOPRANO_BUILD_API_DOCS)
+ $(cmake-utils_use test SOPRANO_BUILD_TESTS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc AUTHORS ChangeLog README TODO
+ newdoc backends/virtuoso/README README.virtuoso
+ newdoc backends/sesame2/README README.sesame2
+ if use doc ; then
+ dohtml -r docs/html/
+ fi
+}