summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2010-07-07 13:43:55 +0000
committerFabio Erculiani <lxnay@gentoo.org>2010-07-07 13:43:55 +0000
commit6f852b14f8a2773984ea79d712cfbf8db468dede (patch)
tree4eaa542af867d5b0c6faf20393de7aacd396741d /dev-libs/svrcore
parentx86 stable wrt bug #324437 (diff)
downloadgentoo-2-6f852b14f8a2773984ea79d712cfbf8db468dede.tar.gz
gentoo-2-6f852b14f8a2773984ea79d712cfbf8db468dede.tar.bz2
gentoo-2-6f852b14f8a2773984ea79d712cfbf8db468dede.zip
new ebuild, Mozilla LDAP C SDK
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/svrcore')
-rw-r--r--dev-libs/svrcore/ChangeLog10
-rw-r--r--dev-libs/svrcore/files/svrcore-4.0.4-gentoo.patch100
-rw-r--r--dev-libs/svrcore/metadata.xml8
-rw-r--r--dev-libs/svrcore/svrcore-4.0.4.ebuild41
4 files changed, 159 insertions, 0 deletions
diff --git a/dev-libs/svrcore/ChangeLog b/dev-libs/svrcore/ChangeLog
new file mode 100644
index 000000000000..2a4f539f56d5
--- /dev/null
+++ b/dev-libs/svrcore/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/svrcore
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/svrcore/ChangeLog,v 1.1 2010/07/07 13:43:55 lxnay Exp $
+
+*svrcore-4.0.4 (07 Jul 2010)
+
+ 07 Jul 2010; Fabio Erculiani <lxnay@gentoo.org> +svrcore-4.0.4.ebuild,
+ +files/svrcore-4.0.4-gentoo.patch, +metadata.xml:
+ new ebuild, Mozilla LDAP C SDK
+
diff --git a/dev-libs/svrcore/files/svrcore-4.0.4-gentoo.patch b/dev-libs/svrcore/files/svrcore-4.0.4-gentoo.patch
new file mode 100644
index 000000000000..83e9f7fca359
--- /dev/null
+++ b/dev-libs/svrcore/files/svrcore-4.0.4-gentoo.patch
@@ -0,0 +1,100 @@
+diff -uNr src/Makefile.am svrcore-4.0.4src/Makefile.am
+--- src/Makefile.am 2006-12-14 18:07:32.000000000 +0100
++++ src/Makefile.am 2007-08-06 17:37:17.000000000 +0200
+@@ -4,8 +4,8 @@
+ Makefile.win \
+ ntgetpin.rc
+
+-lib_LTLIBRARIES = libsvrcore.la
+-include_HEADERS = svrcore.h
++pkglib_LTLIBRARIES = libsvrcore.la
++pkginclude_HEADERS = svrcore.h
+ libsvrcore_la_SOURCES = alt.c \
+ cache.c \
+ errors.c \
+diff -uNr svrcore.pc.in svrcore.pc.in
+--- svrcore.pc.in 2006-12-14 18:07:32.000000000 +0100
++++ svrcore.pc.in 2007-08-06 17:38:12.000000000 +0200
+@@ -1,11 +1,11 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+-libdir=@libdir@
+-includedir=@includedir@
++libdir=@libdir@/@PACKAGE@
++includedir=@includedir@/@PACKAGE@
+
+ Name: svrcore
+ Description: Svrcore - Secure PIN handling using NSS crypto
+ Version: @VERSION@
+ Requires: @NSPR_NAME@ >= @NSPR_MIN_VER@ , @NSS_NAME@ >= @NSS_MIN_VER@
+-Libs: -lsvrcore
++Libs: -L${libdir} -lsvrcore
+ Cflags: -I${includedir}
+diff -ur m4.orig/nspr.m4 m4/nspr.m4
+--- m4.orig/nspr.m4 2009-10-06 01:40:18.979484804 +0300
++++ m4/nspr.m4 2009-10-06 01:41:21.539982482 +0300
+@@ -52,28 +52,6 @@
+ ],
+ AC_MSG_RESULT(no))
+
+-# see if we are doing an "in-tree" build with the other
+-# mozilla components
+-if test -z "$nspr_inc" -o -z "$nspr_lib" ; then
+- for nsprpath in "../../dist" "../../dist/*.OBJ" ; do
+- savedir=`pwd`
+- cd $nsprpath
+- abs_nsprpath=`pwd`
+- cd $savedir
+- if test -f "$abs_nsprpath/include/nspr/nspr.h" ; then
+- nspr_inc="-I$abs_nsprpath/include/nspr"
+- elif test -f "$abs_nsprpath/include/nspr.h" ; then
+- nspr_inc="-I$abs_nsprpath/include"
+- fi
+- if test -d "$abs_nsprpath/lib" ; then
+- nspr_lib="-L$abs_nsprpath/lib"
+- fi
+- if test -n "$nspr_inc" -a -n "$nspr_lib" ; then
+- break
+- fi
+- done
+-fi
+-
+ # if NSPR is not found yet, try pkg-config
+ # last resort
+ if test -z "$nspr_inc" -o -z "$nspr_lib" ; then
+diff -ur m4.orig/nss.m4 m4/nss.m4
+--- m4.orig/nss.m4 2009-10-06 01:40:18.979484804 +0300
++++ m4/nss.m4 2009-10-06 01:41:31.291485717 +0300
+@@ -52,32 +52,6 @@
+ ],
+ AC_MSG_RESULT(no))
+
+-# see if we are building "in tree" with the
+-# other mozilla components
+-if test -z "$nss_inc" -o -z "$nss_lib"; then
+- nsslibpath=`echo ../../dist/*.OBJ/lib | cut -f1 -d' '`
+- savedir=`pwd`
+- cd $nsslibpath
+- abs_nsslibpath=`pwd`
+- cd $savedir
+- nssincpath=../../dist/public/nss
+- savedir=`pwd`
+- cd $nssincpath
+- abs_nssincpath=`pwd`
+- cd $savedir
+- if test -f "$abs_nssincpath/nss.h" ; then
+- nss_inc="-I$abs_nssincpath"
+- fi
+- if test -d "$abs_nsslibpath" ; then
+- nss_lib="-L$abs_nsslibpath"
+- fi
+- if test -n "$nss_inc" -a -n "$nss_lib" ; then
+- AC_MSG_CHECKING(using in-tree NSS from $nssincpath $nsslibpath)
+- else
+- AC_MSG_CHECKING(could not find in-tree NSS in ../../dist)
+- fi
+-fi
+-
+ # if NSS is not found yet, try pkg-config
+ # last resort
+ if test -z "$nss_inc" -o -z "$nss_lib"; then
diff --git a/dev-libs/svrcore/metadata.xml b/dev-libs/svrcore/metadata.xml
new file mode 100644
index 000000000000..bf10992e48b1
--- /dev/null
+++ b/dev-libs/svrcore/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>lxnay@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-libs/svrcore/svrcore-4.0.4.ebuild b/dev-libs/svrcore/svrcore-4.0.4.ebuild
new file mode 100644
index 000000000000..737bfff4ca87
--- /dev/null
+++ b/dev-libs/svrcore/svrcore-4.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/svrcore/svrcore-4.0.4.ebuild,v 1.1 2010/07/07 13:43:55 lxnay Exp $
+
+EAPI=2
+
+inherit multilib autotools
+
+DESCRIPTION="Mozilla LDAP C SDK"
+HOMEPAGE="http://wiki.mozilla.org/LDAP_C_SDK"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/directory/svrcore/releases/"${PV}"/src/"${P}".tar.bz2"
+
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/nss-3.11
+ >=dev-libs/nspr-4.6"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/"${P}"-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pic || die "cannot configure"
+}
+
+src_install () {
+ einstall || die "emake failed"
+
+ # cope with libraries being in /usr/lib/svrcore
+ echo "LDPATH=/usr/$(get_libdir)/svrcore" > 08svrcore
+ dodir /etc/env.d
+ doenvd 08svrcore
+
+ dodoc ChangeLog INSTALL NEWS TODO README AUTHORS
+}