summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-06-17 17:50:30 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-06-17 17:50:30 +0000
commit126d8b14132657acb4db58a74b39fb0d9b863fdb (patch)
tree6d4e6304a1fc116328fdc4b6e3a635a1aa35961b /dev-libs/torch
parentadded two variables: BLUV and SVGV to hold the version numbers of the tarball... (diff)
downloadgentoo-2-126d8b14132657acb4db58a74b39fb0d9b863fdb.tar.gz
gentoo-2-126d8b14132657acb4db58a74b39fb0d9b863fdb.tar.bz2
gentoo-2-126d8b14132657acb4db58a74b39fb0d9b863fdb.zip
Initial version
Diffstat (limited to 'dev-libs/torch')
-rw-r--r--dev-libs/torch/ChangeLog10
-rw-r--r--dev-libs/torch/Manifest2
-rw-r--r--dev-libs/torch/files/digest-torch-32
-rw-r--r--dev-libs/torch/metadata.xml5
-rw-r--r--dev-libs/torch/torch-3.ebuild64
5 files changed, 83 insertions, 0 deletions
diff --git a/dev-libs/torch/ChangeLog b/dev-libs/torch/ChangeLog
new file mode 100644
index 000000000000..051a01b1fed5
--- /dev/null
+++ b/dev-libs/torch/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/torch
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/torch/ChangeLog,v 1.1 2004/06/17 17:50:29 phosphan Exp $
+
+*torch-3 (17 Jun 2004)
+
+ 17 Jun 2004; Patrick Kursawe <phosphan@gentoo.org> metadata.xml,
+ torch-3.ebuild:
+ Initial version.
+
diff --git a/dev-libs/torch/Manifest b/dev-libs/torch/Manifest
new file mode 100644
index 000000000000..b602edf3c8b5
--- /dev/null
+++ b/dev-libs/torch/Manifest
@@ -0,0 +1,2 @@
+MD5 2a80ae82386d1ac06abb80084ff8dca2 torch-3.ebuild 543
+MD5 b783f0f266b5452761370caf0b78e7f3 files/digest-torch-3 117
diff --git a/dev-libs/torch/files/digest-torch-3 b/dev-libs/torch/files/digest-torch-3
new file mode 100644
index 000000000000..44752ac23b2e
--- /dev/null
+++ b/dev-libs/torch/files/digest-torch-3
@@ -0,0 +1,2 @@
+MD5 73ecbab0862a6d98aa6a602a89b2ceb6 Torch3src.tgz 775622
+MD5 3e04241c606ddeb6cf0f6a5bc4b50a2e Torch3doc.tgz 1622648
diff --git a/dev-libs/torch/metadata.xml b/dev-libs/torch/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/dev-libs/torch/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>
diff --git a/dev-libs/torch/torch-3.ebuild b/dev-libs/torch/torch-3.ebuild
new file mode 100644
index 000000000000..f174807fe6b3
--- /dev/null
+++ b/dev-libs/torch/torch-3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/torch/torch-3.ebuild,v 1.1 2004/06/17 17:50:29 phosphan Exp $
+
+DESCRIPTION="machine-learning library, written in simple C++"
+HOMEPAGE="http://www.torch.ch/"
+SRC_URI="http://www.torch.ch/archives/Torch${PV}src.tgz
+ doc? ( http://www.torch.ch/archives/Torch3doc.tgz )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc debug"
+
+DEPEND="virtual/glibc"
+
+S=${WORKDIR}/Torch${PV}
+
+torch_packages="convolutions datasets decoder distributions gradients kernels matrix nonparametrics speech"
+
+src_compile() {
+ local shalldebug="OPT"
+ use debug && shalldebug="DBG"
+ cp config/Makefile_options_Linux .
+ sed -e "s:^PACKAGES.*:PACKAGES = ${torch_packages}:" \
+ -e "s:^DEBUG.*:DEBUG = ${shalldebug}:" \
+ -e "s:^CFLAGS_OPT_FLOAT.*:CFLAGS_OPT_FLOAT = -Wall ${CFLAGS} -ffast-math -malign-double:" \
+ -i Makefile_options_Linux
+
+ make depend
+ emake || die "emake failed"
+}
+
+src_install() {
+ dolib lib/*/*.a
+ dodir /usr/include/torch
+ insinto /usr/include/torch
+ for directory in core ${torch_packages}; do
+ doins ${directory}/*.h
+ done
+ # prepare the options Makefile
+ sed -e 's:^LIBS_DIR.*:LIBS_DIR=/usr/lib:' \
+ -e 's|^INCS := .*|INCS := -I /usr/include/torch $(MYINCS)|' \
+ -e '/^INCS +=/c\' -i Makefile_options_Linux
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins Makefile_options_Linux
+ dodoc LICENSE
+ dodir /usr/share/doc/${PF}
+ insinto /usr/share/doc/${PF}
+ cp -a examples ${D}/usr/share/doc/${PF}
+ cd ${D}/usr/share/doc/${PF}
+ sed -e 's|^TORCHDIR.*|TORCHDIR := /usr/share/torch|' \
+ -e '/MAKE/c\' -e '/VERSION_KEY/c\' \
+ -i examples/*/Makefile
+ for ex in examples/*/Makefile; do
+ echo -e '\t$(CC) $(CFLAGS_$(MODE)) $(INCS) -o $@ $< $(LIBS)' >> ${ex}
+ done
+ if use doc; then
+ cd ${WORKDIR}/docs
+ doins *.pdf
+ dohtml -r manual/.
+ fi
+}