summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-06-14 16:44:43 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-06-14 16:44:43 +0000
commit03d67d897f68881579e807c864eb2f8577898cbe (patch)
treecfc8abbb9aa6bed047c052421618b9c1019736ee /dev-libs/ucommon
parentApply upstream patch by Naohiro Aota to handle unknown acl types, bug #413865 (diff)
downloadgentoo-2-03d67d897f68881579e807c864eb2f8577898cbe.tar.gz
gentoo-2-03d67d897f68881579e807c864eb2f8577898cbe.tar.bz2
gentoo-2-03d67d897f68881579e807c864eb2f8577898cbe.zip
Fix bugs 416059 and 416043, thanks to slepnoga
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/ucommon')
-rw-r--r--dev-libs/ucommon/ChangeLog8
-rw-r--r--dev-libs/ucommon/ucommon-5.2.2-r1.ebuild (renamed from dev-libs/ucommon/ucommon-5.2.1.ebuild)4
-rw-r--r--dev-libs/ucommon/ucommon-5.2.2.ebuild58
3 files changed, 9 insertions, 61 deletions
diff --git a/dev-libs/ucommon/ChangeLog b/dev-libs/ucommon/ChangeLog
index 55b169d4b749..1a0cdbad4eea 100644
--- a/dev-libs/ucommon/ChangeLog
+++ b/dev-libs/ucommon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/ucommon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucommon/ChangeLog,v 1.3 2012/05/04 18:35:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucommon/ChangeLog,v 1.4 2012/06/14 16:44:43 maksbotan Exp $
+
+*ucommon-5.2.2-r1 (14 Jun 2012)
+
+ 14 Jun 2012; Maxim Koltsov <maksbotan@gentoo.org> +ucommon-5.2.2-r1.ebuild,
+ -ucommon-5.2.1.ebuild, -ucommon-5.2.2.ebuild:
+ Fix bugs 416059 and 416043, thanks to slepnoga
04 May 2012; Jeff Horelick <jdhore@gentoo.org> ucommon-5.2.1.ebuild,
ucommon-5.2.2.ebuild:
diff --git a/dev-libs/ucommon/ucommon-5.2.1.ebuild b/dev-libs/ucommon/ucommon-5.2.2-r1.ebuild
index 7eca9f3ee417..6808a553d4b6 100644
--- a/dev-libs/ucommon/ucommon-5.2.1.ebuild
+++ b/dev-libs/ucommon/ucommon-5.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucommon/ucommon-5.2.1.ebuild,v 1.2 2012/05/04 18:35:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucommon/ucommon-5.2.2-r1.ebuild,v 1.1 2012/06/14 16:44:43 maksbotan Exp $
EAPI="4"
@@ -23,6 +23,7 @@ DEPEND="virtual/pkgconfig
DOCS=(README NEWS SUPPORT ChangeLog AUTHORS)
PATCHES=( "${FILESDIR}"/disable_rtf_gen_doxy.patch )
+AUTOTOOLS_IN_SOURCE_BUILD=1
src_configure() {
local myconf=""
@@ -40,7 +41,6 @@ src_configure() {
${myconf}
--enable-atomics
--with-pkg-config
- --enable-posix-timers
)
autotools-utils_src_configure
}
diff --git a/dev-libs/ucommon/ucommon-5.2.2.ebuild b/dev-libs/ucommon/ucommon-5.2.2.ebuild
deleted file mode 100644
index cc9a74cdb6b3..000000000000
--- a/dev-libs/ucommon/ucommon-5.2.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucommon/ucommon-5.2.2.ebuild,v 1.2 2012/05/04 18:35:52 jdhore Exp $
-
-EAPI="4"
-
-inherit autotools-utils
-
-DESCRIPTION="Portable C++ runtime for threads and sockets"
-HOMEPAGE="http://www.gnu.org/software/commoncpp"
-SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE="doc static-libs socks +cxx debug ssl gnutls"
-
-RDEPEND="ssl? ( dev-libs/openssl )"
-
-DEPEND="virtual/pkgconfig
- doc? ( app-doc/doxygen )
- ${RDEPEND}"
-
-DOCS=(README NEWS SUPPORT ChangeLog AUTHORS)
-PATCHES=( "${FILESDIR}"/disable_rtf_gen_doxy.patch )
-
-src_configure() {
- local myconf=""
- if ! use ssl && ! use gnutls; then
- myconf=" --with-sslstack=nossl "
- fi
-
- if use ssl; then
- myconf=" --with-sslstack=ssl "
- fi
-
- local myeconfargs=(
- $(use_enable socks)
- $(use_enable cxx stdcpp)
- ${myconf}
- --enable-atomics
- --with-pkg-config
- --enable-posix-timers
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- use doc && autotools-utils_src_compile doxy
-}
-
-src_install() {
- autotools-utils_src_install
- if use doc; then
- dohtml doc/html/*
- fi
-}